summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-08-06 15:24:37 +0000
committerTorsten Veller <tove@gentoo.org>2012-08-06 15:24:37 +0000
commitcefba5a2bd9c0b5a2f05599cd3d8a4963f46f5c5 (patch)
treefab60ac87ee3e5653ade0311b7f2c0b51f9cf4ee /perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild
parent[bump] virtual/perl-Compress-Raw-Zlib-2.55.0 (diff)
downloadgentoo-2-cefba5a2bd9c0b5a2f05599cd3d8a4963f46f5c5.tar.gz
gentoo-2-cefba5a2bd9c0b5a2f05599cd3d8a4963f46f5c5.tar.bz2
gentoo-2-cefba5a2bd9c0b5a2f05599cd3d8a4963f46f5c5.zip
[bump] perl-core/Compress-Raw-Zlib-2.55.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild
new file mode 100644
index 000000000000..21048b558cf2
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.55.0.ebuild,v 1.1 2012/08/06 15:24:37 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.055
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False \
+ ZLIB_INCLUDE="${EPREFIX}"/usr/include \
+ ZLIB_LIB="${EPREFIX}"/usr/$(get_libdir) \
+ perl-module_src_configure
+}