summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-06-16 08:35:40 +0000
committerTorsten Veller <tove@gentoo.org>2010-06-16 08:35:40 +0000
commit83f2bcd015875f0f4474ae1d7166540ff9836f42 (patch)
treeff324dbf859758165ae7160408c9d54b496c7f7f /perl-core
parentUpdated Spanish translation, fixes test failures (bug #323697) (diff)
downloadgentoo-2-83f2bcd015875f0f4474ae1d7166540ff9836f42.tar.gz
gentoo-2-83f2bcd015875f0f4474ae1d7166540ff9836f42.tar.bz2
gentoo-2-83f2bcd015875f0f4474ae1d7166540ff9836f42.zip
Don't install .packlist or perllocal.pod for perl or vendor
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ChangeLog9
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.56-r1.ebuild26
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch79
3 files changed, 113 insertions, 1 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ChangeLog b/perl-core/ExtUtils-MakeMaker/ChangeLog
index 7432450456b4..5c85d31dd245 100644
--- a/perl-core/ExtUtils-MakeMaker/ChangeLog
+++ b/perl-core/ExtUtils-MakeMaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for perl-core/ExtUtils-MakeMaker
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.15 2010/05/14 15:49:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ChangeLog,v 1.16 2010/06/16 08:35:40 tove Exp $
+
+*ExtUtils-MakeMaker-6.56-r1 (16 Jun 2010)
+
+ 16 Jun 2010; Torsten Veller <tove@gentoo.org>
+ +files/6.56-delete_packlist_podlocal.patch,
+ +ExtUtils-MakeMaker-6.56-r1.ebuild:
+ Don't install .packlist or perllocal.pod for perl or vendor
14 May 2010; Jeroen Roovers <jer@gentoo.org>
ExtUtils-MakeMaker-6.56.ebuild:
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.56-r1.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.56-r1.ebuild
new file mode 100644
index 000000000000..74a047fb852f
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.56-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.56-r1.ebuild,v 1.1 2010/06/16 08:35:40 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=MSCHWERN
+inherit perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/RUNPATH-6.54.patch
+ "${FILESDIR}"/6.56-delete_packlist_podlocal.patch )
+
+DEPEND=">=virtual/perl-ExtUtils-Manifest-1.56
+ >=virtual/perl-ExtUtils-Command-1.16
+ >=virtual/perl-ExtUtils-Install-1.52"
+RDEPEND="${DEPEND}
+ !!<dev-lang/perl-5.8.8-r7"
+
+SRC_TEST=do
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch
new file mode 100644
index 000000000000..c5763d16726a
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch
@@ -0,0 +1,79 @@
+Don't install .packlist or perllocal.pod for perl or vendor.
+Extracted from the debian patchset.
+See also bug #241834
+
+---
+ cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm | 25 +----------------------
+ 1 files changed, 1 insertions(+), 24 deletions(-)
+
+diff --git a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+index 239d6df..b4649ee 100644
+--- a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
++++ b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+@@ -2047,8 +2047,6 @@ doc__install : doc_site_install
+
+ pure_perl_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLPRIVLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLARCHLIB) \
+ $(INST_BIN) $(DESTINSTALLBIN) \
+@@ -2074,8 +2072,6 @@ pure_site_install :: all
+
+ pure_vendor_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLVENDORLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLVENDORARCH) \
+ $(INST_BIN) $(DESTINSTALLVENDORBIN) \
+@@ -2084,15 +2080,6 @@ pure_vendor_install :: all
+ $(INST_MAN3DIR) $(DESTINSTALLVENDORMAN3DIR)
+
+ doc_perl_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLPRIVLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_site_install :: all
+ $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+@@ -2106,15 +2093,6 @@ doc_site_install :: all
+ >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_vendor_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLVENDORLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ };
+
+@@ -2123,13 +2101,12 @@ uninstall :: uninstall_from_$(INSTALLDIRS)dirs
+ $(NOECHO) $(NOOP)
+
+ uninstall_from_perldirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_sitedirs ::
+ $(NOECHO) $(UNINSTALL) }.$self->catfile('$(SITEARCHEXP)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_vendordirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{
++
+ };
+
+ join("",@m);
+--
+tg: (b9ce030..) gentoo/MakeMaker-delete_packlist (depends on: upstream)