summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-21 19:30:33 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-21 19:30:33 +0000
commit970765b65e4e8c02d30164027d86c0d5b9e9cc34 (patch)
treeb92f2672a30eeb8689f1b784f5d4e2d15b926954 /perl-core
parent[bump] virtual/perl-Compress-Raw-Bzip2-2.49.0 (diff)
downloadgentoo-2-970765b65e4e8c02d30164027d86c0d5b9e9cc34.tar.gz
gentoo-2-970765b65e4e8c02d30164027d86c0d5b9e9cc34.tar.bz2
gentoo-2-970765b65e4e8c02d30164027d86c0d5b9e9cc34.zip
[bump] perl-core/Compress-Raw-Zlib-2.49.0
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog10
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.49.0.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index 97748223df0b..ba62f7dd4393 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.44 2011/11/23 17:29:15 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.45 2012/02/21 19:30:33 tove Exp $
+
+*Compress-Raw-Zlib-2.49.0 (21 Feb 2012)
+
+ 21 Feb 2012; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.49.0.ebuild:
+ Version bump
*Compress-Raw-Zlib-2.43.0 (23 Nov 2011)
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.49.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.49.0.ebuild
new file mode 100644
index 000000000000..449f8f48ef23
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.49.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.49.0.ebuild,v 1.1 2012/02/21 19:30:33 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.049
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False \
+ ZLIB_INCLUDE="${EPREFIX}"/usr/include \
+ ZLIB_LIB="${EPREFIX}"/usr/$(get_libdir) \
+ perl-module_src_configure
+}