summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-01-19 13:57:43 +0000
committerBen de Groot <yngwin@gentoo.org>2013-01-19 13:57:43 +0000
commit9c7b772868796cd0b3c40c332f9f55b9ae946cfe (patch)
tree672603116939eb7d9e0645771cc059f3fe53284a /razorqt-base/razorqt-notifications
parentRazor-qt 0.5.2 version bump (diff)
downloadgentoo-2-9c7b772868796cd0b3c40c332f9f55b9ae946cfe.tar.gz
gentoo-2-9c7b772868796cd0b3c40c332f9f55b9ae946cfe.tar.bz2
gentoo-2-9c7b772868796cd0b3c40c332f9f55b9ae946cfe.zip
Razor-qt 0.5.2 version bump
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'razorqt-base/razorqt-notifications')
-rw-r--r--razorqt-base/razorqt-notifications/ChangeLog8
-rw-r--r--razorqt-base/razorqt-notifications/razorqt-notifications-0.5.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/razorqt-base/razorqt-notifications/ChangeLog b/razorqt-base/razorqt-notifications/ChangeLog
index 950c4d37deef..18e108a40f9b 100644
--- a/razorqt-base/razorqt-notifications/ChangeLog
+++ b/razorqt-base/razorqt-notifications/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for razorqt-base/razorqt-notifications
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-notifications/ChangeLog,v 1.4 2013/01/17 07:13:56 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-notifications/ChangeLog,v 1.5 2013/01/19 13:57:43 yngwin Exp $
+
+*razorqt-notifications-0.5.2 (19 Jan 2013)
+
+ 19 Jan 2013; Ben de Groot <yngwin@gentoo.org>
+ +razorqt-notifications-0.5.2.ebuild:
+ Razor-qt 0.5.2 version bump
17 Jan 2013; Ben de Groot <yngwin@gentoo.org>
-razorqt-notifications-0.5.0.ebuild, razorqt-notifications-0.5.1.ebuild:
diff --git a/razorqt-base/razorqt-notifications/razorqt-notifications-0.5.2.ebuild b/razorqt-base/razorqt-notifications/razorqt-notifications-0.5.2.ebuild
new file mode 100644
index 000000000000..a92ce01e6f73
--- /dev/null
+++ b/razorqt-base/razorqt-notifications/razorqt-notifications-0.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-notifications/razorqt-notifications-0.5.2.ebuild,v 1.1 2013/01/19 13:57:43 yngwin Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="Razor-qt notification daemon"
+HOMEPAGE="http://razor-qt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Razor-qt/razor-qt.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.razor-qt.org/downloads/files/razorqt-${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/razorqt-${PV}"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+DEPEND="razorqt-base/razorqt-libs"
+RDEPEND="${DEPEND}
+ razorqt-base/razorqt-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPLIT_BUILD=On
+ -DMODULE_NOTIFICATIOND=On
+ )
+ cmake-utils_src_configure
+}