summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-06-12 15:19:26 +0000
committerJim Ramsay <lack@gentoo.org>2007-06-12 15:19:26 +0000
commit43d07721356bcbcecb8917fe592832b4e2e1fd12 (patch)
tree2e9741afc29442cce5376a1ab62b74d9a3c52234 /rox-base/rox
parentKeyworded ~sparc wrt #180969 (diff)
downloadgentoo-2-43d07721356bcbcecb8917fe592832b4e2e1fd12.tar.gz
gentoo-2-43d07721356bcbcecb8917fe592832b4e2e1fd12.tar.bz2
gentoo-2-43d07721356bcbcecb8917fe592832b4e2e1fd12.zip
Version bump - 2.6.1 is released
(Portage version: 2.1.2.8)
Diffstat (limited to 'rox-base/rox')
-rw-r--r--rox-base/rox/ChangeLog8
-rw-r--r--rox-base/rox/files/digest-rox-2.6.13
-rw-r--r--rox-base/rox/files/rox-2.6.1-nostrip.patch20
-rw-r--r--rox-base/rox/rox-2.6.1.ebuild124
4 files changed, 154 insertions, 1 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index 2fd4e1586551..7dbc04caaaee 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.39 2007/04/25 21:21:43 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.40 2007/06/12 15:19:26 lack Exp $
+
+*rox-2.6.1 (12 Jun 2007)
+
+ 12 Jun 2007; Jim Ramsay <lack@gentoo.org> +files/rox-2.6.1-nostrip.patch,
+ +rox-2.6.1.ebuild:
+ Version bump - 2.6.1 is released
25 Apr 2007; Jim Ramsay <lack@gentoo.org> -rox-2.3.ebuild,
-rox-2.5.ebuild, -rox-2.5-r1.ebuild:
diff --git a/rox-base/rox/files/digest-rox-2.6.1 b/rox-base/rox/files/digest-rox-2.6.1
new file mode 100644
index 000000000000..1d387683eae4
--- /dev/null
+++ b/rox-base/rox/files/digest-rox-2.6.1
@@ -0,0 +1,3 @@
+MD5 e7f7b0b8afbbdf3132ff3af043ee213c rox-filer-2.6.1.tar.bz2 1816711
+RMD160 94a3320883c49066072d44f25f417e20739711ca rox-filer-2.6.1.tar.bz2 1816711
+SHA256 e7efefbfa8e37ba7263771bdfd0b16c9f4b47b09d301b82616012ad53eb03e02 rox-filer-2.6.1.tar.bz2 1816711
diff --git a/rox-base/rox/files/rox-2.6.1-nostrip.patch b/rox-base/rox/files/rox-2.6.1-nostrip.patch
new file mode 100644
index 000000000000..2a63ce73f160
--- /dev/null
+++ b/rox-base/rox/files/rox-2.6.1-nostrip.patch
@@ -0,0 +1,20 @@
+Index: ROX-Filer/src/Makefile.in
+===================================================================
+--- ROX-Filer/src/Makefile.in (revision 4834)
++++ ROX-Filer/src/Makefile.in (working copy)
+@@ -51,10 +51,12 @@
+ ${PROG}: ${OBJECTS}
+ ${CC} -o "${PROG}" ${OBJECTS} ${LDFLAGS}
+ mv "${PROG}" "${PLATFORM_DIR}"
++
++${PROG}.dbg: ${PROG}
+ -(cd "${PLATFORM_DIR}" && \
+- objcopy --only-keep-debug ROX-Filer ROX-Filer.dbg && \
+- strip ROX-Filer && \
+- objcopy --add-gnu-debuglink=ROX-Filer.dbg ROX-Filer)
++ objcopy --only-keep-debug ${PROG} ${PROG}.dbg && \
++ strip ${PROG} && \
++ objcopy --add-gnu-debuglink=${PROG}.dbg ${PROG})
+
+ clean:
+ rm -f *.o Makefile.bak
diff --git a/rox-base/rox/rox-2.6.1.ebuild b/rox-base/rox/rox-2.6.1.ebuild
new file mode 100644
index 000000000000..7e7f75ba95aa
--- /dev/null
+++ b/rox-base/rox/rox-2.6.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.6.1.ebuild,v 1.1 2007/06/12 15:19:26 lack Exp $
+
+inherit eutils multilib
+
+MY_P="rox-filer-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="svg"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.2
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
+ svg? ( gnome-base/librsvg )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+APPNAME="ROX-Filer"
+APPDIR="/usr/$(get_libdir)/rox"
+LIBDIR="/usr/$(get_libdir)/"
+WRAPPERNAME="rox"
+MIMEDIR="/usr/share/mime"
+MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-nostrip.patch
+}
+
+src_compile() {
+
+ cd ${APPNAME}
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "make failed"
+ (cd src; make clean) > /dev/null
+ # don't need these directories anymore
+ if [ -n "${KEEP_SRC}" ]; then
+ (cd src; make clean) > /dev/null
+ else
+ rm -rf src
+ fi
+ rm -fr build
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
+}
+
+# new streamlined install
+
+src_install() {
+ doman rox.1
+
+ dodir ${APPDIR}
+ cp -r ${APPNAME}/ ${D}/${APPDIR}
+
+ # add documentation to be proper
+ ( cd ${APPNAME}/Help
+ dodoc Changes COPYING README README-es TODO
+ )
+
+ # install shell script
+ dodir /usr/bin
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
+#!/bin/sh
+if [[ "\${LIBDIRPATH}" ]]; then
+ export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
+else
+ export LIBDIRPATH="${LIBDIR}"
+fi
+
+if [[ "\${APPDIRPATH}" ]]; then
+ export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
+else
+ export APPDIRPATH="${APPDIR}"
+fi
+exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
+EOF
+
+ cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
+#!/bin/sh
+exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
+EOF
+
+ chmod 0755 ${D}/usr/bin/${WRAPPERNAME}
+ chmod 0755 ${D}/usr/bin/${WRAPPERNAME}uri
+
+ # install rox.xml
+ insinto ${MIMEDIR}/packages
+ doins rox.xml
+
+ # CHOICES system is gone. Now use XDG only
+ # these are shell scripts and must be +x.
+ exeinto ${MIMECONFDIR}/MIME-types
+ doexe Choices/MIME-types/*
+
+ insinto /usr/share/pixmaps
+ newins ${APPNAME}/.DirIcon ${APPNAME}.png
+
+ make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME}.png "System;Utility;Core;ROX"
+}
+
+pkg_postinst() {
+ update-mime-database ${MIMEDIR}
+ einfo "${APPNAME} has been installed in ${APPDIR}."
+ einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
+ einfo "add it to an .xinit or other script during WM startup."
+}