summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-07-12 17:16:41 +0000
committerJim Ramsay <lack@gentoo.org>2007-07-12 17:16:41 +0000
commit09a19bf781c5bb360173c0ab393b80fd9beb127a (patch)
treed1016f058741db608a75212afa31760ecfadfdbd /rox-extra
parentStable for HPPA (bug #184029). (diff)
downloadgentoo-2-09a19bf781c5bb360173c0ab393b80fd9beb127a.tar.gz
gentoo-2-09a19bf781c5bb360173c0ab393b80fd9beb127a.tar.bz2
gentoo-2-09a19bf781c5bb360173c0ab393b80fd9beb127a.zip
Removing flac USE flag, until we become compatible with flac-1.1.3 (bug 181864)
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'rox-extra')
-rw-r--r--rox-extra/musicbox/ChangeLog7
-rw-r--r--rox-extra/musicbox/files/digest-musicbox-027-r23
-rw-r--r--rox-extra/musicbox/musicbox-027-r2.ebuild66
3 files changed, 75 insertions, 1 deletions
diff --git a/rox-extra/musicbox/ChangeLog b/rox-extra/musicbox/ChangeLog
index 2b9ed584b8bb..77fb2254a0c1 100644
--- a/rox-extra/musicbox/ChangeLog
+++ b/rox-extra/musicbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for rox-extra/musicbox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/ChangeLog,v 1.7 2007/01/31 00:10:58 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/ChangeLog,v 1.8 2007/07/12 17:16:41 lack Exp $
+
+*musicbox-027-r2 (12 Jul 2007)
+
+ 12 Jul 2007; Jim Ramsay <lack@gentoo.org> +musicbox-027-r2.ebuild:
+ Removing flac USE flag, until we become compatible with flac-1.1.3 (bug 181864)
*musicbox-027-r1 (31 Jan 2007)
diff --git a/rox-extra/musicbox/files/digest-musicbox-027-r2 b/rox-extra/musicbox/files/digest-musicbox-027-r2
new file mode 100644
index 000000000000..b79e1e22ebf5
--- /dev/null
+++ b/rox-extra/musicbox/files/digest-musicbox-027-r2
@@ -0,0 +1,3 @@
+MD5 ebeeab6c35362856314138a6e3638de8 MusicBox-027.tgz 110634
+RMD160 c6cfbc09b0fbdafd3677f6de391bd20878e5d330 MusicBox-027.tgz 110634
+SHA256 a1a4897ec42f10cfcaaf59990212fe68a83744d5938473d0e560b6c608fd0015 MusicBox-027.tgz 110634
diff --git a/rox-extra/musicbox/musicbox-027-r2.ebuild b/rox-extra/musicbox/musicbox-027-r2.ebuild
new file mode 100644
index 000000000000..4892eb2ff373
--- /dev/null
+++ b/rox-extra/musicbox/musicbox-027-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/musicbox-027-r2.ebuild,v 1.1 2007/07/12 17:16:41 lack Exp $
+
+ROX_LIB_VER=2.0.0
+inherit rox eutils
+
+DESCRIPTION="MusicBox - an MP3/OGG Player for the ROX Desktop"
+HOMEPAGE="http://www.hayber.us/rox/MusicBox/"
+SRC_URI="http://www.hayber.us/rox/musicbox/MusicBox-027.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mp3 vorbis alsa"
+
+# NOTE: flac support is removed because it requires 1.1.2, and 1.1.3 is now
+# being unmasked. See bug 181864 for more info.
+
+DEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )"
+# flac? (
+# ~media-libs/flac-1.1.2
+# >=dev-lang/swig-1.3.25 )"
+
+RDEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )"
+# flac? ( ~media-libs/flac-1.1.2 )"
+
+APPNAME=MusicBox
+APPCATEGORY="AudioVideo;Audio;Player"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# if use flac; then
+# if ! built_with_use dev-lang/swig python; then
+# einfo "MusicBox flac support requires swig with python support."
+# einfo "Please rebuild swig with USE=\"python\"."
+# die "swig python support missing"
+# fi
+# epatch ${FILESDIR}/${P}-fPIC.patch
+# fi
+ epatch ${FILESDIR}/${P}-mime.patch
+}
+
+# Special compilation needed for flac support
+src_compile() {
+# if use flac; then
+# cd "${S}/${APPNAME}/plugins/flac"
+# make || die "flac plugin compile failed."
+# fi
+ rox_src_compile
+}
+