summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-12 17:04:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-12 17:04:35 +0000
commit434e63cab77798fc3d2fde52d46f548de888760d (patch)
treec03bcf36c6f90f9434c65116a08430a155882fd5 /sci-astronomy/celestia
parentDon't rebuild SQLite in src_install(). (diff)
downloadgentoo-2-434e63cab77798fc3d2fde52d46f548de888760d.tar.gz
gentoo-2-434e63cab77798fc3d2fde52d46f548de888760d.tar.bz2
gentoo-2-434e63cab77798fc3d2fde52d46f548de888760d.zip
Version bump. Fixed a few unicode guide (bug #271613), kde deps (bug
#254010). The lua script engine is now mandatory (might be an upstream bug). Closing also bug #278469, thanks Juan Aguado for his work. (Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/ChangeLog11
-rw-r--r--sci-astronomy/celestia/celestia-1.5.1.ebuild12
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild124
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-as-needed.patch25
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch11
5 files changed, 179 insertions, 4 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 2d7d7291e6cc..9fb77271d78d 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.50 2009/05/24 09:40:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.51 2009/08/12 17:04:35 bicatali Exp $
+
+*celestia-1.6.0 (21 Jul 2009)
+
+ 21 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ celestia-1.5.1.ebuild, +celestia-1.6.0.ebuild,
+ +files/celestia-1.6.0-cfg.patch:
+ Version bump. Fixed a few unicode guide (bug #271613), kde deps (bug
+ #254010). The lua script engine is now mandatory (might be an upstream
+ bug). Closing also bug #278469, thanks Juan Aguado for his work.
24 May 2009; Samuli Suominen <ssuominen@gentoo.org>
-celestia-1.4.1-r2.ebuild, -files/celestia-1.4.1-3dsmodels.patch,
diff --git a/sci-astronomy/celestia/celestia-1.5.1.ebuild b/sci-astronomy/celestia/celestia-1.5.1.ebuild
index 1248e81e182e..a3eed1cb7fc0 100644
--- a/sci-astronomy/celestia/celestia-1.5.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.10 2009/05/24 09:40:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.5.1.ebuild,v 1.11 2009/08/12 17:04:35 bicatali Exp $
EAPI=1
inherit eutils flag-o-matic gnome2 kde-functions autotools
@@ -23,11 +23,11 @@ RDEPEND="virtual/glu
>=x11-libs/gtk+-2.6
>=x11-libs/gtkglext-1.0
) ) )
- gnome? ( !kde? (
+ gnome? (
>=x11-libs/gtk+-2.6
>=x11-libs/gtkglext-1.0
>=gnome-base/libgnomeui-2.0
- ) )
+ )
kde? ( !gnome? ( kde-base/kdelibs:3.5 ) )
!gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
arts? ( kde-base/arts )
@@ -112,6 +112,12 @@ src_unpack() {
iconv -f iso-8859-1 ${i} -t utf8 > ${i}.utf8
mv ${i}.utf8 ${i}
done
+ iconv -f iso-8859-1 -t utf8 start_de.cel > start_de.cel.utf8
+ iconv -f cp1251 -t utf8 guide_ru.cel > guide_ru.cel.utf8
+ iconv -f SHIFT-JIS -t utf8 guide_ja.cel > guide_ja.cel.utf8
+ mv start_de.cel.utf8 start_de.cel
+ mv guide_ru.cel.utf8 guide_ru.cel
+ mv guide_ja.cel.utf8 guide_ja.cel
popd > /dev/null
fi
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
new file mode 100644
index 000000000000..85dee3986b6b
--- /dev/null
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.1 2009/08/12 17:04:35 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic gnome2 kde-functions autotools
+
+DESCRIPTION="OpenGL 3D space simulator"
+HOMEPAGE="http://www.shatters.net/celestia/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts cairo gnome gtk kde nls pch theora threads"
+
+RDEPEND="virtual/glu
+ media-libs/jpeg
+ media-libs/libpng
+ >=dev-lang/lua-5.0
+ gtk? ( !gnome? ( !kde? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ ) ) )
+ gnome? (
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0
+ >=gnome-base/libgnomeui-2.0
+ )
+ kde? ( !gnome? ( kde-base/kdelibs:3.5 ) )
+ !gtk? ( !gnome? ( !kde? ( virtual/glut ) ) )
+ arts? ( kde-base/arts )
+ cairo? ( x11-libs/cairo )
+ theora? ( media-libs/libtheora )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # Check for one for the following use flags to be set.
+ if ! use gnome && use kde; then
+ einfo "USE=\"kde\" detected."
+ CELESTIA_GUI="kde"
+ elif ! use kde && use gnome; then
+ einfo "USE=\"gnome\" detected."
+ USE_DESTDIR="1"
+ CELESTIA_GUI="gnome"
+ elif ! use kde && ! use gnome && use gtk; then
+ einfo "USE=\"gtk\" detected."
+ CELESTIA_GUI="gtk"
+ elif use kde && use gnome; then
+ einfo "Both gnome and kde support requested. Defaulting to kde"
+ CELESTIA_GUI="kde"
+ else
+ ewarn "If you want to use the full gui, set USE=\"{kde|gnome|gtk}\""
+ ewarn "Defaulting to glut support (no GUI)."
+ CELESTIA_GUI="glut"
+ fi
+}
+
+src_prepare() {
+ # make better desktop files
+ epatch "${FILESDIR}"/${PN}-1.5.0-desktop.patch
+ # add a ~/.celestia for extra directories
+ epatch "${FILESDIR}"/${P}-cfg.patch
+ # as-needed forces to reorganize some files
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ # missing includes with gcc 4.4
+ epatch "${FILESDIR}"/${PN}-1.5.1-gcc44.patch
+ # remove flags to let the user decide
+ for cf in -O2 -ffast-math \
+ -fexpensive-optimizations \
+ -fomit-frame-pointer; do
+ sed -i \
+ -e "s/${cf}//g" \
+ configure.in admin/* || die "sed failed"
+ done
+ # remove an unused gconf macro killing autoconf when no gnome
+ # (not needed without eautoreconf)
+ if ! use gnome; then
+ sed -i \
+ -e '/AM_GCONF_SOURCE_2/d' \
+ configure.in || die "sed failed"
+ fi
+ eautoreconf
+ if [[ ${CELESTIA_GUI} == kde ]]; then
+ REALHOME="${HOME}"
+ mkdir -p "${T}"/fakehome/.kde
+ mkdir -p "${T}"/fakehome/.qt
+ export HOME="${T}"/fakehome
+ [[ -d ${REALHOME}/.ccache ]] && ln -sf "${REALHOME}/.ccache" "${HOME}/"
+ set-kdedir 3
+ export kde_widgetdir="${KDEDIR}/lib/kde3/plugins/designer"
+ fi
+ filter-flags "-funroll-loops -frerun-loop-opt"
+}
+
+src_configure() {
+ # force lua in 1.6.0. seems to be inevitable
+ econf \
+ --disable-rpath \
+ --with-lua \
+ --with-${CELESTIA_GUI} \
+ $(use_with arts) \
+ $(use_enable cairo) \
+ $(use_enable threads threading) \
+ $(use_enable nls) \
+ $(use_enable pch) \
+ $(use_enable theora)
+}
+
+src_install() {
+ if [[ ${CELESTIA_GUI} == gnome ]]; then
+ gnome2_src_install
+ else
+ emake DESTDIR="${D}" install || die "emake install failed"
+ for size in 16 22 32 48 ; do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins "${S}"/src/celestia/kde/data/hi${size}-app-${PN}.png ${PN}.png
+ done
+ fi
+ [[ ${CELESTIA_GUI} == glut ]] && domenu celestia.desktop
+ dodoc AUTHORS README TRANSLATORS *.txt || die
+}
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-as-needed.patch b/sci-astronomy/celestia/files/celestia-1.6.0-as-needed.patch
new file mode 100644
index 000000000000..81f828902477
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-as-needed.patch
@@ -0,0 +1,25 @@
+--- src/celengine/Makefile.am.orig 2009-08-12 17:54:12.000000000 +0100
++++ src/celengine/Makefile.am 2009-08-12 17:54:28.000000000 +0100
+@@ -25,8 +25,6 @@
+ body.cpp \
+ boundaries.cpp \
+ catalogxref.cpp \
+- cmdparser.cpp \
+- command.cpp \
+ console.cpp \
+ constellation.cpp \
+ customorbit.cpp \
+--- src/celestia/Makefile.am.orig 2009-08-12 17:53:30.000000000 +0100
++++ src/celestia/Makefile.am 2009-08-12 17:54:56.000000000 +0100
+@@ -24,7 +24,10 @@
+ eclipsefinder.cpp\
+ favorites.cpp \
+ imagecapture.cpp \
+- url.cpp
++ url.cpp \
++ ../celengine/cmdparser.cpp \
++ ../celengine/command.cpp
++
+
+ WINSOURCES = \
+ avicapture.cpp \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch b/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
new file mode 100644
index 000000000000..8a4c18143a95
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.0-cfg.patch
@@ -0,0 +1,11 @@
+--- celestia.cfg.orig 2009-07-20 12:52:17.000000000 +0200
++++ celestia.cfg 2009-07-20 12:52:43.000000000 +0200
+@@ -195,7 +195,7 @@
+ # or
+ # ExtrasDirectories [ "D:\\celestia-extras" ]
+ #------------------------------------------------------------------------
+- ExtrasDirectories [ "extras-standard" "extras" ]
++ ExtrasDirectories [ "extras-standard" "extras" "~/.celestia" ]
+
+
+ #------------------------------------------------------------------------