summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-01-31 05:16:35 +0000
committerDaniel Goller <morfic@gentoo.org>2006-01-31 05:16:35 +0000
commitacb1021ebd5b4d48d1871d48c27b1b49a311fbfa (patch)
treeada4464f39dc336cf91f9d0f23b0f0b358786c52 /sci-astronomy/celestia
parentStable on x86 for security bug #83542 (diff)
downloadgentoo-2-acb1021ebd5b4d48d1871d48c27b1b49a311fbfa.tar.gz
gentoo-2-acb1021ebd5b4d48d1871d48c27b1b49a311fbfa.tar.bz2
gentoo-2-acb1021ebd5b4d48d1871d48c27b1b49a311fbfa.zip
Work around gnome eclass writing files to /var/tmp/portage/*
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-astronomy/celestia')
-rw-r--r--sci-astronomy/celestia/ChangeLog5
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 890ae436a2d2..42c87f6d158a 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.8 2006/01/19 07:31:12 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.9 2006/01/31 05:16:35 morfic Exp $
+
+ 31 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
+ Work around gnome eclass writing files to /var/tmp/portage/*
19 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
Fixing bug #119339 while taking care of access violations
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 27b35598a3b5..bc1180e66207 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.4 2006/01/19 07:31:12 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.5 2006/01/31 05:16:35 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -82,8 +82,10 @@ src_compile() {
|| die "econf failed"
#fix Makefiles to avoid Access Violations while fixing bug #119339
+ if ! use gnome ; then
for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
+ fi
emake || die "emake failed"
}