summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-03-04 00:30:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-03-04 00:30:02 +0000
commit67b1c0c293f6413485765a7aba14bfa5e396721a (patch)
tree8d9db5aae3a7c24b4f152a54c6b96873e6cd0369 /sci-astronomy/gasgano
parentFix building against sys-libs/readline-6.3 (bug #503314 by eroen). (diff)
downloadgentoo-2-67b1c0c293f6413485765a7aba14bfa5e396721a.tar.gz
gentoo-2-67b1c0c293f6413485765a7aba14bfa5e396721a.tar.bz2
gentoo-2-67b1c0c293f6413485765a7aba14bfa5e396721a.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy/gasgano')
-rw-r--r--sci-astronomy/gasgano/ChangeLog9
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.5.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-astronomy/gasgano/ChangeLog b/sci-astronomy/gasgano/ChangeLog
index 0b837810ebe3..e4060e085e84 100644
--- a/sci-astronomy/gasgano/ChangeLog
+++ b/sci-astronomy/gasgano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/gasgano
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.9 2012/12/07 17:14:23 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.10 2014/03/04 00:30:02 bicatali Exp $
+
+*gasgano-2.4.5 (04 Mar 2014)
+
+ 04 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> +gasgano-2.4.5.ebuild:
+ Version bump
*gasgano-2.4.3-r2 (07 Dec 2012)
diff --git a/sci-astronomy/gasgano/gasgano-2.4.5.ebuild b/sci-astronomy/gasgano/gasgano-2.4.5.ebuild
new file mode 100644
index 000000000000..12e89e6776be
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/gasgano-2.4.5.ebuild,v 1.1 2014/03/04 00:30:02 bicatali Exp $
+
+EAPI=4
+inherit eutils java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND="
+ >=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e 's:$BASE/share/:$BASE/lib/:g' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+}