summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-17 20:54:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-17 20:54:23 +0000
commit02990118ab91b0a97ceb0811015238f37c3f5f63 (patch)
tree349134f4455c12e945f5d7324af7f595731e91d5 /sci-astronomy/swarp
parentInitial import to the main tree from the sci overlay (diff)
downloadgentoo-2-02990118ab91b0a97ceb0811015238f37c3f5f63.tar.gz
gentoo-2-02990118ab91b0a97ceb0811015238f37c3f5f63.tar.bz2
gentoo-2-02990118ab91b0a97ceb0811015238f37c3f5f63.zip
Initial import to the main tree from the sci overlay, closing bug #65684
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/swarp')
-rw-r--r--sci-astronomy/swarp/ChangeLog33
-rw-r--r--sci-astronomy/swarp/metadata.xml9
-rw-r--r--sci-astronomy/swarp/swarp-2.17.1.ebuild36
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/ChangeLog b/sci-astronomy/swarp/ChangeLog
new file mode 100644
index 000000000000..ce965dd46179
--- /dev/null
+++ b/sci-astronomy/swarp/ChangeLog
@@ -0,0 +1,33 @@
+# ChangeLog for sci-astronomy/swarp
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.1 2009/02/17 20:54:23 bicatali Exp $
+
+*swarp-2.17.1 (17 Feb 2009)
+
+ 17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +swarp-2.17.1.ebuild:
+ Initial import to the main tree from the sci overlay, closing bug #65684
+
+ 14 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> -swarp-2.17.0.ebuild,
+ +swarp-2.17.1.ebuild:
+ Version bump
+
+ 09 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> +swarp-2.17.0.ebuild:
+ Version bump
+
+ 01 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ -swarp-2.16.0-r1.ebuild, +swarp-2.16.4.ebuild:
+ Version bump
+
+ 26 Mar 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ swarp-2.16.0-r1.ebuild:
+ cleaning
+
+ 29 Dec 2006; Sebastien Fabbro <seb@ist.utl.pt>;
+ Removed icc flag, too buggy.
+
+ 15 Oct 2006; Sebastien Fabbro <seb@ist.utl.pt> swarp-2.16.0-r1.ebuild
+ Removed flag filtering. Some cleaning.
+
+ 10 Sep 2006; Sebastien Fabbro <seb@ist.utl.pt> swarp-2.16.0.ebuild
+ Initial import.
diff --git a/sci-astronomy/swarp/metadata.xml b/sci-astronomy/swarp/metadata.xml
new file mode 100644
index 000000000000..80eb84dd5827
--- /dev/null
+++ b/sci-astronomy/swarp/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ SWarp takes astronomical FITS images with a WCS-like projection,
+ resample and stack them all.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/swarp/swarp-2.17.1.ebuild b/sci-astronomy/swarp/swarp-2.17.1.ebuild
new file mode 100644
index 000000000000..f37f3d5c16db
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/swarp-2.17.1.ebuild,v 1.1 2009/02/17 20:54:23 bicatali Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://terapix.iap.fr/soft/swarp"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads mpi"
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ use mpi || export MPICC="$(tc-getCC)"
+ local myconf
+ # --disable-threads is buggy
+ use threads && myconf="--enable-threads"
+ econf \
+ $(use_enable mpi) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/* || die
+ fi
+}