summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-10 19:18:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-10 19:18:20 +0000
commit9bebec92224744d96a4dd8bb3fb903447907cf0d (patch)
treecefcc158dc8c82ab0e7591ee00c2b0723af5eb75 /sci-astronomy
parentEnable multilib support, bug #493176. (diff)
downloadgentoo-2-9bebec92224744d96a4dd8bb3fb903447907cf0d.tar.gz
gentoo-2-9bebec92224744d96a4dd8bb3fb903447907cf0d.tar.bz2
gentoo-2-9bebec92224744d96a4dd8bb3fb903447907cf0d.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog7
-rw-r--r--sci-astronomy/cpl/cpl-6.4.2.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index 06482d5e966e..446a936325b8 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/cpl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.16 2014/04/04 15:51:03 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.17 2014/06/10 19:18:20 bicatali Exp $
+
+*cpl-6.4.2 (10 Jun 2014)
+
+ 10 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> +cpl-6.4.2.ebuild:
+ Version bump
*cpl-6.4.1 (04 Apr 2014)
diff --git a/sci-astronomy/cpl/cpl-6.4.2.ebuild b/sci-astronomy/cpl/cpl-6.4.2.ebuild
new file mode 100644
index 000000000000..4d2ccb8575fb
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-6.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.4.2.ebuild,v 1.1 2014/06/10 19:18:20 bicatali Exp $
+
+EAPI=5
+
+JAVA_PKG_OPT_USE=gasgano
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils java-pkg-opt-2 autotools-utils
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/20"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND="
+ sci-astronomy/wcslib:0=
+ >=sci-libs/cfitsio-3.310:0=
+ sci-libs/fftw:3.0=
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.1-check-shared-libs.patch
+ "${FILESDIR}"/${PN}-6.1.1-use-system-ltdl.patch
+)
+
+src_prepare() {
+ # bug 422455 and remove cpu chcking
+ sed -i \
+ -e '/AM_C_PROTOTYPES/d' \
+ -e '/CPL_CHECK_CPU/d' \
+ configure.ac libcext/configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-ltdl-install
+ --without-included-ltdl
+ --with-cfitsio="${EPREFIX}/usr"
+ --with-wcs="${EPREFIX}/usr"
+ --with-fftw="${EPREFIX}/usr"
+ $(use_enable doc maintainer-mode)
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo html)
+}
+
+src_install() {
+ autotools-utils_src_install all $(use doc && echo install-html)
+}