summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 21:20:03 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 21:20:03 +0000
commit1bcd45d4d86c3e6797bb12a44c52892f1fedd2f9 (patch)
tree12aeb5cb52b49515e97529034512aeb96cca26d2 /sci-biology/last
parentsci-biology/prank: Fix compilation with gcc-4.7, #422581 (diff)
downloadgentoo-2-1bcd45d4d86c3e6797bb12a44c52892f1fedd2f9.tar.gz
gentoo-2-1bcd45d4d86c3e6797bb12a44c52892f1fedd2f9.tar.bz2
gentoo-2-1bcd45d4d86c3e6797bb12a44c52892f1fedd2f9.zip
sci-biology/last: Version BUmp, allows to compile with gcc-4.7, #422573
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/ChangeLog7
-rw-r--r--sci-biology/last/last-230.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 7d4eba45ac70..fa82107032e5 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.19 2012/02/10 18:01:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.20 2012/06/20 21:20:03 jlec Exp $
+
+*last-230 (20 Jun 2012)
+
+ 20 Jun 2012; Justin Lecher <jlec@gentoo.org> +last-230.ebuild:
+ Version BUmp, allows to compile with gcc-4.7, #422573
*last-192 (10 Feb 2012)
diff --git a/sci-biology/last/last-230.ebuild b/sci-biology/last/last-230.ebuild
new file mode 100644
index 000000000000..0abbb611883e
--- /dev/null
+++ b/sci-biology/last/last-230.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-230.ebuild,v 1.1 2012/06/20 21:20:03 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake \
+ -e -C src \
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ STRICT="" || die
+}
+
+src_install() {
+ dobin src/last{al,db,ex}
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ dodoc doc/*.txt ChangeLog.txt README.txt
+}