summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-08-17 03:00:14 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-08-17 03:00:14 +0000
commit03caf9c25db923fb7b133d533c3ffdfa882d71f6 (patch)
tree022aa0cb8d698daf4a50196a9401cf22a3496c96 /sci-biology/rebase
parentuse the qt3 eclass (diff)
downloadgentoo-2-03caf9c25db923fb7b133d533c3ffdfa882d71f6.tar.gz
gentoo-2-03caf9c25db923fb7b133d533c3ffdfa882d71f6.tar.bz2
gentoo-2-03caf9c25db923fb7b133d533c3ffdfa882d71f6.zip
New upstream version
(Portage version: 2.1-r2)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog7
-rw-r--r--sci-biology/rebase/files/digest-rebase-6083
-rw-r--r--sci-biology/rebase/rebase-608.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 3967977e7bb6..5121c66dce23 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.67 2006/07/12 01:22:20 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.68 2006/08/17 03:00:14 ribosome Exp $
+
+*rebase-608 (17 Aug 2006)
+
+ 17 Aug 2006; Olivier Fisette <ribosome@gentoo.org> +rebase-608.ebuild:
+ New upstream version.
*rebase-607 (12 Jul 2006)
diff --git a/sci-biology/rebase/files/digest-rebase-608 b/sci-biology/rebase/files/digest-rebase-608
new file mode 100644
index 000000000000..551b749a06eb
--- /dev/null
+++ b/sci-biology/rebase/files/digest-rebase-608
@@ -0,0 +1,3 @@
+MD5 1d84581da57e1b8ebd8081ee69d506b9 rebase-608.tar.bz2 184005
+RMD160 1bc2d4f3af896ba05119a38fa99d40a9634419e6 rebase-608.tar.bz2 184005
+SHA256 4ed73c49f51972787cac53380fbc2e82aae3e8eab14799897a4f49a8a93192c0 rebase-608.tar.bz2 184005
diff --git a/sci-biology/rebase/rebase-608.ebuild b/sci-biology/rebase/rebase-608.ebuild
new file mode 100644
index 000000000000..3d959728b6a8
--- /dev/null
+++ b/sci-biology/rebase/rebase-608.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-608.ebuild,v 1.1 2006/08/17 03:00:14 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos ~ppc64"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0-r1 )"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins embossre.equ || die "Failed to install enzyme prototypes file."
+ fi
+}