summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 11:11:56 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 11:11:56 +0000
commitfba5f9fc74d456ef2809c1c247f6bfb3eb11f018 (patch)
tree8c8c9689d9a3ca591e6312a768b8f355132f242a /sci-biology/t-coffee
parentRe-add ~ia64/~sparc wrt #338013 (diff)
downloadgentoo-2-fba5f9fc74d456ef2809c1c247f6bfb3eb11f018.tar.gz
gentoo-2-fba5f9fc74d456ef2809c1c247f6bfb3eb11f018.tar.bz2
gentoo-2-fba5f9fc74d456ef2809c1c247f6bfb3eb11f018.zip
Version Bump, 338199
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog7
-rw-r--r--sci-biology/t-coffee/t-coffee-8.93.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index c193d433bd28..5394cbb39124 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.42 2010/06/18 07:55:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.43 2010/10/03 11:11:56 jlec Exp $
+
+*t-coffee-8.93 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org> +t-coffee-8.93.ebuild:
+ Version Bump, 338199
18 Jun 2010; Justin Lecher <jlec@gentoo.org> t-coffee-8.69.ebuild:
Fix installation, #324307
diff --git a/sci-biology/t-coffee/t-coffee-8.93.ebuild b/sci-biology/t-coffee/t-coffee-8.93.ebuild
new file mode 100644
index 000000000000..90a0f33bc8c9
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-8.93.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-8.93.ebuild,v 1.1 2010/10/03 11:11:56 jlec Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A multiple sequence alignment package"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sci-biology/clustalw"
+DEPEND="${DEPEND}
+ test? ( dev-lang/perl )"
+
+S="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/8.69-flags.patch
+ epatch "${FILESDIR}"/8.69-test.patch
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
+ [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
+ emake \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ -C t_coffee_source || die_compile
+}
+
+src_test() {
+ cd "${TCDIR}"
+ perl bin/test.pl || die
+}
+
+src_install() {
+ dobin t_coffee_source/t_coffee || die "Failed to install program."
+
+# insinto /usr/share/${PN}/lib/html
+# doins html/* || die "Failed to install Web interface files."
+
+ dodoc doc/*.txt || die "Failed to install text documentation."
+ dohtml doc/*.htm || die "Failed to install HTML documentation."
+
+ insinto /usr/share/doc/${PF}
+ doins doc/*.doc || die "Failed to install DOC documentation."
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r example || die "Failed to install example files."
+ fi
+}