summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-20 00:34:24 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-20 00:34:24 +0000
commite1c03bb80b5c8890291a5eaedb8faeefbe195c40 (patch)
treec70cf67c2e1d66977a12bf6f23b9ded767adbf2c /sci-biology/velvet/velvet-0.7.55.ebuild
parent19 Sep 2009; Zac Medico <zmedico@gentoo.org> +portage-2.2_rc41.ebuild: (diff)
downloadgentoo-2-e1c03bb80b5c8890291a5eaedb8faeefbe195c40.tar.gz
gentoo-2-e1c03bb80b5c8890291a5eaedb8faeefbe195c40.tar.bz2
gentoo-2-e1c03bb80b5c8890291a5eaedb8faeefbe195c40.zip
Add support for passing compile-time variables to build
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/velvet/velvet-0.7.55.ebuild')
-rw-r--r--sci-biology/velvet/velvet-0.7.55.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-biology/velvet/velvet-0.7.55.ebuild b/sci-biology/velvet/velvet-0.7.55.ebuild
index ed683d3562ff..d5f152c673be 100644
--- a/sci-biology/velvet/velvet-0.7.55.ebuild
+++ b/sci-biology/velvet/velvet-0.7.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/velvet/velvet-0.7.55.ebuild,v 1.1 2009/09/19 23:25:41 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/velvet/velvet-0.7.55.ebuild,v 1.2 2009/09/20 00:34:24 weaver Exp $
EAPI="2"
@@ -31,8 +31,11 @@ src_prepare() {
}
src_compile() {
- emake -j1 || die
- emake -j1 color || die
+ MAKE_XOPTS=""
+ if [[ $VELVET_MAXKMERLENGTH != "" ]]; then MAKE_XOPTS="$MAKE_XOPTS MAXKMERLENGTH=$VELVET_MAXKMERLENGTH"; fi
+ if [[ $VELVET_CATEGORIES != "" ]]; then MAKE_XOPTS="$MAKE_XOPTS CATEGORIES=$VELVET_CATEGORIES"; fi
+ emake -j1 $MAKE_XOPTS || die
+ emake -j1 $MAKE_XOPTS color || die
}
src_install() {
@@ -41,3 +44,10 @@ src_install() {
doins -r contrib || die
dodoc Manual.pdf CREDITS.txt
}
+
+pkg_postinst() {
+ einfo "To adjust the MAXKMERLENGTH or CATEGORIES parameters as described in the manual,"
+ einfo "please set the variables VELVET_MAXKMERLENGTH or VELVET_CATEGORIES in your"
+ einfo "environment or /etc/make.conf, then re-emerge the package. For example:"
+ einfo " VELVET_MAXKMERLENGTH=NN emerge [options] velvet"
+}