summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:26:01 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:26:01 +0000
commit2414c09f6af8881defbdf5e74687315618b2070e (patch)
treee3895953fb71ee5bc72012ac31b1805d30ec3732 /sci-biology
parentAdded support for the "emboss" and "minimal" "USE" flags. (diff)
downloadgentoo-2-2414c09f6af8881defbdf5e74687315618b2070e.tar.gz
gentoo-2-2414c09f6af8881defbdf5e74687315618b2070e.tar.bz2
gentoo-2-2414c09f6af8881defbdf5e74687315618b2070e.zip
Added support for the "emboss" and "minimal" "USE" flags.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/transfac/ChangeLog5
-rw-r--r--sci-biology/transfac/transfac-3.2.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/sci-biology/transfac/ChangeLog b/sci-biology/transfac/ChangeLog
index 2d212cce73a3..46ff6151b25e 100644
--- a/sci-biology/transfac/ChangeLog
+++ b/sci-biology/transfac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/transfac
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/transfac/ChangeLog,v 1.5 2005/01/14 22:41:06 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/transfac/ChangeLog,v 1.6 2005/02/23 04:26:01 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> transfac-3.2.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
14 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> transfac-3.2.ebuild:
Stable ppc-macos.
diff --git a/sci-biology/transfac/transfac-3.2.ebuild b/sci-biology/transfac/transfac-3.2.ebuild
index 409e46738b36..c6f930986f7a 100644
--- a/sci-biology/transfac/transfac-3.2.ebuild
+++ b/sci-biology/transfac/transfac-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/transfac/transfac-3.2.ebuild,v 1.4 2005/01/14 22:41:06 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/transfac/transfac-3.2.ebuild,v 1.5 2005/02/23 04:26:01 ribosome Exp $
DESCRIPTION="A database of eucaryotic transcription factors"
HOMEPAGE="http://www.gene-regulation.com/pub/databases.html"
@@ -9,26 +9,28 @@ LICENSE="public-domain"
SLOT="3"
KEYWORDS="x86 ~ppc ppc-macos ~ppc64"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/tfextract ] && ! use no-emboss; then
+ if use emboss; then
+ echo
einfo "Indexing TRANSFAC for usage with EMBOSS."
EMBOSS_DATA=. tfextract -auto -infile class.dat || die \
"Indexing TRANSFAC failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}-${SLOT}
doins *.dat
fi
- if [ -e /usr/bin/tfextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data
doins tf*
fi