summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-09-25 22:45:35 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-09-25 22:45:35 +0000
commit36839124cbaed03ef979f4084769da6f095622b7 (patch)
tree7d5f200c9b8caa446aaaf9e5023959ae7352d9f4 /sci-biology
parentNew package, ebuild written by me (diff)
downloadgentoo-2-36839124cbaed03ef979f4084769da6f095622b7.tar.gz
gentoo-2-36839124cbaed03ef979f4084769da6f095622b7.tar.bz2
gentoo-2-36839124cbaed03ef979f4084769da6f095622b7.zip
Version bump
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/last/ChangeLog7
-rw-r--r--sci-biology/last/last-184.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 409df24ba839..25be0283f21f 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.14 2011/04/25 11:00:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.15 2011/09/25 22:45:35 weaver Exp $
+
+*last-184 (25 Sep 2011)
+
+ 25 Sep 2011; Andrey Kislyuk <weaver@gentoo.org> +last-184.ebuild:
+ Version bump
25 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/162-gcc46.patch,
last-162.ebuild, last-162-r1.ebuild:
diff --git a/sci-biology/last/last-184.ebuild b/sci-biology/last/last-184.ebuild
new file mode 100644
index 000000000000..ca42a0e6d0a5
--- /dev/null
+++ b/sci-biology/last/last-184.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-184.ebuild,v 1.1 2011/09/25 22:45:35 weaver Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ emake -e -C src CXX="$(tc-getCXX)" \
+ STRICT="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin src/last{al,db,ex} || die
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/* || die
+ dodoc doc/*.txt ChangeLog.txt README.txt || die
+}