summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-15 19:59:23 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-15 19:59:23 +0000
commit7c06c964da1e515975148bcf98633721286a2b66 (patch)
tree83aa6d760e28254eeb3b5ebcf580e68df899e68c /sci-biology
parentfix irrlicht dependency for dedicated USE flag (diff)
downloadgentoo-2-7c06c964da1e515975148bcf98633721286a2b66.tar.gz
gentoo-2-7c06c964da1e515975148bcf98633721286a2b66.tar.bz2
gentoo-2-7c06c964da1e515975148bcf98633721286a2b66.zip
sci-biology/vienna-rna: Version Bump, #522850
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/vienna-rna/ChangeLog8
-rw-r--r--sci-biology/vienna-rna/files/vienna-rna-2.1.8-bindir.patch10
-rw-r--r--sci-biology/vienna-rna/vienna-rna-2.1.8.ebuild114
3 files changed, 131 insertions, 1 deletions
diff --git a/sci-biology/vienna-rna/ChangeLog b/sci-biology/vienna-rna/ChangeLog
index 92d4c0ad8d00..2c9bb047caf6 100644
--- a/sci-biology/vienna-rna/ChangeLog
+++ b/sci-biology/vienna-rna/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/vienna-rna
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.53 2014/08/29 16:54:27 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.54 2014/09/15 19:59:23 jlec Exp $
+
+*vienna-rna-2.1.8 (15 Sep 2014)
+
+ 15 Sep 2014; Justin Lecher <jlec@gentoo.org> +vienna-rna-2.1.8.ebuild,
+ +files/vienna-rna-2.1.8-bindir.patch:
+ Version Bump, #522850
29 Aug 2014; Mikle Kolyada <zlogene@gentoo.org> -vienna-rna-1.8.5.ebuild,
vienna-rna-2.1.1.ebuild:
diff --git a/sci-biology/vienna-rna/files/vienna-rna-2.1.8-bindir.patch b/sci-biology/vienna-rna/files/vienna-rna-2.1.8-bindir.patch
new file mode 100644
index 000000000000..e54dff95b485
--- /dev/null
+++ b/sci-biology/vienna-rna/files/vienna-rna-2.1.8-bindir.patch
@@ -0,0 +1,10 @@
+diff --git a/Utils/Makefile.am b/Utils/Makefile.am
+index f42ebf4..d84a0f1 100644
+--- a/Utils/Makefile.am
++++ b/Utils/Makefile.am
+@@ -1,4 +1,4 @@
+-pkgbindir = $(pkgdatadir)/bin
++pkgbindir = $(prefix)/bin
+ pkgbin_PROGRAMS = b2ct popt ct2db
+
+ pscript = b2mt.pl ct2b.pl dpzoom.pl mountain.pl relplot.pl rotate_ss.pl cmount.pl colorrna.pl coloraln.pl refold.pl switch.pl
diff --git a/sci-biology/vienna-rna/vienna-rna-2.1.8.ebuild b/sci-biology/vienna-rna/vienna-rna-2.1.8.ebuild
new file mode 100644
index 000000000000..23691ee1623c
--- /dev/null
+++ b/sci-biology/vienna-rna/vienna-rna-2.1.8.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/vienna-rna-2.1.8.ebuild,v 1.1 2014/09/15 19:59:23 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=true
+AUTOTOOLS_AUTORECONF=true
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils distutils-r1 multilib perl-module toolchain-funcs
+
+DESCRIPTION="RNA secondary structure prediction and comparison"
+HOMEPAGE="http://www.tbi.univie.ac.at/~ivo/RNA/"
+SRC_URI="http://www.tbi.univie.ac.at/RNA/packages/source/ViennaRNA-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="vienna-rna"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc openmp python static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-lang/perl
+ media-libs/gd
+ doc? ( dev-texlive/texlive-latex )
+ python? (
+ ${PYTHON_DEPS}
+ dev-lang/swig )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ViennaRNA-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-bindir.patch
+ "${FILESDIR}"/${PN}-2.1.1-prll.patch
+ "${FILESDIR}"/${PN}-2.1.1-impl-decl.patch
+)
+
+src_prepare() {
+ sed -i 's/ getline/ v_getline/' Readseq/ureadseq.c || die
+ sed -i 's/@PerlCmd@ Makefile.PL/& INSTALLDIRS=vendor/' interfaces/Perl/Makefile.am || die
+
+ autotools-utils_src_prepare
+
+ if use python; then
+ cd interfaces/Python || die
+ local PATCHES=()
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-cluster
+ $(use_enable openmp)
+ )
+
+ use doc || \
+ myeconfargs+=(
+ --without-doc-pdf
+ --without-doc-html
+ --without-doc
+ )
+ autotools-utils_src_configure
+ sed \
+ -e "s:CC=gcc:CC=$(tc-getCC):" \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS}:" \
+ -i Readseq/Makefile || die
+ if use python; then
+ cd interfaces/Python || die
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ autotools-utils_src_compile -C Readseq build CC=$(tc-getCC)
+
+ # TODO: Add (optional?) support for the NCBI toolkit.
+ if use python; then
+ cd interfaces/Python || die
+ emake RNA_wrap.c
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ autotools-utils_src_compile -C interfaces/Perl check
+ use python && autotools-utils_src_compile -C interfaces/Python check
+ autotools-utils_src_compile -C Readseq test
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
+
+ newbin Readseq/readseq readseq-vienna
+ dodoc Readseq/Readseq.help
+ newdoc Readseq/Readme README.readseq
+ newdoc Readseq/Formats Formats.readseq
+
+ # remove perlocal.pod to avoid file collisions (see #240358)
+ fixlocalpod || die "Failed to remove perlocal.pod"
+ if use python; then
+ cd interfaces/Python || die
+ distutils-r1_src_install
+ fi
+}