summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-05 22:53:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-05 22:53:40 +0000
commit958a943888fabeccf4223278513775ea393ee3d3 (patch)
tree9f08e1f80a6a4c279a94ad4aa59962d4250a6e19 /sci-calculators
parentno longer mask kvm-kmod (diff)
downloadgentoo-2-958a943888fabeccf4223278513775ea393ee3d3.tar.gz
gentoo-2-958a943888fabeccf4223278513775ea393ee3d3.tar.bz2
gentoo-2-958a943888fabeccf4223278513775ea393ee3d3.zip
Added a patch from Debian on file permission, fixed some syntax errors, and cleaned up
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/transcalc/ChangeLog12
-rw-r--r--sci-calculators/transcalc/files/transcalc-0.14-fd-perm.patch13
-rw-r--r--sci-calculators/transcalc/metadata.xml34
-rw-r--r--sci-calculators/transcalc/transcalc-0.14-r1.ebuild35
-rw-r--r--sci-calculators/transcalc/transcalc-0.14.ebuild25
5 files changed, 75 insertions, 44 deletions
diff --git a/sci-calculators/transcalc/ChangeLog b/sci-calculators/transcalc/ChangeLog
index 704b91bfc4cc..40c3e171da16 100644
--- a/sci-calculators/transcalc/ChangeLog
+++ b/sci-calculators/transcalc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-calculators/transcalc
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/transcalc/ChangeLog,v 1.4 2007/02/09 05:22:33 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/transcalc/ChangeLog,v 1.5 2010/01/05 22:53:40 bicatali Exp $
+
+*transcalc-0.14-r1 (05 Jan 2010)
+
+ 05 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -transcalc-0.14.ebuild, +transcalc-0.14-r1.ebuild,
+ +files/transcalc-0.14-fd-perm.patch, metadata.xml:
+ Added a patch from Debian on file permission, fixed some syntax errors,
+ and cleaned up
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-calculators/transcalc/files/transcalc-0.14-fd-perm.patch b/sci-calculators/transcalc/files/transcalc-0.14-fd-perm.patch
new file mode 100644
index 000000000000..534f3a92d8ac
--- /dev/null
+++ b/sci-calculators/transcalc/files/transcalc-0.14-fd-perm.patch
@@ -0,0 +1,13 @@
+Index: transcalc-0.14/src/transcalc.c
+===================================================================
+--- transcalc-0.14.orig/src/transcalc.c 2009-05-19 22:00:01.000000000 -0400
++++ transcalc-0.14/src/transcalc.c 2009-05-19 22:01:22.000000000 -0400
+@@ -146,7 +146,7 @@
+ /* see if config file exists */
+ if (stat (config_filename, config_file_stat) != 0) {
+ /* config file missing, so touch it */
+- config_file_fd = open (config_filename, O_CREAT);
++ config_file_fd = open (config_filename, O_CREAT, 0644);
+ if (config_file_fd == -1)
+ {
+ perror ("open[config_file]");
diff --git a/sci-calculators/transcalc/metadata.xml b/sci-calculators/transcalc/metadata.xml
index 26a51e594f77..e8863d7196a2 100644
--- a/sci-calculators/transcalc/metadata.xml
+++ b/sci-calculators/transcalc/metadata.xml
@@ -1,21 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
- Transcalc is an analysis and synthesis tool for calculating the
- electrical and physical properties of different kinds of RF and
- microwave transmission lines. Transcalc was somewhat inspired by the
- functionality of Agilent Technologies' commercial program linecalc.
- Transcalc aspires to be more functional in the long run and
- well-documented with appropriate references to formulas that are used.
- Transcalc is built using the GIMP toolkit (GTK) for its GUI interface.
- For each type of transmission line, using dialog boxes, you can enter
- values for the various parameters, and either calculate its electrical
- properties (analyze), or use the given electrical requirements to
- sythesize physical parameters of the required transmission line.
- Available transmission lines (this list will expand with subsequent
- releases): microstrip, rectangular waveguide, coaxial line, coupled
- microstrip.
- </longdescription>
+<herd>sci</herd>
+<longdescription>
+ Transcalc is an analysis and synthesis tool for calculating the
+ electrical and physical properties of different kinds of RF and
+ microwave transmission lines. Transcalc was somewhat inspired by the
+ functionality of Agilent Technologies' commercial program linecalc.
+ Transcalc aspires to be more functional in the long run and
+ well-documented with appropriate references to formulas that are used.
+ Transcalc is built using the GIMP toolkit (GTK) for its GUI interface.
+ For each type of transmission line, using dialog boxes, you can enter
+ values for the various parameters, and either calculate its electrical
+ properties (analyze), or use the given electrical requirements to
+ sythesize physical parameters of the required transmission line.
+ Available transmission lines (this list will expand with subsequent
+ releases): microstrip, rectangular waveguide, coaxial line, coupled
+ microstrip.
+</longdescription>
</pkgmetadata>
diff --git a/sci-calculators/transcalc/transcalc-0.14-r1.ebuild b/sci-calculators/transcalc/transcalc-0.14-r1.ebuild
new file mode 100644
index 000000000000..e0c3967fae43
--- /dev/null
+++ b/sci-calculators/transcalc/transcalc-0.14-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/transcalc/transcalc-0.14-r1.ebuild,v 1.1 2010/01/05 22:53:40 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A microwave and RF transmission line calculator"
+HOMEPAGE="http://transcalc.sourceforge.net"
+SRC_URI="http://transcalc.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # respect flags
+ sed -i -e 's|^CFLAGS=|#CFLAGS=|g' configure || die
+ # patch from debian
+ epatch "${FILESDIR}"/${P}-fd-perm.patch
+ # syntax errors
+ sed -i \
+ -e 's/ythesize/ynthesize/g' \
+ src/{setup_menu.c,help.h} docs/transcalc.sgml README || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/sci-calculators/transcalc/transcalc-0.14.ebuild b/sci-calculators/transcalc/transcalc-0.14.ebuild
deleted file mode 100644
index 55d29e89030e..000000000000
--- a/sci-calculators/transcalc/transcalc-0.14.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/transcalc/transcalc-0.14.ebuild,v 1.2 2005/09/25 01:16:28 dang Exp $
-
-DESCRIPTION="A microwave and RF transmission line calculator"
-HOMEPAGE="http://transcalc.sourceforge.net"
-SRC_URI="http://transcalc.sourceforge.net/${P}.tar.gz"
-
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-2.0"
-
-src_compile() {
- econf || die
- emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog COPYING README TODO
-}