summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-12 11:48:14 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-12 11:48:14 +0000
commite6fc1dc8772a8d71de47e33ed6cf1983f15d5e73 (patch)
tree90165bc338fb60778e097c2271de7a542726a64a /sci-calculators
parentStable on arm, wrt bug #476178 (diff)
downloadgentoo-2-e6fc1dc8772a8d71de47e33ed6cf1983f15d5e73.tar.gz
gentoo-2-e6fc1dc8772a8d71de47e33ed6cf1983f15d5e73.tar.bz2
gentoo-2-e6fc1dc8772a8d71de47e33ed6cf1983f15d5e73.zip
Version bump.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/ChangeLog8
-rwxr-xr-xsci-calculators/units/files/units-2.01_cur84
-rw-r--r--sci-calculators/units/units-2.02.ebuild (renamed from sci-calculators/units/units-2.01-r4.ebuild)7
3 files changed, 10 insertions, 89 deletions
diff --git a/sci-calculators/units/ChangeLog b/sci-calculators/units/ChangeLog
index e531ee7d7054..961ebb71d452 100644
--- a/sci-calculators/units/ChangeLog
+++ b/sci-calculators/units/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/units
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.58 2013/07/09 11:27:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.59 2013/07/12 11:48:14 jer Exp $
+
+*units-2.02 (12 Jul 2013)
+
+ 12 Jul 2013; Jeroen Roovers <jer@gentoo.org> +units-2.02.ebuild,
+ -files/units-2.01_cur, -units-2.01-r4.ebuild:
+ Version bump.
*units-2.01-r4 (09 Jul 2013)
diff --git a/sci-calculators/units/files/units-2.01_cur b/sci-calculators/units/files/units-2.01_cur
deleted file mode 100755
index dceb6ff5ac37..000000000000
--- a/sci-calculators/units/files/units-2.01_cur
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/usr/bin/python2
-
-import datetime
-import sys
-import urllib
-import xml.etree.ElementTree as ET
-
-outfile = 'currency.units'
-outstr = ''
-
-if len(sys.argv)==2:
- outfile = sys.argv[1]
-elif len(sys.argv)>2:
- sys.stderr.write('Usage: {0} [filename]\n\n'.format(sys.argv[0]))
- sys.stderr.write('Update currency information for \'units\' into the specified\n')
- sys.stderr.write('filename or the default location, \'{0}\'.\n'.format(outfile))
- sys.exit(1)
-
-try:
- currencies = ET.parse(urllib.urlopen('http://rss.timegenie.com/forex.xml')).findall('data')
-except IOError, exc:
- sys.stderr.write('Error connecting to currency server. {0}\n'.format(exc))
- sys.exit(1)
-
-# print codes here
-
-outstr += '# ISO Currency Codes\n\n'
-
-maxlen = 0
-
-for currency in currencies:
- code = currency.find('code').text
- description = currency.find('description').text.lower().replace(' ','')
- currency.find('description').text = description
- outstr += code + ' '*20 + description + '\n'
- if len(currency.find('description').text) > maxlen:
- maxlen = len(currency.find('description').text)
- if currency.find('code').text == 'USD':
- usdval = currency.find('rate').text[2:]
- currencies.remove(currency)
-
-# print rates here
-
-now = datetime.datetime.now()
-outstr += '\n# Currency exchange rates from Time Genie (www.timegenie.com)\n'
-outstr += '\n!message Currency exchange rates from ' + now.strftime('%Y-%m-%d') + '\n\n'
-
-for currency in currencies:
- if currency.find('code').text == 'EUR':
- euro = currency.find('rate').text
- currency.find('rate').text = usdval + ' US$'
-
- else:
- currency.find('rate').text += ' euro'
- outstr += currency.find('description').text.ljust(maxlen+2) + '1|' + currency.find('rate').text + '\n'
-
-# precious metals prices
-
-# Another source for this data might be
-# http://www.xmlcharts.com/cache/precious-metals.xml
-
-outstr += '\n# Precious metals prices from http://services.packetizer.com/spotprices/\n\n'
-
-try:
- spotprices = ET.parse(urllib.urlopen('http://services.packetizer.com/spotprices/?f=xml'))
-except IOError, exc:
- sys.stderr.write('Error connecting to spotprices server. {0}\n'.format(exc))
- sys.exit(1)
-
-metals = ['gold','platinum','silver']
-
-for metal in metals:
- outstr += '{0} {1} US$/troyounce\n'.format((metal+'price').ljust(15), spotprices.find(metal).text)
-
-try:
- if outfile == '-':
- outfile = sys.stdout
- else:
- outfile = open(outfile,'w')
-except IOError, exc:
- sys.stderr.write('Unable to write to output file. {0}\n'.format(exc))
- sys.exit(1)
-
-outfile.write(outstr)
diff --git a/sci-calculators/units/units-2.01-r4.ebuild b/sci-calculators/units/units-2.02.ebuild
index af37224d7b05..7fc6abc3c335 100644
--- a/sci-calculators/units/units-2.01-r4.ebuild
+++ b/sci-calculators/units/units-2.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.01-r4.ebuild,v 1.1 2013/07/09 11:27:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.02.ebuild,v 1.1 2013/07/12 11:48:14 jer Exp $
EAPI=5
inherit autotools eutils
@@ -9,7 +9,7 @@ DESCRIPTION="Unit conversion program"
HOMEPAGE="http://www.gnu.org/software/units/units.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="FDL-1.3 GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
@@ -29,7 +29,6 @@ RDEPEND="
DOCS=( ChangeLog NEWS README )
src_prepare() {
- epatch "${FILESDIR}"/${P}-install.patch
- cp "${FILESDIR}"/${P}_cur ${PN}_cur
+ epatch "${FILESDIR}"/${PN}-2.01-install.patch
eautoreconf
}