summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-18 08:27:49 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-18 08:27:49 +0000
commit07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8 (patch)
treeaa78c35ff8e75865fe6e9d3d15493e85746568cf /sci-chemistry/cluster/files
parentKeyword ~ppc64 wrt #321937. (diff)
downloadgentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.tar.gz
gentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.tar.bz2
gentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.zip
New Addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/cluster/files')
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-includes.patch12
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-ldflags.patch35
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/files/1.3.081231-includes.patch b/sci-chemistry/cluster/files/1.3.081231-includes.patch
new file mode 100644
index 000000000000..a5586a540a4f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-includes.patch
@@ -0,0 +1,12 @@
+diff --git a/cluster.cpp b/cluster.cpp
+index 0a8c3c1..1384949 100644
+--- a/cluster.cpp
++++ b/cluster.cpp
+@@ -24,6 +24,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <string>
++#include <cstring>
+
+ #include <iostream>
+ #include <fstream>
diff --git a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
new file mode 100644
index 000000000000..d407e0bc8b8f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index 7892054..938a8c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ PROG_FLGS = -D BOOLPREDEFINED
+
+ SRCS = cluster.cpp DisjointSets.cpp utility.cpp
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS)
++CXXFLAGS += $(OPT) $(DEBUG) $(PROG_FLGS)
+
+ LFLAGS =
+
+@@ -12,7 +12,7 @@ OBJLIST = cluster.o DisjointSets.o utility.o
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) $(CXXFLAGS) -c $*.cpp
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)
+@@ -20,10 +20,10 @@ DEBUG = $(CXXDEBUGFLAGS)
+ all: cluster
+
+ cluster: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST)
+
+ depend:
+- makedepend -- $(CFLAGS) -- $(SRCS)
++ makedepend -- $(CXXFLAGS) -- $(SRCS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files