summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-06-08 08:27:31 +0000
committerJustin Lecher <jlec@gentoo.org>2014-06-08 08:27:31 +0000
commit682c0cbfa6f8f53b544cef1b562b0d106473874c (patch)
tree97fb1d5597cce8677679695abe7cf86fbca77e27 /sci-chemistry/cns
parentdev-cpp/tbb: Add compatibility with versioned gcc, #512672 (diff)
downloadgentoo-2-682c0cbfa6f8f53b544cef1b562b0d106473874c.tar.gz
gentoo-2-682c0cbfa6f8f53b544cef1b562b0d106473874c.tar.bz2
gentoo-2-682c0cbfa6f8f53b544cef1b562b0d106473874c.zip
sci-chemistry/cns: Stabilize; drop pre EAPI=5 ebuilds, #478584; add longdescription, #511734
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/cns')
-rw-r--r--sci-chemistry/cns/ChangeLog8
-rw-r--r--sci-chemistry/cns/cns-1.2.1-r7.ebuild241
-rw-r--r--sci-chemistry/cns/cns-1.3_p7.ebuild224
-rw-r--r--sci-chemistry/cns/metadata.xml10
4 files changed, 16 insertions, 467 deletions
diff --git a/sci-chemistry/cns/ChangeLog b/sci-chemistry/cns/ChangeLog
index 8709f966b04f..d900e61ea061 100644
--- a/sci-chemistry/cns/ChangeLog
+++ b/sci-chemistry/cns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/cns
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.54 2013/10/09 14:33:46 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.55 2014/06/08 08:27:31 jlec Exp $
+
+ 08 Jun 2014; Justin Lecher <jlec@gentoo.org> -cns-1.2.1-r7.ebuild,
+ -cns-1.3_p7.ebuild, metadata.xml:
+ Stabilize; drop pre EAPI=5 ebuilds, #478584; add longdescription, #511734
*cns-1.3_p7-r1 (09 Oct 2013)
*cns-1.2.1-r8 (09 Oct 2013)
diff --git a/sci-chemistry/cns/cns-1.2.1-r7.ebuild b/sci-chemistry/cns/cns-1.2.1-r7.ebuild
deleted file mode 100644
index b01e7cccc969..000000000000
--- a/sci-chemistry/cns/cns-1.2.1-r7.ebuild
+++ /dev/null
@@ -1,241 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r7.ebuild,v 1.7 2012/11/27 13:17:37 jlec Exp $
-
-EAPI=3
-
-inherit eutils fortran-2 toolchain-funcs versionator flag-o-matic
-
-MY_PN="${PN}_solve"
-MY_PV="$(delete_version_separator 2)"
-MY_P="${MY_PN}_${MY_PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="
- ${MY_P}_all-mp.tar.gz
- aria? ( aria2.3.2.tar.gz )"
-
-SLOT="0"
-LICENSE="cns"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="aria openmp"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-FORTRAN_NEED_OPENMP=1
-
-S="${WORKDIR}/${MY_P}"
-
-RESTRICT="fetch test"
-
-pkg_nofetch() {
- elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- use aria && elog "and http://aria.pasteur.fr/"
- elog "and place these files:"
- elog ${A}
- elog "in ${DISTDIR}."
-}
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- fortran-2_pkg_setup
- get_fcomp
-}
-
-get_bitness() {
- echo > "${T}"/test.c
- $(tc-getCC) ${CFLAGS} -c "${T}"/test.c -o "${T}"/test.o
- case $(file "${T}"/test.o) in
- *64-bit*|*ppc64*|*x86_64*) export _bitness="64";;
- *32-bit*|*ppc*|*i386*) export _bitness="32";;
- *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
- esac
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${PV}-parallel.patch
-
- get_bitness
-
- if use aria; then
- pushd "${WORKDIR}"/aria* >& /dev/null
- # Update the cns sources in aria for version 1.2.1
- epatch "${FILESDIR}"/1.2.1-aria2.3.patch
-
- # Update the code with aria specific things
- cp -rf cns/src/* "${S}"/source/
- popd >& /dev/null
- fi
-
- # the code uses Intel-compiler-specific directives
- if [[ $(tc-getFC) =~ gfortran ]]; then
- epatch "${FILESDIR}"/${PV}-allow-gcc-openmp.patch
- use openmp && \
- append-flags -fopenmp && append-ldflags -fopenmp
- COMP="gfortran"
- [[ ${_bitness} == 64 ]] && \
- append-fflags -fdefault-integer-8
- elif [[ $(tc-getFC) == if* ]]; then
- epatch "${FILESDIR}"/${PV}-ifort.patch
- use openmp && \
- append-flags -openmp && append-ldflags -openmp
- COMP="ifort"
- [[ ${_bitness} == 64 ]] && append-fflags -i8
- fi
-
- [[ ${_bitness} == 64 ]] && \
- append-cflags "-DINTEGER='long long int'"
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- cp "${FILESDIR}"/cns_solve_env_sh "${T}"/
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- "${T}"/cns_solve_env_sh
-
- einfo "Fixing shebangs..."
- find "${S}" -type f \
- -exec sed "s:/bin/csh:${EPREFIX}/bin/csh:g" -i '{}' \; || die
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN
- if [[ $(tc-getFC) =~ g77 ]]; then
- GLOBALS="-fno-globals"
- MALIGN='\$(CNS_MALIGN_I86)'
- fi
-
- # Set up the compiler to use
- pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FCOMP} || die
- popd 2>/dev/null
-
- # make install really means build, since it's expected to be used in-place
- # -j1 doesn't mean we do no respect MAKEOPTS!
- emake -j1 \
- CC="$(tc-getCC)" \
- F77=$(tc-getFC) \
- LD=$(tc-getFC) \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- LDFLAGS="${LDFLAGS}" \
- F77OPT="${FCFLAGS} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- OMPLIB="${OMPLIB}" \
- compiler="${COMP}" \
- install \
- || die "emake failed"
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- csh -c \
- "export CNS_G77=ON; source ${S}/cns_solve_env; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- # Install to locations resembling FHS
- sed -i \
- -e "s:${S}:usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_ROOT ${EPREFIX}/usr:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DATA \$CNS_ROOT/share/cns:g" \
- -e "s:^\(setenv CNS_SOLVE.*\):\1\nsetenv CNS_DOC \$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB \$CNS_SOLVE/libraries:CNS_LIB \$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE \$CNS_SOLVE/modules:CNS_MODULE \$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB \$CNS_SOLVE/helplib:CNS_HELPLIB \$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- -e "/^g77on/d" \
- "${S}"/cns_solve_env
- # I don't entirely understand why the sh version requires a leading /
- # for CNS_SOLVE and CNS_ROOT, but it does
- sed -i \
- -e "s:${S}:/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_ROOT=${EPREFIX}/usr:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DATA=\$CNS_ROOT/share/cns:g" \
- -e "s:^\(^[[:space:]]*CNS_SOLVE=.*\):\1\nexport CNS_DOC=\$CNS_ROOT/share/doc/${PF}:g" \
- -e "s:CNS_LIB=\$CNS_SOLVE/libraries:CNS_LIB=\$CNS_DATA/libraries:g" \
- -e "s:CNS_MODULE=\$CNS_SOLVE/modules:CNS_MODULE=\$CNS_DATA/modules:g" \
- -e "s:CNS_HELPLIB=\$CNS_SOLVE/helplib:CNS_HELPLIB=\$CNS_DATA/helplib:g" \
- -e "s:\$CNS_SOLVE/bin/cns_info:\$CNS_DATA/cns_info:g" \
- -e "/^g77on/d" \
- -e "/^g77off/d" \
- "${T}"/cns_solve_env_sh
-
- # Get rid of setup stuff we don't need in the installed script
- sed -i \
- -e "83,$ d" \
- -e "37,46 d" \
- "${S}"/cns_solve_env
- sed -i \
- -e "84,$ d" \
- -e "39,50 d" \
- "${T}"/cns_solve_env_sh
-
- newbin "${S}"/*linux*/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- # Don't want to install this
- rm -f "${S}"/*linux*/utils/Makefile
-
- dobin "${S}"/*linux*/utils/* || die "install utils failed"
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web || die
-
- dobin "${S}"/bin/cns_{edit,header,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib || die
- doins "${S}"/bin/cns_info || die
-
- insinto /etc/profile.d
- newins "${S}"/cns_solve_env cns_solve_env.csh || die
- newins "${T}"/cns_solve_env_sh cns_solve_env.sh || die
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/* || die
- # Conflits with app-text/dos2unix
- rm -f "${D}"/usr/bin/dos2unix
-}
-
-pkg_info() {
- if use openmp; then
- elog "Set OMP_NUM_THREADS to the number of threads you want."
- elog "If you get segfaults on large structures, set the GOMP_STACKSIZE"
- elog "variable if using gcc (16384 should be good)."
- fi
-}
-
-pkg_postinst() {
- pkg_info
-}
diff --git a/sci-chemistry/cns/cns-1.3_p7.ebuild b/sci-chemistry/cns/cns-1.3_p7.ebuild
deleted file mode 100644
index 0caa1251ad4c..000000000000
--- a/sci-chemistry/cns/cns-1.3_p7.ebuild
+++ /dev/null
@@ -1,224 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.3_p7.ebuild,v 1.3 2012/11/27 13:17:37 jlec Exp $
-
-EAPI=3
-
-inherit eutils fortran-2 toolchain-funcs versionator flag-o-matic
-
-MY_PN="${PN}_solve"
-MY_PV="$(delete_version_separator 2)"
-MY_P="${MY_PN}_${MY_PV}"
-
-DESCRIPTION="Crystallography and NMR System"
-HOMEPAGE="http://cns.csb.yale.edu/"
-SRC_URI="
- ${MY_P/p7}_all.tar.gz
- aria? ( aria2.3.1.tar.gz )"
-
-SLOT="0"
-LICENSE="cns"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="aria openmp"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-FORTRAN_NEED_OPENMP=1
-
-S="${WORKDIR}/${MY_P/p7}"
-
-RESTRICT="fetch"
-
-pkg_nofetch() {
- elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
- use aria && elog "and http://aria.pasteur.fr/"
- elog "and place these files:"
- elog ${A}
- elog "in ${DISTDIR}."
-}
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- fortran-2_pkg_setup
- get_fcomp
-}
-
-get_bitness() {
- echo > "${T}"/test.c
- $(tc-getCC) ${CFLAGS} -c "${T}"/test.c -o "${T}"/test.o
- case $(file "${T}"/test.o) in
- *64-bit*|*ppc64*|*x86_64*) export _bitness="64";;
- *32-bit*|*ppc*|*i386*) export _bitness="32";;
- *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
- esac
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${PV}-delete.patch
-
- get_bitness
-
- if use aria; then
- pushd "${WORKDIR}"/aria* >& /dev/null
- # Update the cns sources in aria for version 1.2.1
- epatch "${FILESDIR}"/1.2.1-aria2.3.patch
-
- # Update the code with aria specific things
- cp -rf cns/src/* "${S}"/source/
- popd >& /dev/null
- fi
-
- # the code uses Intel-compiler-specific directives
- if [[ $(tc-getFC) =~ gfortran ]]; then
- use openmp && \
- append-flags -fopenmp && append-ldflags -fopenmp
- COMP="gfortran"
- [[ ${_bitness} == 64 ]] && \
- append-fflags -fdefault-integer-8
- elif [[ $(tc-getFC) == if* ]]; then
- use openmp && \
- append-flags -openmp && append-ldflags -openmp
- COMP="ifort"
- [[ ${_bitness} == 64 ]] && append-fflags -i8
- fi
-
- [[ ${_bitness} == 64 ]] && \
- append-cflags "-DINTEGER='long long int'"
-
- # Set up location for the build directory
- # Uses obsolete `sort` syntax, so we set _POSIX2_VERSION
- cp "${FILESDIR}"/cns_solve_env_sh-${PV} "${T}"/cns_solve_env_sh || die
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nsetenv _POSIX2_VERSION 199209:g" \
- "${S}"/cns_solve_env || die
- sed -i \
- -e "s:_CNSsolve_location_:${S}:g" \
- -e "17 s:\(.*\):\1\nexport _POSIX2_VERSION; _POSIX2_VERSION=199209:g" \
- -e "s:setenv OMP_STACKSIZE 256m:export OMP_STACKSIZE= 256m:g" \
- -e "s:limit:ulimit:g" \
- "${T}"/cns_solve_env_sh || die
-
- ebegin "Fixing shebangs..."
- find "${S}" -type f \
- -exec sed "s:/bin/csh:${EPREFIX}/bin/csh:g" -i '{}' \; || die
- find . -name "Makefile*" \
- -exec \
- sed \
- -e "s:^SHELL=/bin/sh:SHELL=${EPREFIX}/bin/sh:g" \
- -e "s:/bin/ls:ls:g" \
- -e "s:/bin/rm:rm:g" \
- -i '{}' \; || die
- eend
-}
-
-src_compile() {
- local GLOBALS
- local MALIGN
-
- # Set up the compiler to use
- pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FCOMP} || die
- popd 2>/dev/null
-
- # make install really means build, since it's expected to be used in-place
- # -j1 doesn't mean we do no respect MAKEOPTS!
- emake -j1 \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- F77=$(tc-getFC) \
- LD=$(tc-getFC) \
- CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- CXXFLAGS="${CXXFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
- LDFLAGS="${LDFLAGS}" \
- F77OPT="${FCFLAGS} ${MALIGN}" \
- F77STD="${GLOBALS}" \
- OMPLIB="${OMPLIB}" \
- compiler="${COMP}" \
- install \
- || die "emake failed"
-}
-
-src_test() {
- # We need to force on g77 manually, because we can't get aliases working
- # when we source in a -c
- einfo "Running tests ..."
- sh -c \
- "export CNS_G77=ON; source ${T}/cns_solve_env_sh; make run_tests" \
- || die "tests failed"
- einfo "Displaying test results ..."
- cat "${S}"/*_g77/test/*.diff-test
-}
-
-src_install() {
- cat >> "${T}"/66cns <<- EOF
- CNS_SOLVE="${EPREFIX}/usr"
- CNS_ROOT="${EPREFIX}/usr"
- CNS_DATA="${EPREFIX}/usr/share/cns"
- CNS_DOC="${EPREFIX}/usr/share/doc/cns-1.3"
- CNS_LIB="${EPREFIX}/usr/share/cns/libraries"
- CNS_MODULE="${EPREFIX}/usr/share/cns/modules"
- CNS_TOPPAR="${EPREFIX}/usr/share/cns/libraries/toppar"
- CNS_CONFDB="${EPREFIX}/usr/share/cns/libraries/confdb"
- CNS_XTALLIB="${EPREFIX}/usr/share/cns/libraries/xtal"
- CNS_NMRLIB="${EPREFIX}/usr/share/cns/libraries/nmr"
- CNS_XRAYLIB="${EPREFIX}/usr/share/cns/libraries/xray"
- CNS_XTALMODULE="${EPREFIX}/usr/share/cns/modules/xtal"
- CNS_NMRMODULE="${EPREFIX}/usr/share/cns/modules/nmr"
- CNS_HELPLIB="${EPREFIX}/usr/share/cns/helplib"
- EOF
-
- doenvd "${T}"/66cns || die
-
- # Don't want to install this
- rm -f "${S}"/*linux*/utils/Makefile
-
- sed -i \
- -e "s:\$CNS_SOLVE/doc/:\$CNS_SOLVE/share/doc/${PF}/:g" \
- "${S}"/bin/cns_web || die
-
- newbin "${S}"/*linux*/bin/cns_solve* cns_solve \
- || die "install cns_solve failed"
-
- # Can be run by either cns_solve or cns
- dosym cns_solve /usr/bin/cns
-
- dobin \
- "${S}"/*linux*/utils/* \
- "${S}"/bin/cns_{edit,header,import_cif,transfer,web} || die "install bin failed"
-
- insinto /usr/share/cns
- doins -r "${S}"/libraries "${S}"/modules "${S}"/helplib "${S}"/bin/cns_info || die
-
- dohtml \
- -A iq,cgi,csh,cv,def,fm,gif,hkl,inp,jpeg,lib,link,list,mask,mtf,param,pdb,pdf,pl,ps,sc,sca,sdb,seq,tbl,top \
- -f all_cns_info_template,omac,def \
- -r doc/html/* || die
- # Conflits with app-text/dos2unix
- rm -f "${D}"/usr/bin/dos2unix || die
-}
-
-pkg_info() {
- if use openmp; then
- elog "Set OMP_NUM_THREADS to the number of threads you want."
- elog "If you get segfaults on large structures, set the GOMP_STACKSIZE"
- elog "variable if using gcc (16384 should be good)."
- fi
-}
-
-pkg_postinst() {
- pkg_info
-}
diff --git a/sci-chemistry/cns/metadata.xml b/sci-chemistry/cns/metadata.xml
index 3102a32e4dd1..a9cb92ec3f79 100644
--- a/sci-chemistry/cns/metadata.xml
+++ b/sci-chemistry/cns/metadata.xml
@@ -8,4 +8,14 @@
<use>
<flag name="aria"> Support patch for sci-chemistry/aria</flag>
</use>
+ <longdescription>
+Crystallography and NMR System (CNS) is the result of an international
+collaborative effort among several research groups. The program has
+been designed to provide a flexible multi-level hierachical approach for the
+most commonly used algorithms in macromolecular structure determination.
+Highlights include heavy atom searching, experimental phasing (including
+MAD and MIR), density modification, crystallographic refinement with maximum
+likelihood targets, and NMR structure calculation using NOEs, J-coupling,
+chemical shift, and dipolar coupling data.
+</longdescription>
</pkgmetadata>