summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-08-19 12:53:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-08-19 12:53:14 +0000
commit22e34ab0e59275d08e2e5e9ff2af8a9b16b0e7f0 (patch)
tree236f384ba1cff76e1b501d2b9cf3c3c958e59747 /sci-chemistry/gabedit
parentremove old (diff)
downloadgentoo-2-22e34ab0e59275d08e2e5e9ff2af8a9b16b0e7f0.tar.gz
gentoo-2-22e34ab0e59275d08e2e5e9ff2af8a9b16b0e7f0.tar.bz2
gentoo-2-22e34ab0e59275d08e2e5e9ff2af8a9b16b0e7f0.zip
sci-chemistry/gabedit: Version BUmp, #481626
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/gabedit')
-rw-r--r--sci-chemistry/gabedit/ChangeLog7
-rw-r--r--sci-chemistry/gabedit/gabedit-2.4.7.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-chemistry/gabedit/ChangeLog b/sci-chemistry/gabedit/ChangeLog
index 7c5596f52231..c96ade3df0a4 100644
--- a/sci-chemistry/gabedit/ChangeLog
+++ b/sci-chemistry/gabedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/gabedit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.20 2013/04/09 06:22:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.21 2013/08/19 12:53:14 jlec Exp $
+
+*gabedit-2.4.7 (19 Aug 2013)
+
+ 19 Aug 2013; Justin Lecher <jlec@gentoo.org> +gabedit-2.4.7.ebuild:
+ Version BUmp, #481626
*gabedit-2.4.6 (09 Apr 2013)
diff --git a/sci-chemistry/gabedit/gabedit-2.4.7.ebuild b/sci-chemistry/gabedit/gabedit-2.4.7.ebuild
new file mode 100644
index 000000000000..68b58a7986d2
--- /dev/null
+++ b/sci-chemistry/gabedit/gabedit-2.4.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.4.7.ebuild,v 1.1 2013/08/19 12:53:14 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator
+
+MY_PN=${PN/g/G}
+MY_PV=$(delete_all_version_separators)
+MY_P="${MY_PN}Src${MY_PV}"
+
+DESCRIPTION="GUI for computational chemistry packages"
+HOMEPAGE="http://gabedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/gl2ps
+ x11-libs/pango
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i "/rmdir tmp/d" "${S}"/Makefile || die
+ sed \
+ -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
+ -i "${S}/Config.h" || die
+ sed -e 's:-g::g' -i Makefile || die
+ cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
+
+ if use openmp && tc-has-openmp; then
+ cat <<- EOF >> "${S}/CONFIG"
+ OMPLIB=-fopenmp
+ OMPCFLAGS=-DENABLE_OMP -fopenmp
+ EOF
+ fi
+ echo "COMMONCFLAGS = ${CFLAGS} -DENABLE_DEPRECATED \$(OMPCFLAGS) \$(DRAWGEOMGL)" >> CONFIG
+
+ tc-export CC
+}
+
+src_compile() {
+ emake clean
+ emake external_gl2ps=1
+}
+
+src_install() {
+ local size
+ dobin ${PN}
+ dodoc ChangeLog
+ for size in 16 24 32 48; do
+ doicon -s ${size} icons/Gabedit${size}.*
+ done
+}