summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-07-09 00:08:06 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-07-09 00:08:06 +0000
commitb3c3e8b229b994550efb7a49996a8bc16054db86 (patch)
treef5b3da3d3fa4065aea813adcea824bfdafbb663a /sci-chemistry/ghemical
parentFixed a typo in the ebuild info messages (bug #98375). Removed old ebuild. (diff)
downloadgentoo-2-b3c3e8b229b994550efb7a49996a8bc16054db86.tar.gz
gentoo-2-b3c3e8b229b994550efb7a49996a8bc16054db86.tar.bz2
gentoo-2-b3c3e8b229b994550efb7a49996a8bc16054db86.zip
Version bump. Now uses external mopac7 and openbabel instead of including its own copies. Added USE flags for mpqc and for GTK+ front-end instead of GLUT front-end.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sci-chemistry/ghemical')
-rw-r--r--sci-chemistry/ghemical/ChangeLog10
-rw-r--r--sci-chemistry/ghemical/files/digest-ghemical-1.021
-rw-r--r--sci-chemistry/ghemical/ghemical-1.02.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/sci-chemistry/ghemical/ChangeLog b/sci-chemistry/ghemical/ChangeLog
index a8226109f754..5c5f50aa3a96 100644
--- a/sci-chemistry/ghemical/ChangeLog
+++ b/sci-chemistry/ghemical/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/ghemical
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.5 2005/07/08 05:20:45 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.6 2005/07/09 00:08:06 spyderous Exp $
+
+*ghemical-1.02 (09 Jul 2005)
+
+ 09 Jul 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +ghemical-1.02.ebuild:
+ Version bump. Now uses external mopac7 and openbabel instead of including
+ its own copies. Added USE flags for mpqc and for GTK+ front-end instead of
+ GLUT front-end.
*ghemical-1.01 (04 Jan 2005)
diff --git a/sci-chemistry/ghemical/files/digest-ghemical-1.02 b/sci-chemistry/ghemical/files/digest-ghemical-1.02
new file mode 100644
index 000000000000..60d8efe02b8a
--- /dev/null
+++ b/sci-chemistry/ghemical/files/digest-ghemical-1.02
@@ -0,0 +1 @@
+MD5 851b77fe9fc21cb03ef5af321b8c82f4 ghemical-1.02.tgz 1692832
diff --git a/sci-chemistry/ghemical/ghemical-1.02.ebuild b/sci-chemistry/ghemical/ghemical-1.02.ebuild
new file mode 100644
index 000000000000..3a9513f7440f
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-1.02.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-1.02.ebuild,v 1.1 2005/07/09 00:08:06 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mpqc gtk"
+
+DEPEND="dev-libs/libf2c
+ sci-chemistry/mopac7
+ >=sci-chemistry/openbabel-1.100.2
+ sci-chemistry/mpqc
+ >=media-libs/glut-3.7
+ dev-libs/libxml
+ >=dev-util/pkgconfig-0.15
+ =x11-libs/gtkglarea-1.2*
+ =gnome-base/libglade-0*
+ gtk? (
+ gnome-base/gnome-libs
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc3.4-r1.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ $(use_enable mpqc) \
+ $(use_enable gtk) ||die
+ emake || die "Configure failed"
+}
+
+src_install() {
+ sed -e "s:^prefix=.*:prefix=${D}/usr:" -i Makefile
+ make install || die "Install failed"
+}