summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 21:25:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 21:25:05 +0000
commit99a994a5ca1752b7db68cfc3f1f80f560a5d6c7b (patch)
tree5516d3e30de6a90f0c12390667327739be21916f /sci-chemistry/molmol
parentUse Requires.private and Libs.private instead of Requires and Libs wrt #38019... (diff)
downloadgentoo-2-99a994a5ca1752b7db68cfc3f1f80f560a5d6c7b.tar.gz
gentoo-2-99a994a5ca1752b7db68cfc3f1f80f560a5d6c7b.tar.bz2
gentoo-2-99a994a5ca1752b7db68cfc3f1f80f560a5d6c7b.zip
Fix building with libpng15 wrt #378341 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molmol')
-rw-r--r--sci-chemistry/molmol/ChangeLog6
-rw-r--r--sci-chemistry/molmol/files/libpng15.patch32
-rw-r--r--sci-chemistry/molmol/molmol-2k_p2-r2.ebuild3
3 files changed, 39 insertions, 2 deletions
diff --git a/sci-chemistry/molmol/ChangeLog b/sci-chemistry/molmol/ChangeLog
index a7d082071d43..8f99378b1bd6 100644
--- a/sci-chemistry/molmol/ChangeLog
+++ b/sci-chemistry/molmol/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/molmol
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.26 2011/07/15 20:37:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/ChangeLog,v 1.27 2011/09/14 21:25:05 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> +files/libpng15.patch,
+ molmol-2k_p2-r2.ebuild:
+ Fix building with libpng15 wrt #378341 by Diego Elio Pettenò
15 Jul 2011; Markus Meier <maekke@gentoo.org> molmol-2k_p2-r2.ebuild:
x86 stable, bug #373091
diff --git a/sci-chemistry/molmol/files/libpng15.patch b/sci-chemistry/molmol/files/libpng15.patch
new file mode 100644
index 000000000000..cd27e4906608
--- /dev/null
+++ b/sci-chemistry/molmol/files/libpng15.patch
@@ -0,0 +1,32 @@
+--- src/motogl/MotOGLDump.c
++++ src/motogl/MotOGLDump.c
+@@ -248,7 +248,7 @@
+ pngErrHand(png_structp pngStrucP, char *errMsg)
+ {
+ IORaiseError(errMsg);
+- longjmp(pngStrucP->jmpbuf, 1);
++ longjmp(png_jmpbuf(pngStrucP), 1);
+ }
+ #endif
+
+@@ -357,7 +357,7 @@
+ return IO_RES_ERR;
+ }
+
+- if (setjmp(pngStrucP->jmpbuf)) {
++ if (setjmp(png_jmpbuf(pngStrucP))) {
+ if (cBuf != NULL)
+ free(cBuf);
+ if (fBuf != NULL)
+@@ -368,10 +368,7 @@
+
+ png_init_io(pngStrucP, ImgFileP);
+
+- pngInfoP->width = imgW;
+- pngInfoP->height = imgH;
+- pngInfoP->bit_depth = 8;
+- pngInfoP->color_type = PNG_COLOR_TYPE_RGB;
++ png_set_IHDR(pngStrucP, pngInfoP, imgW, imgH, 8, PNG_COLOR_TYPE_RGB, 0, PNG_COMPRESSION_TYPE_DEFAULT, PNG_FILTER_TYPE_DEFAULT);
+ png_write_info(pngStrucP, pngInfoP);
+ }
+ #endif
diff --git a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
index 719bd8cca888..cef6add6ea62 100644
--- a/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
+++ b/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.7 2011/07/15 20:37:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molmol/molmol-2k_p2-r2.ebuild,v 1.8 2011/09/14 21:25:05 ssuominen Exp $
EAPI=4
@@ -59,6 +59,7 @@ src_prepare() {
-i "${S}"/makedef || die
epatch "${FILESDIR}"/cast.patch
+ epatch "${FILESDIR}"/libpng15.patch
}
src_install() {