summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-06-12 10:10:36 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-06-12 10:10:36 +0000
commit3f2f60d6bcd46c6ab2c3b9d5743ab32cb1d38a8d (patch)
tree2ce6dccae7d48dd507aff81b56012b3ab76ff675 /sci-chemistry/prekin
parentback out portage specific /etc/portage/env hack; it's directly supported in p... (diff)
downloadgentoo-2-3f2f60d6bcd46c6ab2c3b9d5743ab32cb1d38a8d.tar.gz
gentoo-2-3f2f60d6bcd46c6ab2c3b9d5743ab32cb1d38a8d.tar.bz2
gentoo-2-3f2f60d6bcd46c6ab2c3b9d5743ab32cb1d38a8d.zip
Add missing dependencies wrt #371235 by Piotr Szymaniak <lazy_bum@o2.pl>, add missing die, remove unnecessary messages and quotes. Drop old
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/prekin')
-rw-r--r--sci-chemistry/prekin/ChangeLog9
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild21
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122.ebuild54
3 files changed, 17 insertions, 67 deletions
diff --git a/sci-chemistry/prekin/ChangeLog b/sci-chemistry/prekin/ChangeLog
index e7076b32f71d..caa678d2b56c 100644
--- a/sci-chemistry/prekin/ChangeLog
+++ b/sci-chemistry/prekin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/prekin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/ChangeLog,v 1.3 2010/10/10 21:28:36 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/ChangeLog,v 1.4 2011/06/12 10:10:35 xarthisius Exp $
+
+ 12 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ -prekin-6.51.081122.ebuild, prekin-6.51.081122-r1.ebuild:
+ Add missing dependencies wrt #371235 by Piotr Szymaniak <lazy_bum@o2.pl>, add
+ missing die, remove unnecessary messages and quotes. Drop old
10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> prekin-6.51.081122.ebuild,
prekin-6.51.081122-r1.ebuild:
diff --git a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
index f259d714e2fc..06b34fbec698 100644
--- a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
+++ b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
@@ -1,29 +1,30 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild,v 1.2 2010/10/10 21:28:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild,v 1.3 2011/06/12 10:10:35 xarthisius Exp $
EAPI="2"
inherit toolchain-funcs eutils multilib
-MY_P="${PN}.${PV}"
+MY_P=${PN}.${PV}
DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/prekin/${MY_P}.src.tgz"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
LICENSE="richardson"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="X"
-RDEPEND="
+RDEPEND="x11-libs/libXext
+ x11-libs/libXmu
x11-libs/libX11
x11-libs/libXt
X? ( >=x11-libs/openmotif-2.3:0 )"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_prepare() {
epatch \
@@ -32,7 +33,7 @@ src_prepare() {
sed \
-e 's:cc:$(CC):g' \
-e "s:GENTOOLIBDIR:$(get_libdir):g" \
- "${S}"/Makefile.linux > Makefile
+ "${S}"/Makefile.linux > Makefile || die
}
src_compile() {
@@ -44,11 +45,9 @@ src_compile() {
mytarget="nogui"
fi
- emake \
- CC="$(tc-getCC)" \
- ${mytarget} || die "make failed"
+ emake CC="$(tc-getCC)" ${mytarget} || die
}
src_install() {
- dobin "${S}"/prekin || die "dobin failed"
+ dobin "${S}"/prekin || die
}
diff --git a/sci-chemistry/prekin/prekin-6.51.081122.ebuild b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
deleted file mode 100644
index d64df43d7139..000000000000
--- a/sci-chemistry/prekin/prekin-6.51.081122.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122.ebuild,v 1.3 2010/10/10 21:28:36 ulm Exp $
-
-EAPI="2"
-
-inherit toolchain-funcs eutils multilib
-
-MY_P="${PN}.${PV}"
-
-DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
-HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/prekin/${MY_P}.src.tgz"
-
-LICENSE="richardson"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="X"
-
-RDEPEND="
- x11-libs/libX11
- x11-libs/libXt
- X? ( >=x11-libs/openmotif-2.3:0 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-Makefile.patch \
- "${FILESDIR}"/${PV}-overflow.patch
- sed \
- -e 's:cc:$(CC):g' \
- -e "s:GENTOOLIBDIR:$(get_libdir):g" \
- "${S}"/Makefile.linux > Makefile
-}
-
-src_compile() {
- local mytarget
-
- if use X; then
- mytarget="${PN}"
- else
- mytarget="nogui"
- fi
-
- emake \
- CC="$(tc-getCC)" \
- ${mytarget} || die "make failed"
-}
-
-src_install() {
- dobin "${S}"/prekin || die "dobin failed"
-}