summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-06 09:02:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-06 09:02:39 +0000
commit00fb7eac2a14ce166c62356a03f5d59df9159b88 (patch)
tree2d19238ef700ec40792733dd83bed0237ab56a93 /sci-chemistry/probe
parentmarked x86 per bug 418729 (diff)
downloadgentoo-2-00fb7eac2a14ce166c62356a03f5d59df9159b88.tar.gz
gentoo-2-00fb7eac2a14ce166c62356a03f5d59df9159b88.tar.bz2
gentoo-2-00fb7eac2a14ce166c62356a03f5d59df9159b88.zip
sci-chemistry/probe: Version BUmp
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/probe')
-rw-r--r--sci-chemistry/probe/ChangeLog8
-rw-r--r--sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch25
-rw-r--r--sci-chemistry/probe/probe-2.13.110909.ebuild34
3 files changed, 66 insertions, 1 deletions
diff --git a/sci-chemistry/probe/ChangeLog b/sci-chemistry/probe/ChangeLog
index 2dd434bf9254..757b41f3df03 100644
--- a/sci-chemistry/probe/ChangeLog
+++ b/sci-chemistry/probe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/probe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/ChangeLog,v 1.14 2012/06/06 08:54:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/ChangeLog,v 1.15 2012/06/06 09:02:39 jlec Exp $
+
+*probe-2.13.110909 (06 Jun 2012)
+
+ 06 Jun 2012; Justin Lecher <jlec@gentoo.org> +probe-2.13.110909.ebuild,
+ +files/probe-2.13.110909-as-needed.patch:
+ Version BUmp
06 Jun 2012; Justin Lecher <jlec@gentoo.org> probe-2.12.110413.ebuild:
minor cleaning
diff --git a/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
new file mode 100644
index 000000000000..df7040c3ba1d
--- /dev/null
+++ b/sci-chemistry/probe/files/probe-2.13.110909-as-needed.patch
@@ -0,0 +1,25 @@
+ Makefile | 8 +++-----
+ 1 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9031bd0..8f74d6a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,12 @@
+-MACHINEFLAGS =
+-CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -static -lm $(MACHINEFLAGS)
++LIBS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+ .c.o:
+- cc -c $*.c $(CFLAGS)
++ $(CC) $(CFLAGS) -c $*.c
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ probe.o $(OBJLIST) $(LIBS)
+
+ clean:
+ @rm -f *.o *.ckp
diff --git a/sci-chemistry/probe/probe-2.13.110909.ebuild b/sci-chemistry/probe/probe-2.13.110909.ebuild
new file mode 100644
index 000000000000..8b7fc38dee24
--- /dev/null
+++ b/sci-chemistry/probe/probe-2.13.110909.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/probe-2.13.110909.ebuild,v 1.1 2012/06/06 09:02:39 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Evaluates atomic packing within or between molecules"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
+
+SLOT="0"
+LICENSE="richardson"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}.src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin "${S}"/probe
+ dodoc "${S}"/README*
+}