summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-05-26 15:23:43 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-05-26 15:23:43 +0000
commitcb5305be26fde12848e0c149c4ee0c6b6c3a1ac0 (patch)
tree80cbad80221b8a36d02d2e13eb649bd39f032a4b /sci-chemistry/pymol
parentStable on amd64 wrt bug #132213 (diff)
downloadgentoo-2-cb5305be26fde12848e0c149c4ee0c6b6c3a1ac0.tar.gz
gentoo-2-cb5305be26fde12848e0c149c4ee0c6b6c3a1ac0.tar.bz2
gentoo-2-cb5305be26fde12848e0c149c4ee0c6b6c3a1ac0.zip
Moved path variable declarations from the wrapper to an env.d file
(Portage version: 2.0.54-r2)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog9
-rw-r--r--sci-chemistry/pymol/Manifest2
-rw-r--r--sci-chemistry/pymol/files/digest-pymol-0.99_rc6-r21
-rw-r--r--sci-chemistry/pymol/pymol-0.99_rc6-r2.ebuild80
4 files changed, 91 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 9422094c67ca..d8c07f1e62ba 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.13 2006/03/16 03:41:51 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.14 2006/05/26 15:23:43 ribosome Exp $
+
+*pymol-0.99_rc6-r2 (26 May 2006)
+
+ 26 May 2006; Olivier Fisette <ribosome@gentoo.org>
+ +pymol-0.99_rc6-r2.ebuild:
+ Moved path variable declarations from the wrapper to an env.d file
+ (necessary for Python scripting).
*pymol-0.99_rc6-r1 (16 Mar 2006)
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 51b809fd0d4b..958a7383927a 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -3,6 +3,7 @@ MD5 cb324029606a6b5048895957143c7a44 files/digest-pymol-0.97 64
MD5 2dbc83e197b07cf99e7b02a03555a3d6 files/digest-pymol-0.98 64
MD5 925dc45d0ae6070f5506dffc1d100975 files/digest-pymol-0.99_rc6 247
MD5 9c414f568a3de5c4af6aee28e735a7a3 files/digest-pymol-0.99_rc6-r1 67
+MD5 9c414f568a3de5c4af6aee28e735a7a3 files/digest-pymol-0.99_rc6-r2 67
MD5 1a6ba582a7928c370c8dfe44c8867e7c files/header_order.patch 905
MD5 929741dc2da6577e6e99c5542d68dbd5 files/nosplash-gentoo.patch 332
MD5 035c32a87c619d2c2cf6c0d7466d92e0 files/pymol-0.99_rc6-data-path.patch 2473
@@ -13,4 +14,5 @@ MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 2e14ab661047ad8d8c2fe6b21b72c5cc pymol-0.97.ebuild 1131
MD5 178d73732fb90d64350e98c172b9b594 pymol-0.98.ebuild 1131
MD5 03c375c56799851b4df5b75cdb5f2720 pymol-0.99_rc6-r1.ebuild 1811
+MD5 285353e685d12202898634d5769742d6 pymol-0.99_rc6-r2.ebuild 2207
MD5 e339da592644e001ae3b497400f08716 pymol-0.99_rc6.ebuild 1720
diff --git a/sci-chemistry/pymol/files/digest-pymol-0.99_rc6-r2 b/sci-chemistry/pymol/files/digest-pymol-0.99_rc6-r2
new file mode 100644
index 000000000000..fd7a889871f4
--- /dev/null
+++ b/sci-chemistry/pymol/files/digest-pymol-0.99_rc6-r2
@@ -0,0 +1 @@
+MD5 cb29385ab523f648d4db47a222b1d03e pymol-0_99rc6-src.tgz 4198816
diff --git a/sci-chemistry/pymol/pymol-0.99_rc6-r2.ebuild b/sci-chemistry/pymol/pymol-0.99_rc6-r2.ebuild
new file mode 100644
index 000000000000..b0cdf0bfd595
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.99_rc6-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.99_rc6-r2.ebuild,v 1.1 2006/05/26 15:23:43 ribosome Exp $
+
+inherit distutils eutils multilib
+
+MY_PV=${PV/_}
+MY_S_P="${PN}-${MY_PV}"
+MY_PV=${MY_PV/./_}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymol/${MY_P}-src.tgz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/python
+ dev-python/pmw
+ dev-python/numeric
+ dev-lang/tk
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/glut"
+S="${WORKDIR}/${MY_S_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/modules/${PN}
+ epatch "${FILESDIR}"/${P}-data-path.patch
+ cd "${S}"
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch "${FILESDIR}"/nosplash-gentoo.patch
+
+ # Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py
+}
+
+src_install() {
+ python_version
+
+ distutils_src_install
+ cd "${S}"
+
+ #The following three lines probably do not do their jobs and should be
+ #changed
+ PYTHONPATH="${D}/usr/$(get_libdir)/site-packages" ${python} setup2.py
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+cat >> "${T}"/20pymol << EOF
+PYMOL_PATH=/usr/lib/python${PYVER}/site-packages/pymol
+PYMOL_DATA="/usr/share/pymol/data"
+PYMOL_SCRIPTS="/usr/share/pymol/scripts"
+EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+ # Make our own wrapper
+cat >> "${T}"/pymol << EOF
+#!/bin/sh
+${python} \${PYMOL_PATH}/__init__.py \$*
+EOF
+
+ exeinto /usr/bin
+ doexe "${T}"/pymol || die "Failed to install wrapper."
+ dodoc DEVELOPERS CHANGES || die "Failed to install docs."
+
+ mv examples "${D}"/usr/share/doc/${PF}/ || die "Failed moving docs."
+
+ dodir /usr/share/pymol
+ mv test "${D}"/usr/share/pymol/ || die "Failed moving test files."
+ mv data "${D}"/usr/share/pymol/ || die "Failed moving data files."
+ mv scripts "${D}"/usr/share/pymol/ || die "Failed moving scripts."
+}