summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-27 07:58:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-27 07:58:28 +0000
commit466d9561e0752cce3046995583da1438c002a74f (patch)
tree5b46ab83379de60f3ea3237e9f9573504226ef34 /sci-chemistry/relax
parentapp-text/multitail: Version BUmp (diff)
downloadgentoo-2-466d9561e0752cce3046995583da1438c002a74f.tar.gz
gentoo-2-466d9561e0752cce3046995583da1438c002a74f.tar.bz2
gentoo-2-466d9561e0752cce3046995583da1438c002a74f.zip
sci-chemistry/relax: Version Bump
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/relax')
-rw-r--r--sci-chemistry/relax/ChangeLog8
-rw-r--r--sci-chemistry/relax/relax-2.2.5.ebuild6
-rw-r--r--sci-chemistry/relax/relax-3.0.2.ebuild67
3 files changed, 77 insertions, 4 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index ff459b9e4414..e8562b1c1e52 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.7 2013/11/16 08:25:43 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.8 2013/11/27 07:58:28 jlec Exp $
+
+*relax-3.0.2 (27 Nov 2013)
+
+ 27 Nov 2013; Justin Lecher <jlec@gentoo.org> relax-2.2.5.ebuild,
+ +relax-3.0.2.ebuild:
+ Version Bump
16 Nov 2013; Ryan Hill <dirtyepic@gentoo.org> relax-2.1.0.ebuild,
relax-2.2.1.ebuild, relax-2.2.5.ebuild, relax-3.0.1.ebuild:
diff --git a/sci-chemistry/relax/relax-2.2.5.ebuild b/sci-chemistry/relax/relax-2.2.5.ebuild
index b1382483f56f..0bfb6d253f44 100644
--- a/sci-chemistry/relax/relax-2.2.5.ebuild
+++ b/sci-chemistry/relax/relax-2.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-2.2.5.ebuild,v 1.4 2013/11/16 08:25:43 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-2.2.5.ebuild,v 1.5 2013/11/27 07:58:28 jlec Exp $
EAPI=5
@@ -50,8 +50,8 @@ src_compile() {
}
src_test() {
- ${EPYTHON} ./${PN}.py -s || die
- ${EPYTHON} ./${PN}.py -x || die
+# ${EPYTHON} ./${PN}.py -s || die
+ ${EPYTHON} ./${PN}.py --gui-tests || die
}
src_install() {
diff --git a/sci-chemistry/relax/relax-3.0.2.ebuild b/sci-chemistry/relax/relax-3.0.2.ebuild
new file mode 100644
index 000000000000..eda95f4bc01f
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.0.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.0.2.ebuild,v 1.1 2013/11/27 07:58:28 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.8"
+
+inherit eutils python-single-r1 scons-utils toolchain-funcs wxwidgets
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.1_pre198[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.4_pre98[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib || die
+ epatch "${FILESDIR}"/${PN}-3.0.1-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ ${EPYTHON} ./${PN}.py -s || die
+# ${EPYTHON} ./${PN}.py -x || die
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf,prompt_screenshot.txt}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}