summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 19:35:37 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 19:35:37 +0000
commit0b7d7ae48e75c833c17edb346b73f3d36c583722 (patch)
tree5c59b07fd31c145f38c301b7ab6fa6d4f6563048 /sci-chemistry/tinker
parentAdd ~sparc (diff)
downloadgentoo-2-0b7d7ae48e75c833c17edb346b73f3d36c583722.tar.gz
gentoo-2-0b7d7ae48e75c833c17edb346b73f3d36c583722.tar.bz2
gentoo-2-0b7d7ae48e75c833c17edb346b73f3d36c583722.zip
Version Bump and old version removed
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/tinker')
-rw-r--r--sci-chemistry/tinker/ChangeLog10
-rw-r--r--sci-chemistry/tinker/tinker-4.2-r1.ebuild121
-rw-r--r--sci-chemistry/tinker/tinker-5.1.ebuild76
3 files changed, 84 insertions, 123 deletions
diff --git a/sci-chemistry/tinker/ChangeLog b/sci-chemistry/tinker/ChangeLog
index 9a3f030941aa..84d281f631fd 100644
--- a/sci-chemistry/tinker/ChangeLog
+++ b/sci-chemistry/tinker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/tinker
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.12 2009/12/14 13:55:26 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.13 2010/02/13 19:35:37 jlec Exp $
+
+*tinker-5.1 (13 Feb 2010)
+
+ 13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> -tinker-4.2-r1.ebuild,
+ +tinker-5.1.ebuild:
+ Version Bump and old version removed
14 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
tinker-4.2-r1.ebuild:
diff --git a/sci-chemistry/tinker/tinker-4.2-r1.ebuild b/sci-chemistry/tinker/tinker-4.2-r1.ebuild
deleted file mode 100644
index 6b91053dbf0a..000000000000
--- a/sci-chemistry/tinker/tinker-4.2-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-4.2-r1.ebuild,v 1.6 2009/12/14 13:55:26 flameeyes Exp $
-
-inherit fortran toolchain-funcs
-
-FORTRAN="g77 gfortran ifc"
-
-DESCRIPTION="TINKER is a molecular modeling package that includes force fields for handing large molecules and large systems, such as AMBER and CHARMM. A Java based visualization front end is included."
-HOMEPAGE="http://dasher.wustl.edu/tinker/"
-SRC_URI="ftp://dasher.wustl.edu/pub/tinker.tar.gz"
-IUSE="X"
-LICENSE="Tinker"
-SLOT="0"
-KEYWORDS="~x86"
-
-# file collision, bug #279018
-DEPEND="!dev-util/diffuse
- X? ( dev-java/sun-java3d-bin )"
-S=${WORKDIR}/tinker/source
-
-src_compile() {
- if use X; then
- COMPGUI="./compgui.make"
- LINK="./linkgui.make"
- cp ../jar/linux/sockets.c .
- else
- LINK="./link.make"
- fi
-
- COMPILE="./compile.make"
- LIBRARY="./library.make"
-
- # Need to make sure all of the appropriate config files are in place
- # for the build.
- # This should be easily customizable for other Fortran compilers, e.g. pg77.
- if [[ ${FORTRANC} == "ifc" ]]; then
- cp ../linux/intel/* .
- else
- cp ../linux/gnu/* .
- fi
-
- cp ../make/* .
-
- # Prep build scripts
- if use X; then
- sed -i \
- -e "s:-O3:${CFLAGS}:" \
- -e "s:gcc:$(tc-getCC):" \
- ${COMPGUI}
- local JAVA_HOME=$(java-config --jdk-home)
- local JAVA_LIB_PATH="${JAVA_HOME}/jre/lib/i386/client"
- ln -s ${JAVA_LIB_PATH}/libjvm.so
- sed -i -e "s:/local/java/j2sdk1.4.2_05:${JAVA_HOME}:g" ${COMPGUI}
- sed -i -e "s:g77:${FORTRANC}:g" ${LINK}
- fi
- # Default to -O2 if FFLAGS is unset
- sed -i -e "s:-O3 -ffast-math:${FFLAGS:- -O2}:" ${COMPILE}
- sed -i -e "s:g77:${FORTRANC}:g" ${COMPILE}
-
- # Prep executable script - the one packaged with the distro is b0rked
- if use X; then
- echo 'java -Djava.library.path=$(java-config -i sun-java3d-bin) -cp $(java-config -p sun-java3d-bin):/usr/lib/tinker/ffe.jar ffe.Main' > tinker
- fi
-
- einfo "Compiling ..."
- if use X; then
- ${COMPGUI} || die "GUI compile failed"
- fi
- ${COMPILE} || die "compile failed"
- einfo "Building libraries ..."
- ${LIBRARY} || die "library creation failed"
- einfo "Linking ..."
- ${LINK} || die "link failed"
-}
-
-src_install() {
- exeinto /usr/bin
-
- dodoc \
- ${WORKDIR}/tinker/doc/*.txt \
- ${WORKDIR}/tinker/doc/release-4.2 \
- ${WORKDIR}/tinker/doc/*.pdf
-
- if use X; then
- dolib.so ${WORKDIR}/tinker/jar/linux/libffe.so || die
- fi
-
- dolib.a libtinker.a || die
-
- insinto /usr/lib/tinker
- if use X; then
- doins ${WORKDIR}/tinker/jar/ffe.jar || die
- fi
-
- for EXE in *.x; do
- newexe ${EXE} ${EXE%.x} || die
- done
-
- if use X; then
- doexe tinker || die
- fi
-
- docinto example
- dodoc ${WORKDIR}/tinker/example/*
- docinto test
- dodoc ${WORKDIR}/tinker/test/*
-
- doexe ${WORKDIR}/tinker/perl/mdavg || die
-
- insinto /usr/share/tinker/params
- doins ${WORKDIR}/tinker/params/* || die
-}
-
-pkg_postinst() {
- einfo "Tinker binaries installed to ${ROOT}usr/bin."
- einfo "Parameter files installed to ${ROOT}usr/share/tinker/params."
- einfo "Call the Java X front-end, Force-Field Explorer, with 'tinker.'"
- einfo "It doesn't seem to detect installed Java3D yet, fixes welcome."
- einfo "You must edit ${ROOT}usr/bin/tinker if you aren't using Blackdown."
-}
diff --git a/sci-chemistry/tinker/tinker-5.1.ebuild b/sci-chemistry/tinker/tinker-5.1.ebuild
new file mode 100644
index 000000000000..54b88ccdadda
--- /dev/null
+++ b/sci-chemistry/tinker/tinker-5.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.ebuild,v 1.1 2010/02/13 19:35:37 jlec Exp $
+
+EAPI="2"
+FORTRAN="gfortran ifc"
+
+inherit fortran
+
+DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM."
+HOMEPAGE="http://dasher.wustl.edu/tinker/"
+SRC_URI="http://dasher.wustl.edu/tinker/downloads/tinker.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Tinker"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# RDEPEND="dev-java/j3d-core"
+RESTRICT="mirror"
+
+S="${WORKDIR}"/tinker/source
+
+src_compile() {
+ LINK="./link.make"
+ COMPILE="./compile.make"
+ LIBRARY="./library.make"
+
+ # Need to make sure all of the appropriate config files are in place
+ # for the build.
+ # This should be easily customizable for other Fortran compilers, e.g. pg77.
+ if [[ ${FORTRANC} == "ifort" ]]; then
+ cp ../linux/intel/* .
+ else
+ cp ../linux/gfortran/* .
+ fi
+
+ cp ../make/* .
+
+ # Prep build scripts
+ sed -i -e "s:gfortran:${FORTRANC} ${LDFLAGS}:g" ${LINK}
+ sed -r -i -e "s:^${FORTRANC}.+$:echo &\n&:" ${LINK}
+
+ # Default to -O2 if FFLAGS is unset
+ sed -i -e "s:-O:${FFLAGS:- -O2}:" ${COMPILE}
+ sed -r -i -e "s:^${FORTRANC}.+$:echo &\n&:" ${COMPILE}
+
+ einfo "Compiling ..."
+ ${COMPILE} || die "compile failed"
+ einfo "Building libraries ..."
+ ${LIBRARY} || die "library creation failed"
+ einfo "Linking ..."
+ ${LINK} || die "link failed"
+}
+
+src_install() {
+ dodoc \
+ "${WORKDIR}"/tinker/doc/{*.txt,announce/release-*,*.pdf,0README} || die
+
+ dolib.a libtinker.a || die
+
+ for EXE in *.x; do
+ newbin ${EXE} ${EXE%.x} || die
+ done
+
+ docinto example
+ dodoc "${WORKDIR}"/tinker/example/* || die
+
+ docinto test
+ dodoc "${WORKDIR}"/tinker/test/* || die
+
+ dobin "${WORKDIR}"/tinker/perl/mdavg || die
+
+ insinto /usr/share/tinker/params
+ doins "${WORKDIR}"/tinker/params/* || die
+}