summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-08-25 20:25:13 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-08-25 20:25:13 +0000
commite7b6e53105bb6e0f9b0ee6a09fa8b686d9059395 (patch)
tree4ce901a1447db42ae6b676e5d775bc830d541469 /sci-chemistry/votca-csg
parentAdded ~mips (diff)
downloadgentoo-2-e7b6e53105bb6e0f9b0ee6a09fa8b686d9059395.tar.gz
gentoo-2-e7b6e53105bb6e0f9b0ee6a09fa8b686d9059395.tar.bz2
gentoo-2-e7b6e53105bb6e0f9b0ee6a09fa8b686d9059395.zip
version bump
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog8
-rw-r--r--sci-chemistry/votca-csg/metadata.xml1
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.2.1.ebuild (renamed from sci-chemistry/votca-csg/votca-csg-1.2.ebuild)22
3 files changed, 17 insertions, 14 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
index f88ca3a2739c..66da50211e56 100644
--- a/sci-chemistry/votca-csg/ChangeLog
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/votca-csg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.7 2011/08/14 15:17:01 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.8 2011/08/25 20:25:13 ottxor Exp $
+
+*votca-csg-1.2.1 (25 Aug 2011)
+
+ 25 Aug 2011; Christoph Junghans <ottxor@gentoo.org> -votca-csg-1.2.ebuild,
+ +votca-csg-1.2.1.ebuild, metadata.xml:
+ version bump
14 Aug 2011; Christoph Junghans <ottxor@gentoo.org> -votca-csg-1.1.1.ebuild,
-votca-csg-1.1.2.ebuild, votca-csg-1.2.ebuild, metadata.xml:
diff --git a/sci-chemistry/votca-csg/metadata.xml b/sci-chemistry/votca-csg/metadata.xml
index 2b261601af3e..b78ffaa93a74 100644
--- a/sci-chemistry/votca-csg/metadata.xml
+++ b/sci-chemistry/votca-csg/metadata.xml
@@ -9,5 +9,6 @@
<use>
<flag name='gromacs'>Add support for gromacs file formats through <pkg>sci-chemistry/gromacs</pkg></flag>
<flag name='system-boost'>Use system boost (<pkg>dev-libs/boost</pkg>) instead of bundled one</flag>
+ <flag name='extras'>Pull in extra applications from <pkg>sci-chemistry/votca-csg-apps</pkg></flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/votca-csg/votca-csg-1.2.ebuild b/sci-chemistry/votca-csg/votca-csg-1.2.1.ebuild
index 4b05ee2b3f01..d658c852aa13 100644
--- a/sci-chemistry/votca-csg/votca-csg-1.2.ebuild
+++ b/sci-chemistry/votca-csg/votca-csg-1.2.1.ebuild
@@ -1,30 +1,26 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.ebuild,v 1.3 2011/08/14 15:17:01 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.2.1.ebuild,v 1.1 2011/08/25 20:25:13 ottxor Exp $
EAPI=4
inherit bash-completion cmake-utils
-MANUAL_PV=1.2
-TUTORIAL_PV=1.2
-IUSE="doc examples +gromacs +system-boost"
+IUSE="doc examples extras +gromacs +system-boost"
+PDEPEND="extras? ( =sci-chemistry/votca-csgapps-${PV} )"
if [ "${PV}" != "9999" ]; then
SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz
- doc? ( http://votca.googlecode.com/files/votca-manual-${MANUAL_PV}.pdf )
- examples? ( http://votca.googlecode.com/files/votca-tutorials-${TUTORIAL_PV}.tar.gz )"
+ doc? ( http://votca.googlecode.com/files/votca-manual-${PV}.pdf )
+ examples? ( http://votca.googlecode.com/files/votca-tutorials-${PV}.tar.gz )"
RESTRICT="primaryuri"
else
SRC_URI=""
- #make this a common use when csg-apps get released
- IUSE="${IUSE} extras"
inherit mercurial
EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
EHG_REVISION="default"
S="${WORKDIR}/${EHG_REPO_URI##*/}"
- PDEPEND="doc? ( =app-doc/votca-csg-manual-${PV} )
- examples? ( =sci-chemistry/votca-csg-tutorials-${PV} )
- extras? ( =sci-chemistry/votca-csg-apps-${PV} )"
+ PDEPEND="${PDEPEND} doc? ( =app-doc/votca-csg-manual-${PV} )
+ examples? ( =sci-chemistry/votca-csg-tutorials-${PV} )"
fi
DESCRIPTION="Votca coarse-graining engine"
@@ -65,7 +61,7 @@ src_install() {
cmake-utils_src_install
if use doc; then
if [ -n "${PV##*9999}" ]; then
- dodoc "${DISTDIR}/votca-manual-${MANUAL_PV}.pdf"
+ dodoc "${DISTDIR}/votca-manual-${PV}.pdf"
fi
cd "${CMAKE_BUILD_DIR}" || die
cd share/doc || die
@@ -75,7 +71,7 @@ src_install() {
if use examples && [ -n "${PV##*9999}" ]; then
insinto "/usr/share/doc/${PF}/tutorials"
docompress -x "/usr/share/doc/${PF}/tutorials"
- doins -r "${WORKDIR}/votca-tutorials-${TUTORIAL_PV}"/*
+ doins -r "${WORKDIR}/votca-tutorials-${PV}"/*
fi
}