summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-14 18:53:30 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-14 18:53:30 +0000
commit7b2d4f8c57bc0b4caaae4a4acaafc5b08e13d720 (patch)
tree7de6c4f58a4b9f4955eed40b8d0deee587048991 /sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild
parentVersion bump. (diff)
downloadgentoo-2-7b2d4f8c57bc0b4caaae4a4acaafc5b08e13d720.tar.gz
gentoo-2-7b2d4f8c57bc0b4caaae4a4acaafc5b08e13d720.tar.bz2
gentoo-2-7b2d4f8c57bc0b4caaae4a4acaafc5b08e13d720.zip
(#114260) Bump. Supports openbabel-2.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild')
-rw-r--r--sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild b/sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild
new file mode 100644
index 000000000000..7abfe7d6e5a7
--- /dev/null
+++ b/sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xdrawchem/xdrawchem-1.9.9.ebuild,v 1.1 2006/05/14 18:53:30 spyderous Exp $
+
+inherit qt3
+
+DESCRIPTION="Molecular structure drawing program"
+HOMEPAGE="http://xdrawchem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="$(qt_min_version 3.1)
+ >=sys-devel/gcc-3.2
+ dev-util/pkgconfig
+ >=sci-chemistry/openbabel-2"
+
+src_compile() {
+ # make sure we use moc from Qt, not from eg media-sound/moc
+ PATH="${QTDIR}/bin:${PATH}"
+ econf || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed."
+ cd ${D}/usr/share
+ dodir /usr/share/doc
+ mv xdrawchem/doc doc/${PF}
+ dosym /usr/share/doc/${PF} /usr/share/xdrawchem/doc
+}