summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-10 15:38:20 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-10 15:38:20 +0000
commit4f5cc73ee2dc31abdfc6c082563f345564baf306 (patch)
tree705e331d982174a0da447a81a566f69f6139660f /sci-chemistry
parentVersion bump (diff)
downloadgentoo-2-4f5cc73ee2dc31abdfc6c082563f345564baf306.tar.gz
gentoo-2-4f5cc73ee2dc31abdfc6c082563f345564baf306.tar.bz2
gentoo-2-4f5cc73ee2dc31abdfc6c082563f345564baf306.zip
Fix for compilation with gcc-4.6 (-fwhole-file), #362843; use pkg-config to get lapack libs
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/scala/ChangeLog9
-rw-r--r--sci-chemistry/scala/files/3.3.18-gcc4.6.patch17
-rw-r--r--sci-chemistry/scala/files/Makefile.am2
-rw-r--r--sci-chemistry/scala/files/configure.ac2
-rw-r--r--sci-chemistry/scala/scala-3.3.18-r2.ebuild38
5 files changed, 66 insertions, 2 deletions
diff --git a/sci-chemistry/scala/ChangeLog b/sci-chemistry/scala/ChangeLog
index 50ff9ccd38ba..e3d09d6e3e80 100644
--- a/sci-chemistry/scala/ChangeLog
+++ b/sci-chemistry/scala/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/scala
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/ChangeLog,v 1.7 2011/01/18 17:01:49 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/ChangeLog,v 1.8 2011/04/10 15:38:20 jlec Exp $
+
+*scala-3.3.18-r2 (10 Apr 2011)
+
+ 10 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/3.3.18-gcc4.6.patch,
+ +scala-3.3.18-r2.ebuild, files/Makefile.am, files/configure.ac:
+ Fix for compilation with gcc-4.6 (-fwhole-file), #362843; use pkg-config to
+ get lapack libs
18 Jan 2011; Thomas Kahle <tomka@gentoo.org> scala-3.3.18-r1.ebuild:
x86 stable per bug 351756
diff --git a/sci-chemistry/scala/files/3.3.18-gcc4.6.patch b/sci-chemistry/scala/files/3.3.18-gcc4.6.patch
new file mode 100644
index 000000000000..0bb3d40d479a
--- /dev/null
+++ b/sci-chemistry/scala/files/3.3.18-gcc4.6.patch
@@ -0,0 +1,17 @@
+ scala.f | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/scala.f b/scala.f
+index d7e1cbe..8ed6fd2 100644
+--- a/scala.f
++++ b/scala.f
+@@ -3955,7 +3955,8 @@ c line buffer
+ character*40 key, value
+ character*200 realfilename
+
+- integer intfp, i2swap, lenstr
++ integer intfp, lenstr
++ integer*2 i2swap
+ external intfp, i2swap, lenstr
+ logical litend
+ external litend
diff --git a/sci-chemistry/scala/files/Makefile.am b/sci-chemistry/scala/files/Makefile.am
index b16394b8817c..49fd61180ef0 100644
--- a/sci-chemistry/scala/files/Makefile.am
+++ b/sci-chemistry/scala/files/Makefile.am
@@ -1,5 +1,5 @@
-LIBS = -lccp4f -llapack
+LIBS = -lccp4f $(LAPACK_LIBS)
bin_PROGRAMS = scala
diff --git a/sci-chemistry/scala/files/configure.ac b/sci-chemistry/scala/files/configure.ac
index bcbd7dededa2..35c4c7fdd194 100644
--- a/sci-chemistry/scala/files/configure.ac
+++ b/sci-chemistry/scala/files/configure.ac
@@ -6,6 +6,8 @@ AC_INIT(scala, https://bugs.gentoo.org/)
AC_CONFIG_SRCDIR([scala.f])
AM_INIT_AUTOMAKE([foreign])
+PKG_CHECK_MODULES([LAPACK],[lapack])
+
# Checks for programs.
AC_PROG_FC
AC_PROG_F77
diff --git a/sci-chemistry/scala/scala-3.3.18-r2.ebuild b/sci-chemistry/scala/scala-3.3.18-r2.ebuild
new file mode 100644
index 000000000000..6e2d5a820a5f
--- /dev/null
+++ b/sci-chemistry/scala/scala-3.3.18-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/scala/scala-3.3.18-r2.ebuild,v 1.1 2011/04/10 15:38:20 jlec Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Scale together multiple observations of reflections"
+HOMEPAGE="http://www.ccp4.ac.uk/dist/html/scala.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-libs/ccp4-libs
+ virtual/lapack
+ !<sci-chemistry/ccp4-6.1.2"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc4.6.patch
+ cp "${FILESDIR}"/{configure.ac,Makefile.am} "${S}"
+ eautoreconf
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${PN} || die
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc ${PN}.doc || die
+ dohtml ${PN}.html || die
+}