summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-30 13:44:13 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-30 13:44:13 +0000
commit53ddbc200464cde2d0c9413339ff845687db57fa (patch)
tree5bd7d17d79b3667c41bc82932544156f72e08e62 /sci-chemistry
parentCorrect location of atmtypenumber file (diff)
downloadgentoo-2-53ddbc200464cde2d0c9413339ff845687db57fa.tar.gz
gentoo-2-53ddbc200464cde2d0c9413339ff845687db57fa.tar.bz2
gentoo-2-53ddbc200464cde2d0c9413339ff845687db57fa.zip
New addition
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/threeV/ChangeLog10
-rw-r--r--sci-chemistry/threeV/files/1.2-gentoo.patch107
-rw-r--r--sci-chemistry/threeV/metadata.xml8
-rw-r--r--sci-chemistry/threeV/threeV-1.2.ebuild34
4 files changed, 159 insertions, 0 deletions
diff --git a/sci-chemistry/threeV/ChangeLog b/sci-chemistry/threeV/ChangeLog
new file mode 100644
index 000000000000..f943cf8eda5b
--- /dev/null
+++ b/sci-chemistry/threeV/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/threeV
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/threeV/ChangeLog,v 1.1 2010/10/30 13:44:13 jlec Exp $
+
+*threeV-1.2 (30 Oct 2010)
+
+ 30 Oct 2010; Justin Lecher <jlec@gentoo.org> +files/1.2-gentoo.patch,
+ +threeV-1.2.ebuild, +metadata.xml:
+ New addition
+
diff --git a/sci-chemistry/threeV/files/1.2-gentoo.patch b/sci-chemistry/threeV/files/1.2-gentoo.patch
new file mode 100644
index 000000000000..0827551599ba
--- /dev/null
+++ b/sci-chemistry/threeV/files/1.2-gentoo.patch
@@ -0,0 +1,107 @@
+diff --git a/src/Makefile b/src/Makefile
+index a58462c..616f51a 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,7 +1,7 @@
+-CC = g++
+-EXT=$(shell ./cpuflags.pl --opt )
+-FLAGS = -Wall $(EXT)
+-#FLAGS = -O3 -Wall -ffast-math
++CXX ?= g++
++#EXT=$(shell ./cpuCXXFLAGS.pl --opt )
++#CXXFLAGS = -Wall $(EXT)
++#CXXFLAGS = -O3 -Wall -ffast-math
+ OBJS = utils-main.o utils-output.o utils-mrc.o
+
+ all: cav chan fsv sol tun vdw vol
+@@ -17,54 +17,65 @@ volume: vol
+ objects: utils-main.o utils-output.o utils-mrc.o
+
+ cav: objects cavities.cpp
+- $(CC) $(FLAGS) -o Cavities.exe $(OBJS) cavities.cpp
+- chmod 777 Cavities.exe
+- mv Cavities.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o cavities.o cavities.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o Cavities $(OBJS) cavities.o
++ chmod 755 Cavities
++ mv Cavities ../bin
+
+ chan: objects channel.cpp
+- $(CC) $(FLAGS) -o Channel.exe $(OBJS) channel.cpp
+- chmod 777 Channel.exe
+- mv Channel.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o channel.o channel.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o Channel $(OBJS) channel.o
++ chmod 755 Channel
++ mv Channel ../bin
+
+ fsv: objects fsv_calc.cpp
+- $(CC) $(FLAGS) -o FsvCalc.exe $(OBJS) fsv_calc.cpp
+- chmod 777 FsvCalc.exe
+- mv FsvCalc.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o fsv_calc.o fsv_calc.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o FsvCalc $(OBJS) fsv_calc.o
++ chmod 755 FsvCalc
++ mv FsvCalc ../bin
+
+ sol: objects solvent.cpp
+- $(CC) $(FLAGS) -o Solvent.exe $(OBJS) solvent.cpp
+- chmod 777 Solvent.exe
+- mv Solvent.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o solvent.o solvent.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o Solvent $(OBJS) solvent.o
++ chmod 755 Solvent
++ mv Solvent ../bin
+
+ tun: objects tunnel.cpp
+- $(CC) $(FLAGS) -o Tunnel.exe $(OBJS) tunnel.cpp
+- chmod 777 Tunnel.exe
+- mv Tunnel.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o tunnel.o tunnel.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o Tunnel $(OBJS) tunnel.o
++ chmod 755 Tunnel
++ mv Tunnel ../bin
+
+ vdw: objects vdw.cpp
+- $(CC) $(FLAGS) -o VDW.exe $(OBJS) vdw.cpp
+- chmod 777 VDW.exe
+- mv VDW.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o vdw.o vdw.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o VDW $(OBJS) vdw.o
++ chmod 755 VDW
++ mv VDW ../bin
+
+ vol: objects volume.cpp
+- $(CC) $(FLAGS) -o Volume.exe $(OBJS) volume.cpp
+- chmod 777 Volume.exe
+- mv Volume.exe ../bin
++ $(CXX) $(CXXFLAGS) -c -o volume.o volume.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o Volume $(OBJS) volume.o
++ chmod 755 Volume
++ mv Volume ../bin
+
+ utils-main.o: utils-main.cpp
+- $(CC) $(FLAGS) -c -o utils-main.o utils-main.cpp
++ $(CXX) $(CXXFLAGS) -c -o utils-main.o utils-main.cpp
+
+ utils-output.o: utils-main.o utils-output.cpp
+- $(CC) $(FLAGS) -c -o utils-output.o utils-output.cpp
++ $(CXX) $(CXXFLAGS) -c -o utils-output.o utils-output.cpp
+
+ utils-mrc.o: utils-mrc.cpp
+- $(CC) $(FLAGS) -c -o utils-mrc.o utils-mrc.cpp
++ $(CXX) $(CXXFLAGS) -c -o utils-mrc.o utils-mrc.cpp
++
++install:
++ install -d $(DESTDIR)/usr/bin
++ install ../bin/* $(DESTDIR)/usr/bin/
+
+ clean:
+ rm -fv *.o *~
+
+ distclean:
+- rm -fv *.o ../bin/*.exe *~
++ rm -fv *.o ../bin/* *~
+
+ none:
+ echo "Please type make xxx, where xxx = cav, cha, fsv, sol, tun, vdw, or vol"
diff --git a/sci-chemistry/threeV/metadata.xml b/sci-chemistry/threeV/metadata.xml
new file mode 100644
index 000000000000..043cc7527474
--- /dev/null
+++ b/sci-chemistry/threeV/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/threeV/threeV-1.2.ebuild b/sci-chemistry/threeV/threeV-1.2.ebuild
new file mode 100644
index 000000000000..ee1e35af8d7d
--- /dev/null
+++ b/sci-chemistry/threeV/threeV-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/threeV/threeV-1.2.ebuild,v 1.1 2010/10/30 13:44:13 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="3V: Voss Volume Voxelator"
+HOMEPAGE="http://geometry.molmovdb.org/3v/"
+SRC_URI="http://geometry.molmovdb.org/3v/3v-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND="sci-chemistry/msms-bin"
+# sci-chemistry/usf-rave"
+
+S="${WORKDIR}/3v-${PV}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CXX
+ emake distclean || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ cd ..
+ dodoc AUTHORS ChangeLog QUICKSTART README TODO VERSION || die
+}