summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 10:28:14 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 10:28:14 +0000
commit60884ea0e07edbed079617e0af880c9bdb1f2e96 (patch)
treeece53c785cd6b6a5ea469f0d0448d217e1eb45b8 /sci-chemistry
parentsci-chemistry/scala: Remove virtual/fortran and always call fortran-2_pkg_set... (diff)
downloadgentoo-2-60884ea0e07edbed079617e0af880c9bdb1f2e96.tar.gz
gentoo-2-60884ea0e07edbed079617e0af880c9bdb1f2e96.tar.bz2
gentoo-2-60884ea0e07edbed079617e0af880c9bdb1f2e96.zip
sci-chemistry/sfcheck: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/sfcheck/ChangeLog9
-rw-r--r--sci-chemistry/sfcheck/metadata.xml8
-rw-r--r--sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild24
3 files changed, 20 insertions, 21 deletions
diff --git a/sci-chemistry/sfcheck/ChangeLog b/sci-chemistry/sfcheck/ChangeLog
index 35e55f44ec30..60140d3ada08 100644
--- a/sci-chemistry/sfcheck/ChangeLog
+++ b/sci-chemistry/sfcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/sfcheck
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/ChangeLog,v 1.10 2011/06/21 15:57:05 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/ChangeLog,v 1.11 2012/10/19 10:28:14 jlec Exp $
+
+ 19 Oct 2012; Justin Lecher <jlec@gentoo.org> sfcheck-7.03.18-r1.ebuild,
+ metadata.xml:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
21 Jun 2011; Justin Lecher <jlec@gentoo.org> sfcheck-7.03.18-r1.ebuild:
Add dependency on virtual/fortran
diff --git a/sci-chemistry/sfcheck/metadata.xml b/sci-chemistry/sfcheck/metadata.xml
index efb490d78817..d747d72a25b4 100644
--- a/sci-chemistry/sfcheck/metadata.xml
+++ b/sci-chemistry/sfcheck/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild b/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild
index 25ceb9561929..7974d44e349f 100644
--- a/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild
+++ b/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild,v 1.6 2011/06/21 15:57:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/sfcheck-7.03.18-r1.ebuild,v 1.7 2012/10/19 10:28:14 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils fortran-2 toolchain-funcs
@@ -12,13 +12,11 @@ HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/sfcheck.html"
SRC_URI="mirror://gentoo/${P}.tar.gz"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
LICENSE="ccp4"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="
- virtual/fortran
- sci-libs/ccp4-libs"
+RDEPEND="sci-libs/ccp4-libs"
DEPEND="${RDEPEND}
!<sci-chmistry/ccp4-apps-6.1.3"
@@ -27,22 +25,18 @@ S="${WORKDIR}"/${PN}
src_prepare() {
epatch "${FILESDIR}"/7.03.17-ldflags.patch
- emake \
- -C src \
- clean || die
+ emake -C src clean
}
src_compile() {
MR_FORT="$(tc-getFC) ${FFLAGS}" \
MR_LIBRARY="-lccp4f" \
- emake \
- -C src \
- all || die
+ emake -C src all
}
src_install() {
exeinto /usr/libexec/ccp4/bin/
- doexe bin/${PN} || die
+ doexe bin/${PN}
dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
- dodoc readme ${PN}.com.gz doc/${PN}* || die
+ dodoc readme ${PN}.com.gz doc/${PN}*
}