summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-27 17:03:21 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-27 17:03:21 +0000
commit6affaa43e16cb9df28cf5bd9f0f364a4c4be9427 (patch)
tree08748eebb6431398a4e8b9aca66769d5b2f36035 /sci-chemistry
parentadded missing REQUIRED_USE tag (diff)
downloadgentoo-2-6affaa43e16cb9df28cf5bd9f0f364a4c4be9427.tar.gz
gentoo-2-6affaa43e16cb9df28cf5bd9f0f364a4c4be9427.tar.bz2
gentoo-2-6affaa43e16cb9df28cf5bd9f0f364a4c4be9427.zip
sci-chemistry/pdb2pqr: Version Bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog8
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch45
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild108
3 files changed, 160 insertions, 1 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 6b70f1fa377b..d475c25007f7 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.40 2014/10/24 12:06:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.41 2014/10/27 17:03:21 jlec Exp $
+
+*pdb2pqr-1.9.0 (27 Oct 2014)
+
+ 27 Oct 2014; Justin Lecher <jlec@gentoo.org> +pdb2pqr-1.9.0.ebuild,
+ +files/pdb2pqr-1.9.0-flags.patch:
+ Version Bump
*pdb2pqr-1.8.0-r1 (24 Oct 2014)
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch
new file mode 100644
index 000000000000..fac32b233e6b
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.9.0-flags.patch
@@ -0,0 +1,45 @@
+ pdb2pka/SConscript | 9 ++++++++-
+ pdb2pka/substruct/SConscript | 6 ++++++
+ 2 files changed, 14 insertions(+), 1 deletion(-)
+
+diff --git a/pdb2pka/SConscript b/pdb2pka/SConscript
+index 583cdc5..6c30011 100644
+--- a/pdb2pka/SConscript
++++ b/pdb2pka/SConscript
+@@ -1,4 +1,11 @@
+ Import('env')
++import os
++
++env['CCFLAGS'].extend(os.environ['CXXFLAGS'].split())
++env['LINKFLAGS'].extend(os.environ['LDFLAGS'].split())
++env['CXX'] = os.environ['CXX']
++env['LINK'] = os.environ['CXX']
++
+
+ if env['REBUILD_SWIG']:
+ pyc = env.LoadableModule('_pMC_mult', ['pMC_mult.cpp', 'pMC_mult.i'])
+@@ -9,4 +16,4 @@ Default(pyc)
+
+ algorithms_module = SConscript('substruct/SConscript')
+
+-Return('pyc algorithms_module')
+\ No newline at end of file
++Return('pyc algorithms_module')
+diff --git a/pdb2pka/substruct/SConscript b/pdb2pka/substruct/SConscript
+index 7dbcdb0..56fb577 100644
+--- a/pdb2pka/substruct/SConscript
++++ b/pdb2pka/substruct/SConscript
+@@ -1,7 +1,13 @@
+ import distutils
+ import numpy
++import os
+ Import('env')
+
++env['CCFLAGS'].extend(os.environ['CXXFLAGS'].split())
++env['LINKFLAGS'].extend(os.environ['LDFLAGS'].split())
++env['CXX'] = os.environ['CXX']
++env['LINK'] = os.environ['CXX']
++
+ env.Append(CPPPATH=[distutils.sysconfig.get_python_inc(), numpy.get_include()])
+
+ algorithms_pyc = env.LoadableModule('Algorithms', ['Algorithms.cpp'])
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild
new file mode 100644
index 000000000000..360ae3fbd21e
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild,v 1.1 2014/10/27 17:03:21 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools scons-utils fortran-2 flag-o-matic python-single-r1 toolchain-funcs
+
+DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
+HOMEPAGE="http://www.poissonboltzmann.org/"
+SRC_URI="https://github.com/Electrostatics/apbs-${PN}/releases/download/${P}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc examples opal +pdb2pka"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-chemistry/openbabel[python]
+ opal? ( dev-python/zsi[${PYTHON_USEDEP}] )
+ pdb2pka? ( sci-chemistry/apbs[${PYTHON_USEDEP},-mpi] )"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0"
+
+pkg_setup() {
+ if [[ -z ${MAXATOMS} ]]; then
+ einfo "If you like to have support for more then 10000 atoms,"
+ einfo "export MAXATOMS=\"your value\""
+ export MAXATOMS=10000
+ else
+ einfo "Allow usage of ${MAXATOMS} during calculations"
+ fi
+ fortran-2_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find -type f \( -name "*\.pyc" -o -name "*\.pyo" \) -delete || die
+
+ cat > build_config.py <<- EOF
+ PREFIX="${ED}/$(python_get_sitedir)/${PN}"
+ #URL="http://<COMPUTER NAME>/pdb2pqr/"
+ APBS="${EPREFIX}/usr/bin/apbs"
+ #OPAL="http://nbcr-222.ucsd.edu/opal2/services/pdb2pqr_1.8"
+ #APBS_OPAL="http://nbcr-222.ucsd.edu/opal2/services/apbs_1.3"
+ MAX_ATOMS=${MAXATOMS}
+ BUILD_PDB2PKA=$(usex pdb2pka True False)
+ REBUILD_SWIG=True
+ EOF
+
+ export CXXFLAGS="${CXXFLAGS}"
+ export LDFLAGS="${LDFLAGS}"
+
+ epatch "${FILESDIR}"/${P}-flags.patch
+ tc-export CXX
+ rm -rf scons || die
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ local myesconsargs=( -j1 )
+ escons test
+ escons advtest
+ escons complete-test
+}
+
+src_install() {
+ escons install
+
+ local lib
+
+ make_wrapper ${PN} "${PYTHON} /$(python_get_sitedir)/${PN}/${PN}.py"
+ make_wrapper pdb2pka "${PYTHON} /$(python_get_sitedir)/${PN}/pdb2pka/pka.py"
+
+ for lib in apbslib.py{,c,o}; do
+ dosym ../../apbs/${lib} $(python_get_sitedir)/${PN}/pdb2pka/${lib}
+ done
+ dosym ../../_apbslib.so $(python_get_sitedir)/${PN}/pdb2pka/_apbslib.so
+
+ if use doc; then
+ pushd doc > /dev/null
+ dohtml -r *.html images pydoc
+ popd > /dev/null
+ fi
+
+ use examples && \
+ insinto /usr/share/${PN}/ && \
+ doins -r examples
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${ED}"$(python_get_sitedir)/${PN}/doc/pydoc/* "${ED}"/usr/share/doc/${PF}/html || die
+ rmdir "${ED}"$(python_get_sitedir)/${PN}/doc/pydoc || die
+ mv "${ED}"$(python_get_sitedir)/${PN}/doc/* "${ED}"/usr/share/doc/${PF}/ || die
+
+ dodoc *md NEWS
+
+ find "${ED}"$(python_get_sitedir)/${PN}/contrib -delete || die
+
+ python_optimize
+}