summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-27 18:57:43 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-27 18:57:43 +0000
commit7af7e7956b77ac618eba05b475e39e204a1a8b53 (patch)
tree131e82b7affdf79dc101d959f25d42c4d2910c7e /sci-chemistry
parentBug #329991: Document that users of plain (non-LUKS) volumes from the 1.0 ser... (diff)
downloadgentoo-2-7af7e7956b77ac618eba05b475e39e204a1a8b53.tar.gz
gentoo-2-7af7e7956b77ac618eba05b475e39e204a1a8b53.tar.bz2
gentoo-2-7af7e7956b77ac618eba05b475e39e204a1a8b53.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/xia2/ChangeLog8
-rw-r--r--sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch61
-rw-r--r--sci-chemistry/xia2/xia2-0.3.1.7.ebuild66
3 files changed, 134 insertions, 1 deletions
diff --git a/sci-chemistry/xia2/ChangeLog b/sci-chemistry/xia2/ChangeLog
index b4b08366275a..c91e4ca9661b 100644
--- a/sci-chemistry/xia2/ChangeLog
+++ b/sci-chemistry/xia2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/xia2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/ChangeLog,v 1.3 2010/04/22 19:29:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/ChangeLog,v 1.4 2010/07/27 18:57:43 jlec Exp $
+
+*xia2-0.3.1.7 (27 Jul 2010)
+
+ 27 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.3.1.7-fix-syntax.patch, +xia2-0.3.1.7.ebuild:
+ Version bump
22 Apr 2010; Justin Lecher <jlec@gentoo.org> xia2-0.3.1.6.ebuild:
Keyworded for ~*-linux
diff --git a/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch b/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch
new file mode 100644
index 000000000000..ec8ada48aad1
--- /dev/null
+++ b/sci-chemistry/xia2/files/0.3.1.7-fix-syntax.patch
@@ -0,0 +1,61 @@
+diff --git a/xia2-0.3.1.7/Applications/xia2find.py b/xia2-0.3.1.7/Applications/xia2find.py
+index 1a3b0e2..e0b8a1e 100755
+--- a/xia2-0.3.1.7/Applications/xia2find.py
++++ b/xia2-0.3.1.7/Applications/xia2find.py
+@@ -38,7 +38,7 @@ from Schema.Sweep import SweepFactory
+ from Experts.FindImages import image2template_directory
+
+ known_image_extensions = ['img', 'mccd', 'mar2300', 'mar1200', 'mar3450',
+- 'osc', 'cbf', 'mar2000']]
++ 'osc', 'cbf', 'mar2000']
+ known_sweeps = { }
+
+ def is_image_name(file):
+diff --git a/xia2-0.3.1.7/Experts/DRStrategyExpert.py b/xia2-0.3.1.7/Experts/DRStrategyExpert.py
+index 28b1dc3..dba3ef7 100644
+--- a/xia2-0.3.1.7/Experts/DRStrategyExpert.py
++++ b/xia2-0.3.1.7/Experts/DRStrategyExpert.py
+@@ -48,24 +48,24 @@ strategy_dict = {
+ 'default':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'default':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'}
++ 'indexer':'labelit', 'integrater':'mosflm', 'scaler':'mosflm'},
+ 'depends-on':['labelit.screen', 'mosflm', 'scala', 'reindex',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':1,
+ 'pipeline':{
+- 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'}
++ 'indexer':'labelit', 'integrater':'xds', 'scaler':'xds-hybrid'},
+ 'depends-on':['labelit.screen', 'xds', 'xscale', 'scala', 'combat',
+ 'pointless-1.1.0.4']},
+ 'mosaic':{
+ 'score':2,
+ 'pipeline':{
+- 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'}
++ 'indexer':'xds', 'integrater':'xds', 'scaler':'xds'},
+ 'depends-on':['xds', 'xscale']}
+ }
+diff --git a/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py b/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
+index 88f9218..5fb6f2a 100644
+--- a/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
++++ b/xia2core-0.3.1.7/Python/Examples/CCP4/Cad.py
+@@ -49,8 +49,8 @@ def Cad(DriverType = None):
+ self.add_command_line(hklin)
+
+ self.set_task('Rewriting reflections %s => %s' %
+- ` (os.path.split(hklin)[-1],
+- ` os.path.split(self.getHklout())[-1]))
++ (os.path.split(hklin)[-1],
++ os.path.split(self.getHklout())[-1]))
+
+ self.start()
+
diff --git a/sci-chemistry/xia2/xia2-0.3.1.7.ebuild b/sci-chemistry/xia2/xia2-0.3.1.7.ebuild
new file mode 100644
index 000000000000..6b3152269410
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.1.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xia2/xia2-0.3.1.7.ebuild,v 1.1 2010/07/27 18:57:43 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.xia2.org/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}"/usr/share/ccp4/XIAROOT
+ XIA2CORE_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}
+ PATH="${EPREFIX}"/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}