summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-06 12:07:57 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-06 12:07:57 +0000
commit817b56b36d6d4dd01d09a485df7a87aeeadf20e2 (patch)
tree933937cbde17ee8ff637ad6a0eb60c8318e8aebf /sci-chemistry
parentppc64 stable wrt #322631 (diff)
downloadgentoo-2-817b56b36d6d4dd01d09a485df7a87aeeadf20e2.tar.gz
gentoo-2-817b56b36d6d4dd01d09a485df7a87aeeadf20e2.tar.bz2
gentoo-2-817b56b36d6d4dd01d09a485df7a87aeeadf20e2.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mustang/ChangeLog9
-rw-r--r--sci-chemistry/mustang/mustang-3.2.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-chemistry/mustang/ChangeLog b/sci-chemistry/mustang/ChangeLog
index befb97d8315e..761ecc12aa11 100644
--- a/sci-chemistry/mustang/ChangeLog
+++ b/sci-chemistry/mustang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/mustang
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.5 2008/12/19 20:22:42 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.6 2010/07/06 12:07:57 jlec Exp $
+
+*mustang-3.2.1 (06 Jul 2010)
+
+ 06 Jul 2010; Justin Lecher <jlec@gentoo.org> +mustang-3.2.1.ebuild:
+ Version Bump
19 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+files/mustang-3-gcc43.patch, mustang-3.ebuild:
diff --git a/sci-chemistry/mustang/mustang-3.2.1.ebuild b/sci-chemistry/mustang/mustang-3.2.1.ebuild
new file mode 100644
index 000000000000..b0dc9ec7c9e4
--- /dev/null
+++ b/sci-chemistry/mustang/mustang-3.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/mustang-3.2.1.ebuild,v 1.1 2010/07/06 12:07:57 jlec Exp $
+
+EAPI="3"
+
+inherit base toolchain-funcs
+
+MY_PN="MUSTANG"
+SRC_P="${PN}_v${PV}"
+MY_P="${MY_PN}_v${PV}"
+
+DESCRIPTION="MUltiple STructural AligNment AlGorithm."
+HOMEPAGE="http://www.cs.mu.oz.au/~arun/mustang/"
+SRC_URI="http://www.csse.unimelb.edu.au/~arun/${PN}/${SRC_P}.tgz -> ${P}.tar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake \
+ CPP=$(tc-getCXX) \
+ CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_test() {
+ ./bin/${P} -f ./data/test/test_zf-CCHH || die
+}
+
+src_install() {
+ newbin bin/${P} mustang || die
+}
+
+pkg_postinst() {
+ elog "If you use this program for an academic paper, please cite:"
+ elog "Arun S. Konagurthu, James C. Whisstock, Peter J. Stuckey, and Arthur M. Lesk"
+ elog "Proteins: Structure, Function, and Bioinformatics. 64(3):559-574, Aug. 2006"
+}