summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-07 15:27:34 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-07 15:27:34 +0000
commit8b8e80e2d059ce7719a2336d46ac1ac1af02835d (patch)
tree48a70159dd778e3dcc54b0f862a9f16f1074d8ee /sci-chemistry
parentRemoved older versions (diff)
downloadgentoo-2-8b8e80e2d059ce7719a2336d46ac1ac1af02835d.tar.gz
gentoo-2-8b8e80e2d059ce7719a2336d46ac1ac1af02835d.tar.bz2
gentoo-2-8b8e80e2d059ce7719a2336d46ac1ac1af02835d.zip
Version Bump, #349409; keyworded *-linux
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/imosflm/ChangeLog8
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.4.ebuild4
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.5.ebuild75
-rw-r--r--sci-chemistry/imosflm/metadata.xml8
4 files changed, 88 insertions, 7 deletions
diff --git a/sci-chemistry/imosflm/ChangeLog b/sci-chemistry/imosflm/ChangeLog
index 5d87d1d6d93c..c9334237a74f 100644
--- a/sci-chemistry/imosflm/ChangeLog
+++ b/sci-chemistry/imosflm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/imosflm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/ChangeLog,v 1.4 2011/01/27 10:53:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/ChangeLog,v 1.5 2011/09/07 15:27:34 jlec Exp $
+
+*imosflm-1.0.5 (07 Sep 2011)
+
+ 07 Sep 2011; Justin Lecher <jlec@gentoo.org> imosflm-1.0.4.ebuild,
+ +imosflm-1.0.5.ebuild, metadata.xml:
+ Version Bump, #349409; keyworded *-linux
27 Jan 2011; Markos Chandras <hwoarang@gentoo.org> imosflm-1.0.4.ebuild:
Stable on amd64 wrt bug #352051
diff --git a/sci-chemistry/imosflm/imosflm-1.0.4.ebuild b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
index f1a153a52fae..334a01bd855d 100644
--- a/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
+++ b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.4.ebuild,v 1.4 2011/01/27 10:53:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.4.ebuild,v 1.5 2011/09/07 15:27:34 jlec Exp $
EAPI="3"
@@ -14,7 +14,7 @@ SRC_URI="${HOMEPAGE}/ver${MY_PV}/downloads/${P}.zip"
LICENSE="ccp4"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
diff --git a/sci-chemistry/imosflm/imosflm-1.0.5.ebuild b/sci-chemistry/imosflm/imosflm-1.0.5.ebuild
new file mode 100644
index 000000000000..b97f81638900
--- /dev/null
+++ b/sci-chemistry/imosflm/imosflm-1.0.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.5.ebuild,v 1.1 2011/09/07 15:27:34 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators ${PV})"
+
+DESCRIPTION="A new GUI for the Mosflm crystallographic data processing tool"
+HOMEPAGE="http://www.mrc-lmb.cam.ac.uk/harry/imosflm"
+SRC_URI="${HOMEPAGE}/ver${MY_PV}/downloads/${P}.zip"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tcl
+ >=dev-tcltk/itcl-3.3
+ >=dev-tcltk/itk-3.3
+ >=dev-tcltk/iwidgets-4
+ >=dev-tcltk/tdom-0.8
+ >=dev-tcltk/tkimg-1.3
+ >=dev-tcltk/tktreectrl-2.1
+ dev-tcltk/anigif
+ dev-tcltk/combobox
+ dev-tcltk/tablelist
+ >=sci-chemistry/mosflm-7.0.4"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/1.0.4-tk.patch \
+ "${FILESDIR}"/1.0.4-impl-dec.patch
+}
+
+src_compile() {
+ cd c
+
+ objs="tkImageLoadDLL.o tkImageLoad.o"
+ libs="-ltclstub -ltkstub"
+ config="-fPIC -DUSE_TCL_STUBS -DTK_USE_STUBS"
+ ldextra="-shared"
+
+ for file in ${objs}; do
+ einfo "$(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}"
+ $(tc-getCC) -c ${CFLAGS} ${config} ${file/.o/.c} -o ${file}
+ done
+
+ einfo "$(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}"
+ $(tc-getCC) ${LDFLAGS} ${ldextra} ${objs} -o tkImageLoad.so ${libs}
+}
+
+src_install(){
+ rm -rf lib/{*.so,anigif,combobox}
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins -r "${S}"/{src,bitmaps,lib}
+ fperms 775 /usr/$(get_libdir)/${PN}/src/imosflm
+
+ dolib.so c/tkImageLoad.so
+
+ cat >> "${T}"/23imosflm <<- EOF
+ IMOSFLM_VERSION="${PV}"
+ EOF
+
+ doenvd "${T}"/23imosflm
+
+ make_wrapper imosflm /usr/$(get_libdir)/${PN}/src/imosflm
+}
diff --git a/sci-chemistry/imosflm/metadata.xml b/sci-chemistry/imosflm/metadata.xml
index efb490d78817..d747d72a25b4 100644
--- a/sci-chemistry/imosflm/metadata.xml
+++ b/sci-chemistry/imosflm/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
</pkgmetadata>