summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-01 09:45:37 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-01 09:45:37 +0000
commitccd3ab95063f3d90c6e0b1ba0663fdb3a04796af (patch)
treeba8a6f2687b6bbc698d7bdc46a32d01e1419b88b /sci-chemistry
parentOnly block <xfce-extra/xfce4-notifyd-0.2.1_p20110101 because of the new uniqu... (diff)
downloadgentoo-2-ccd3ab95063f3d90c6e0b1ba0663fdb3a04796af.tar.gz
gentoo-2-ccd3ab95063f3d90c6e0b1ba0663fdb3a04796af.tar.bz2
gentoo-2-ccd3ab95063f3d90c6e0b1ba0663fdb3a04796af.zip
Version Bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol-plugins-dssp/ChangeLog8
-rw-r--r--sci-chemistry/pymol-plugins-dssp/pymol-plugins-dssp-110430.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-chemistry/pymol-plugins-dssp/ChangeLog b/sci-chemistry/pymol-plugins-dssp/ChangeLog
index 190eff1bf2c6..c902eb96c48a 100644
--- a/sci-chemistry/pymol-plugins-dssp/ChangeLog
+++ b/sci-chemistry/pymol-plugins-dssp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol-plugins-dssp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-dssp/ChangeLog,v 1.2 2011/04/17 13:53:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-dssp/ChangeLog,v 1.3 2011/05/01 09:45:37 jlec Exp $
+
+*pymol-plugins-dssp-110430 (01 May 2011)
+
+ 01 May 2011; Justin Lecher <jlec@gentoo.org>
+ +pymol-plugins-dssp-110430.ebuild:
+ Version Bump
*pymol-plugins-dssp-110413 (17 Apr 2011)
diff --git a/sci-chemistry/pymol-plugins-dssp/pymol-plugins-dssp-110430.ebuild b/sci-chemistry/pymol-plugins-dssp/pymol-plugins-dssp-110430.ebuild
new file mode 100644
index 000000000000..ff289a9c314a
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-dssp/pymol-plugins-dssp-110430.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-dssp/pymol-plugins-dssp-110430.ebuild,v 1.1 2011/05/01 09:45:37 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit python
+
+DESCRIPTION="DSSP Plugin for PyMOL"
+HOMEPAGE="http://www.biotec.tu-dresden.de/~hongboz/dssp_pymol/dssp_pymol.html"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.py.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/dssp
+ sci-biology/stride
+ sci-chemistry/pymol"
+DEPEND=""
+
+src_prepare() {
+ sed \
+ -e "s:GENTOO_DSSP:${EPREFIX}/usr/bin/dssp:g" \
+ -e "s:GENTOO_STRIDE:${EPREFIX}/usr/bin/stride:g" \
+ -i ${P}.py || die
+}
+
+src_install() {
+ installation() {
+ insinto $(python_get_sitedir)/pmg_tk/startup
+ doins ${P}.py
+ }
+ python_execute_function installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/${P}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/${P}.py
+}