summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-10 13:49:48 +0000
committerJustin Lecher <jlec@gentoo.org>2012-01-10 13:49:48 +0000
commited4599fbcaaf89b51650e0ed602c9d0e6b31ba7e (patch)
tree89eaae2c73979ec34481b3626e3bd4f89789938c /sci-chemistry
parentdon't try to parse the config file - bug #397763 (diff)
downloadgentoo-2-ed4599fbcaaf89b51650e0ed602c9d0e6b31ba7e.tar.gz
gentoo-2-ed4599fbcaaf89b51650e0ed602c9d0e6b31ba7e.tar.bz2
gentoo-2-ed4599fbcaaf89b51650e0ed602c9d0e6b31ba7e.zip
Enhance nofetch msg, fix compilation with USE=cuda and gcc != 4.4*, thanks xarthisius for the help
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/vmd/ChangeLog8
-rw-r--r--sci-chemistry/vmd/metadata.xml8
-rw-r--r--sci-chemistry/vmd/vmd-1.9.ebuild12
3 files changed, 18 insertions, 10 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index f144bb676105..eed67c818206 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/vmd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.42 2011/07/20 16:58:14 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.43 2012/01/10 13:49:48 jlec Exp $
+
+ 10 Jan 2012; Justin Lecher <jlec@gentoo.org> vmd-1.9.ebuild, metadata.xml:
+ Enhance nofetch msg, fix compilation with USE=cuda and gcc != 4.4*, thanks
+ xarthisius for the help
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #105599
diff --git a/sci-chemistry/vmd/metadata.xml b/sci-chemistry/vmd/metadata.xml
index 103ce95d4894..be76141a652b 100644
--- a/sci-chemistry/vmd/metadata.xml
+++ b/sci-chemistry/vmd/metadata.xml
@@ -7,9 +7,9 @@
</maintainer>
<herd>sci-chemistry</herd>
<use>
- <flag name='msms'>Add support for MSMS SAS calcualtion tool</flag>
- <flag name='povray'>Add support for povray raytracer for HQ images</flag>
- <flag name='tachyon'>Add support for tachyon raytracer for HQ images</flag>
- <flag name='cuda'>Use nvidia cuda toolkit for speeding up computations</flag>
+ <flag name="msms">Add support for MSMS SAS calcualtion tool</flag>
+ <flag name="povray">Add support for povray raytracer for HQ images</flag>
+ <flag name="tachyon">Add support for tachyon raytracer for HQ images</flag>
+ <flag name="cuda">Use nvidia cuda toolkit for speeding up computations</flag>
</use>
</pkgmetadata>
diff --git a/sci-chemistry/vmd/vmd-1.9.ebuild b/sci-chemistry/vmd/vmd-1.9.ebuild
index b6a71f49c95c..9a03082dccd5 100644
--- a/sci-chemistry/vmd/vmd-1.9.ebuild
+++ b/sci-chemistry/vmd/vmd-1.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.ebuild,v 1.6 2011/06/15 08:29:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.9.ebuild,v 1.7 2012/01/10 13:49:48 jlec Exp $
EAPI="3"
@@ -57,8 +57,9 @@ QA_DT_HASH_x86="usr/lib/vmd/plugins/LINUX/tcl/intersurf1.1/bin/intersurf.so"
pkg_nofetch() {
elog "Please download ${P}.src.tar.gz from"
elog "${VMD_DOWNLOAD}"
- elog "after agreeing to the license and then move it to "
- elog "${DISTDIR}"
+ elog "after agreeing to the license and get"
+ elog "http://dev.gentoo.org/~jlec/distfiles/${P}-gentoo-patches.tar.xz"
+ elog "Place both in ${DISTDIR}"
}
src_prepare() {
@@ -117,8 +118,11 @@ src_prepare() {
# -e "s:gentoo-numpy-include:${EPREFIX}$(python_get_sitedir)/${NUMPY_INCLUDE}:" \
# -i configure || die "failed setting up python"
+ local gcc44_bindir="$(ls -d ${EPREFIX}/usr/*pc-linux-gnu/gcc-bin/4.4*)"
+
sed \
-e "s:gentoo-cuda-lib:${EPREFIX}/opt/cuda/$(get_libdir):g" \
+ -e "/^\$arch_nvccflags/s:=:= \"--compiler-bindir=${gcc44_bindir} \" . \n:1" \
-i configure || die
sed \