summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-14 18:08:37 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-14 18:08:37 +0000
commitee52d2867414ea4f09c3182f3f3c4837f9cd6b28 (patch)
treecdc000d603874ab57d2c8aff7674d69fe49b2b94 /sci-chemistry
parentRevision bump, make sure the bash-completion script installs to the right place. (diff)
downloadgentoo-2-ee52d2867414ea4f09c3182f3f3c4837f9cd6b28.tar.gz
gentoo-2-ee52d2867414ea4f09c3182f3f3c4837f9cd6b28.tar.bz2
gentoo-2-ee52d2867414ea4f09c3182f3f3c4837f9cd6b28.zip
sci-chemistry/molscript: Bump to EAPI=5
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molscript/ChangeLog10
-rw-r--r--sci-chemistry/molscript/metadata.xml2
-rw-r--r--sci-chemistry/molscript/molscript-2.1.2-r2.ebuild68
3 files changed, 77 insertions, 3 deletions
diff --git a/sci-chemistry/molscript/ChangeLog b/sci-chemistry/molscript/ChangeLog
index 7584e3740f3f..57f7c519f24b 100644
--- a/sci-chemistry/molscript/ChangeLog
+++ b/sci-chemistry/molscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/molscript
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.15 2011/08/09 08:25:28 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.16 2014/10/14 18:08:37 jlec Exp $
+
+*molscript-2.1.2-r2 (14 Oct 2014)
+
+ 14 Oct 2014; Justin Lecher <jlec@gentoo.org> +molscript-2.1.2-r2.ebuild,
+ metadata.xml:
+ Bump to EAPI=5
09 Aug 2011; Samuli Suominen <ssuominen@gentoo.org>
+files/2.1.2-libpng15.patch, molscript-2.1.2-r1.ebuild:
diff --git a/sci-chemistry/molscript/metadata.xml b/sci-chemistry/molscript/metadata.xml
index 9ac9ffdb3a41..51fdedab1b38 100644
--- a/sci-chemistry/molscript/metadata.xml
+++ b/sci-chemistry/molscript/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>
diff --git a/sci-chemistry/molscript/molscript-2.1.2-r2.ebuild b/sci-chemistry/molscript/molscript-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..78b6c05231c8
--- /dev/null
+++ b/sci-chemistry/molscript/molscript-2.1.2-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r2.ebuild,v 1.1 2014/10/14 18:08:37 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Display molecular 3D structures, such as proteins, in both schematic and detailed representations"
+HOMEPAGE="http://www.avatar.se/molscript/"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="glut molscript"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/gd
+ media-libs/freeglut
+ || (
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libX11
+ )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please visit ${HOMEPAGE}"
+ elog "and get ${A}."
+ elog "Place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/fix-makefile-shared.patch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-prll.patch \
+ "${FILESDIR}"/${PV}-libpng15.patch
+
+ # Provide glutbitmap.h, because freeglut doesn't have it
+ cp "${FILESDIR}"/glutbitmap.h "${S}"/clib/ || die
+
+ # Stop an incredibly hacky include
+ sed \
+ -e 's:<../lib/glut/glutbitmap.h>:"glutbitmap.h":g' \
+ -i "${S}"/clib/ogl_bitmap_character.c || die
+}
+
+src_compile() {
+ # Prefix of programs it links with
+ export FREEWAREDIR="${EPREFIX}/usr"
+
+ ln -s Makefile.complete Makefile || die
+
+ emake \
+ CC="$(tc-getCC)" \
+ COPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin molscript molauto
+ dohtml "${S}"/doc/*.html
+}