summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2009-02-07 20:47:28 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2009-02-07 20:47:28 +0000
commit2d49ed3aa6ddffce4b21220fc1de03c92f2a2efa (patch)
tree09fdd75901e41a7be3e4fa20834e740485456c9f /sci-electronics/eagle
parentInitial ebuild by me. (diff)
downloadgentoo-2-2d49ed3aa6ddffce4b21220fc1de03c92f2a2efa.tar.gz
gentoo-2-2d49ed3aa6ddffce4b21220fc1de03c92f2a2efa.tar.bz2
gentoo-2-2d49ed3aa6ddffce4b21220fc1de03c92f2a2efa.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/eagle')
-rw-r--r--sci-electronics/eagle/ChangeLog9
-rw-r--r--sci-electronics/eagle/eagle-5.4.0.ebuild91
2 files changed, 98 insertions, 2 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 3ef75ef9f8fb..ee2c1c8a30ec 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/eagle
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.17 2008/11/11 01:58:31 nixphoeni Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.18 2009/02/07 20:47:28 nixphoeni Exp $
+
+*eagle-5.4.0 (07 Feb 2009)
+
+ 07 Feb 2009; Joe Sapp <nixphoeni@gentoo.org> +eagle-5.4.0.ebuild:
+ Version bump
*eagle-5.3.0 (11 Nov 2008)
diff --git a/sci-electronics/eagle/eagle-5.4.0.ebuild b/sci-electronics/eagle/eagle-5.4.0.ebuild
new file mode 100644
index 000000000000..bbe96d746e89
--- /dev/null
+++ b/sci-electronics/eagle/eagle-5.4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.4.0.ebuild,v 1.1 2009/02/07 20:47:28 nixphoeni Exp $
+
+inherit eutils
+
+DESCRIPTION="EAGLE Layout Editor"
+HOMEPAGE="http://www.cadsoft.de"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_de doc"
+LICENSE="cadsoft"
+RESTRICT="strip"
+SLOT="0"
+
+# Cadsoft has used the suffix "_p" in the past which we translate to "r"
+MY_PV=${PV/_p/r}
+
+SRC_URI="ftp://ftp.cadsoft.de/pub/program/${PV%\.[0-9]}/${PN}-lin-${MY_PV}.run"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+
+# Append ${PV} since that's what upstream installs to
+INSTALLDIR="/opt/eagle-${PV}"
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="de";;
+ *)
+ MY_LANG="en";;
+esac
+# Mandatory documentation being installed
+DOCS="README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt"
+
+src_unpack() {
+
+ # Extract the built-in .tar.bz2 file starting at __DATA__
+ sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
+
+}
+
+src_install() {
+
+ cd "${S}"
+ dodir ${INSTALLDIR}
+ # Copy all to INSTALLDIR
+ cp -r . "${D}"/${INSTALLDIR}
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
+ exeinto /usr/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting INSTALLDIR and any
+ # arguments passed to the script (thanks Denilson)
+ echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle"
+
+ # Install the documentation
+ cd doc
+ dodoc ${DOCS}
+ doman eagle.1
+ # Install extra documentation if requested
+ use doc && dodoc elektro-tutorial.pdf manual_${MY_LANG}.pdf tutorial_${MY_LANG}.pdf
+ # Remove docs left in INSTALLDIR
+ rm -rf "${D}${INSTALLDIR}/doc"
+ cd ..
+
+ echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
+ doenvd "${S}/90eagle"
+
+ # Create desktop entry
+ doicon bin/${PN}icon50.png
+ make_desktop_entry "${ROOT}/usr/bin/eagle" ${PN} ${PN}icon50.png "Graphics;Electronics"
+
+}
+
+pkg_postinst() {
+
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+ echo
+ ewarn "Due to some necessary changes in the data structure, once you edit"
+ ewarn "a file with version 5.x you will no longer be able to edit it"
+ ewarn "with versions prior to 5.0!"
+ ewarn
+ ewarn "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 4.xx."
+
+}