summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-05-13 07:17:17 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-05-13 07:17:17 +0000
commit32fe6650ea1e65eb361bd1bb0476b422340968d6 (patch)
treee76d4861a9e6a76af5970996211155db88bd92b8 /sci-electronics/gnucap/gnucap-0.35.20070820.ebuild
parentAdded workaround to init.d-files to correctly detect an already running serve... (diff)
downloadgentoo-2-32fe6650ea1e65eb361bd1bb0476b422340968d6.tar.gz
gentoo-2-32fe6650ea1e65eb361bd1bb0476b422340968d6.tar.bz2
gentoo-2-32fe6650ea1e65eb361bd1bb0476b422340968d6.zip
Fixed obsolete virtual/tetex dependency, reported by Andrey Grozin.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sci-electronics/gnucap/gnucap-0.35.20070820.ebuild')
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.20070820.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild b/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild
index 9f149826001a..56c67a5adcd7 100644
--- a/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild
+++ b/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild,v 1.1 2007/09/20 15:45:04 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.20070820.ebuild,v 1.2 2008/05/13 07:17:17 calchan Exp $
inherit multilib
@@ -19,13 +19,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="doc? ( virtual/tetex )"
+DEPEND="doc? ( virtual/latex-base )"
S="${WORKDIR}/${MY_PV}"
src_unpack() {
unpack ${A} || die "Failed to unpack!"
- cd ${S}
+ cd "${S}"
# No need to install COPYING and INSTALL
sed -i \
@@ -62,17 +62,17 @@ src_compile () {
econf --disable-dependency-tracking || die "Configuration failed"
emake || die "Compilation failed"
for PLUGIN_DIR in plugins/* ; do
- cd ${S}/${PLUGIN_DIR}
+ cd "${S}"/${PLUGIN_DIR}
emake || die "Compilation failed in ${PLUGIN_DIR}"
done
}
src_install () {
- emake DESTDIR=${D} install || die "Installation failed"
+ emake DESTDIR="${D}" install || die "Installation failed"
insopts -m0755
for PLUGIN_DIR in plugins/* ; do
insinto /usr/$(get_libdir)/gnucap/${PLUGIN_DIR}
- cd ${S}/${PLUGIN_DIR}
+ cd "${S}"/${PLUGIN_DIR}
for PLUGIN in */*.so ; do
newins ${PLUGIN} ${PLUGIN##*/} \
|| die "Installation of ${PLUGIN_DIR}/${PLUGIN} failed"