summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-09-16 15:37:15 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-09-16 15:37:15 +0000
commitf2a22bb0899844d038216d6da5518094f82fd5d8 (patch)
tree426a453d78f576d08030831ec4cf59e38c620a9b /sci-electronics/gplcver
parentFix up PAM issues on amd64, add vmware-modules blockers and fix init script f... (diff)
downloadgentoo-2-f2a22bb0899844d038216d6da5518094f82fd5d8.tar.gz
gentoo-2-f2a22bb0899844d038216d6da5518094f82fd5d8.tar.bz2
gentoo-2-f2a22bb0899844d038216d6da5518094f82fd5d8.zip
Version bump, thanks to Luis Vitorio Cargnini (bug #187067).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-electronics/gplcver')
-rw-r--r--sci-electronics/gplcver/ChangeLog9
-rw-r--r--sci-electronics/gplcver/files/digest-gplcver-2.12a3
-rw-r--r--sci-electronics/gplcver/gplcver-2.12a.ebuild65
3 files changed, 75 insertions, 2 deletions
diff --git a/sci-electronics/gplcver/ChangeLog b/sci-electronics/gplcver/ChangeLog
index 55f1e4e6eafe..c85c625b67eb 100644
--- a/sci-electronics/gplcver/ChangeLog
+++ b/sci-electronics/gplcver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/gplcver
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gplcver/ChangeLog,v 1.7 2006/08/12 11:42:09 chrb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gplcver/ChangeLog,v 1.8 2007/09/16 15:37:15 calchan Exp $
+
+*gplcver-2.12a (16 Sep 2007)
+
+ 16 Sep 2007; Denis Dupeyron <calchan@gentoo.org> +gplcver-2.12a.ebuild:
+ Version bump, thanks to Luis Vitorio Cargnini (bug #187067).
12 Aug 2006; Chris Bainbridge <chrb@gentoo.org> -gplcver-1.10j.ebuild,
-gplcver-2.10c.ebuild, gplcver-2.11a.ebuild:
diff --git a/sci-electronics/gplcver/files/digest-gplcver-2.12a b/sci-electronics/gplcver/files/digest-gplcver-2.12a
new file mode 100644
index 000000000000..321659e7a696
--- /dev/null
+++ b/sci-electronics/gplcver/files/digest-gplcver-2.12a
@@ -0,0 +1,3 @@
+MD5 857a15a9ebc8ef63ece01502509cbeb7 gplcver-2.12a.src.tar.bz2 1224470
+RMD160 5af004b345142ac5400c9defc7125bbe127d2c49 gplcver-2.12a.src.tar.bz2 1224470
+SHA256 f7d94677677f10c2d1e366eda2d01a652ef5f30d167660905c100f52f1a46e75 gplcver-2.12a.src.tar.bz2 1224470
diff --git a/sci-electronics/gplcver/gplcver-2.12a.ebuild b/sci-electronics/gplcver/gplcver-2.12a.ebuild
new file mode 100644
index 000000000000..80fe278c24c2
--- /dev/null
+++ b/sci-electronics/gplcver/gplcver-2.12a.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gplcver/gplcver-2.12a.ebuild,v 1.1 2007/09/16 15:37:15 calchan Exp $
+
+MY_PN=gpl-cver
+
+DESCRIPTION="Verilog simulator"
+HOMEPAGE="http://www.pragmatic-c.com/${MY_PN}"
+SRC_URI="http://www.pragmatic-c.com/${MY_PN}/downloads/${P}.src.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+S=${WORKDIR}/${P}.src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s/^CFLAGS/#CFLAGS/" \
+ -e "s/(CFLAGS)/(INCS) \$(CFLAGS)/" \
+ -e "s/(LFLAGS)/(LFLAGS) \$(LDFLAGS)/" \
+ src/makefile.* | die "sed failed"
+ sed -i \
+ -e "s/^CFLAGS/#CFLAGS/" \
+ -e "s/(OPTFLGS) vcddiff.o/(LDFLAGS) vcddiff.o/" \
+ vcddiff.dir/src/makefile.* | die "sed failed"
+}
+
+src_compile(){
+ cd ${S}/src
+ emake -f makefile.lnx || die "emake failed"
+ cd ${S}/vcddiff.dir/src
+ emake -f makefile.lnx || die "emake failed"
+}
+
+src_install() {
+ dobin bin/cver bin/vcddiff || die "Failed installing binaries"
+ doman doc/systasks.1
+ dodoc doc/README doc/cver*[!htm] doc/dbg.hlp doc/systasks.pdf vcddiff.dir/README.vcddiff
+ dohtml doc/cver.faq.htm
+ dodir /usr/include/cver_pli_incs
+ insinto /usr/include/cver_pli_incs
+ doins pli_incs/*.h
+}
+
+src_test() {
+ # fixme: make tests die if something fails
+ cd ${S}/tests_and_examples/
+ # first verify install
+ cd install.tst
+ ./inst_tst.sh
+ # now individual tests
+ cd ../capacity.tst
+ ../../bin/cver -f lfsr.vc
+ diff verilog.log lfsr.plg
+ cd ../examples.acc
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.tf
+ ./inst_pli.sh lnx
+ #opt_inst_pli.sh lnx
+ cd ../examples.vpi
+ ./inst_pli.sh lnx
+}