summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-09-18 08:28:35 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-09-18 08:28:35 +0000
commit6538b62837c2a1de28fad9b3dcf6d0ee33560c20 (patch)
tree14c2eb1ae4bf5edb3e0a7f906a20c5ced3e8d66e /sci-electronics/kicad
parentUse EAPI 1 and slot deps for freetype. (diff)
downloadgentoo-2-6538b62837c2a1de28fad9b3dcf6d0ee33560c20.tar.gz
gentoo-2-6538b62837c2a1de28fad9b3dcf6d0ee33560c20.tar.bz2
gentoo-2-6538b62837c2a1de28fad9b3dcf6d0ee33560c20.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/ChangeLog8
-rw-r--r--sci-electronics/kicad/kicad-20080914.1262.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 45d61cb71d79..6e0cea0bb804 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.33 2008/03/30 13:58:33 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.34 2008/09/18 08:28:35 calchan Exp $
+
+*kicad-20080914.1262 (18 Sep 2008)
+
+ 18 Sep 2008; Denis Dupeyron <calchan@gentoo.org>
+ +kicad-20080914.1262.ebuild:
+ Version bump.
30 Mar 2008; Denis Dupeyron <calchan@gentoo.org>
kicad-20080320.918.ebuild:
diff --git a/sci-electronics/kicad/kicad-20080914.1262.ebuild b/sci-electronics/kicad/kicad-20080914.1262.ebuild
new file mode 100644
index 000000000000..e7dbae4229cf
--- /dev/null
+++ b/sci-electronics/kicad/kicad-20080914.1262.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20080914.1262.ebuild,v 1.1 2008/09/18 08:28:35 calchan Exp $
+
+inherit versionator wxwidgets cmake-utils
+
+MY_PV="$(get_major_version)-r$(get_after_major_version)"
+
+DESCRIPTION="Electronic Schematic and PCB design tools."
+HOMEPAGE="http://kicad.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~calchan/distfiles/${PN}-${MY_PV}.tar.bz2
+ !minimal? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-library-${MY_PV}.tar.bz2 )
+ doc? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-doc-${MY_PV}.tar.bz2 )
+ examples? ( http://dev.gentoo.org/~calchan/distfiles/${PN}-examples-${MY_PV}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc debug examples minimal python"
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ dev-libs/boost
+ python? ( dev-lang/python )"
+RDEPEND="${DEPEND}
+ sys-libs/zlib"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ check_wxuse opengl
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use minimal ; then
+ sed -i -e "s:add_subdirectory(kicad-library):#add_subdirectory(kicad-library):" \
+ CMakeLists.txt || die "sed failed"
+ fi
+
+ if ! use doc ; then
+ sed -i -e "s:add_subdirectory(kicad-doc):#add_subdirectory(kicad-doc):" \
+ CMakeLists.txt || die "sed failed"
+ fi
+
+ if ! use examples ; then
+ sed -i -e "s:^add_subdirectory(demos):#add_subdirectory(demos):" \
+ CMakeLists.txt || die "sed failed"
+ fi
+}
+
+src_compile() {
+ cmakeargs="-DKICAD_MINIZIP=OFF"
+
+ if use python ; then
+ cmakeargs+=" -DKICAD_PYTHON=ON"
+ else
+ cmakeargs+=" -DKICAD_PYTHON=OFF"
+ fi
+
+ cmake-utils_src_compile
+}
+
+pkg_postinst() {
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you"
+ ewarn "open old projects, you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ fi
+ elog
+ elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
+}