summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-12-07 15:11:47 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-12-07 15:11:47 +0000
commit1ed43fbf633b6dabe35bec36d5a2d5ecb3bd34d3 (patch)
tree63bbb1748bc0740ff263ef042344def9700c6f2c /sci-electronics/linsmith
parentStable for HPPA (bug #446094). (diff)
downloadgentoo-2-1ed43fbf633b6dabe35bec36d5a2d5ecb3bd34d3.tar.gz
gentoo-2-1ed43fbf633b6dabe35bec36d5a2d5ecb3bd34d3.tar.bz2
gentoo-2-1ed43fbf633b6dabe35bec36d5a2d5ecb3bd34d3.zip
Version bump
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/ChangeLog7
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.24.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index 62eee01fbccc..2d2f0774b5eb 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/linsmith
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.12 2012/09/23 12:29:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.13 2012/12/07 15:11:46 tomjbe Exp $
+
+*linsmith-0.99.24 (07 Dec 2012)
+
+ 07 Dec 2012; Thomas Beierlein <tomjbe@gentoo.org> +linsmith-0.99.24.ebuild:
+ Version bump
23 Sep 2012; Agostino Sarubbo <ago@gentoo.org> linsmith-0.99.22.ebuild:
Stable for amd64, wrt bug #433902
diff --git a/sci-electronics/linsmith/linsmith-0.99.24.ebuild b/sci-electronics/linsmith/linsmith-0.99.24.ebuild
new file mode 100644
index 000000000000..56ef2a01cf34
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.24.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/linsmith-0.99.24.ebuild,v 1.1 2012/12/07 15:11:47 tomjbe Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use."
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809 || die
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO || die
+ doman doc/linsmith.1 || die
+
+ domenu linsmith.desktop || die
+ doicon linsmith_icon.xpm || die
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf || die
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}