summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-18 16:38:02 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-18 16:38:02 +0000
commit786c0eca1cbe6a648bd03558f3734606450073c2 (patch)
treef07b049155040ea52371eb5121ddce398bd59c5f /sci-electronics/qucs/qucs-0.0.17.130503.ebuild
parentCorrect cvs issue. (diff)
downloadgentoo-2-786c0eca1cbe6a648bd03558f3734606450073c2.tar.gz
gentoo-2-786c0eca1cbe6a648bd03558f3734606450073c2.tar.bz2
gentoo-2-786c0eca1cbe6a648bd03558f3734606450073c2.zip
Introduce a snapshot of Quite Universal Circuit Simulator, Qt4 version.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sci-electronics/qucs/qucs-0.0.17.130503.ebuild')
-rw-r--r--sci-electronics/qucs/qucs-0.0.17.130503.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-electronics/qucs/qucs-0.0.17.130503.ebuild b/sci-electronics/qucs/qucs-0.0.17.130503.ebuild
new file mode 100644
index 000000000000..b48045e99dd6
--- /dev/null
+++ b/sci-electronics/qucs/qucs-0.0.17.130503.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/qucs/qucs-0.0.17.130503.ebuild,v 1.1 2013/05/18 16:38:02 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Quite Universal Circuit Simulator in Qt4"
+HOMEPAGE="http://qucs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore[qt3support]
+ dev-qt/qtgui[qt3support]
+ dev-qt/qt3support
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ # the package doesn't use pkg-config on Linux, only on Darwin
+ # very smart of upstream...
+ append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
+ QtCore QtGui QtXml Qt3Support )
+
+ autotools-utils_src_configure
+}