summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-25 17:22:35 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-25 17:22:35 +0000
commit13aabb0802b6f028a0082b7e693b3b4e0cf3bd51 (patch)
treec202cd9aecfd798f57b408cee971be31034c488f /sci-electronics
parentsci-electronics/magic: -v (diff)
downloadgentoo-2-13aabb0802b6f028a0082b7e693b3b4e0cf3bd51.tar.gz
gentoo-2-13aabb0802b6f028a0082b7e693b3b4e0cf3bd51.tar.bz2
gentoo-2-13aabb0802b6f028a0082b7e693b3b4e0cf3bd51.zip
sci-electronics/balsa: Drop unnessecary die
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/balsa/ChangeLog8
-rw-r--r--sci-electronics/balsa/balsa-3.5.ebuild43
-rw-r--r--sci-electronics/balsa/balsa-4.0.ebuild26
-rw-r--r--sci-electronics/balsa/metadata.xml4
4 files changed, 40 insertions, 41 deletions
diff --git a/sci-electronics/balsa/ChangeLog b/sci-electronics/balsa/ChangeLog
index 7e2a8b9b4ea6..242a87693abf 100644
--- a/sci-electronics/balsa/ChangeLog
+++ b/sci-electronics/balsa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/balsa
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.15 2010/08/27 09:39:28 tomjbe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.16 2012/04/25 17:22:35 jlec Exp $
+
+ 25 Apr 2012; Justin Lecher <jlec@gentoo.org> balsa-3.5.ebuild,
+ balsa-4.0.ebuild, metadata.xml:
+ Drop unnessecary die
27 Aug 2010; Thomas Beierlein <tomjbe@gentoo.org>
+files/4.0-ldflags.patch, balsa-4.0.ebuild:
diff --git a/sci-electronics/balsa/balsa-3.5.ebuild b/sci-electronics/balsa/balsa-3.5.ebuild
index e33c528d0dab..22c622ad4a60 100644
--- a/sci-electronics/balsa/balsa-3.5.ebuild
+++ b/sci-electronics/balsa/balsa-3.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.5.ebuild,v 1.5 2010/06/27 04:33:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.5.ebuild,v 1.6 2012/04/25 17:22:35 jlec Exp $
EAPI="1"
@@ -36,7 +36,7 @@ RDEPEND="${DEPEND}
BALSA_TECH_AMS="balsa-tech-ams-20030506.tar.gz"
-if [ -f ${DISTDIR}/${BALSA_TECH_AMS} ]; then
+if [ -f "${DISTDIR}"/${BALSA_TECH_AMS} ]; then
TECH_AMS=1
fi
@@ -45,7 +45,7 @@ src_unpack() {
if [ $TECH_AMS ]; then
unpack ${BALSA_TECH_AMS}
fi
- sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I"${S}"/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
+ sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' "${S}"/bin/Makefile.in
sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' "${S}"/share/balsa/types/Makefile.in
sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' "${S}"/share/balsa/sim/Makefile.in
@@ -54,7 +54,7 @@ src_unpack() {
src_compile() {
# compile balsa
einfo "Compiling balsa"
- ./configure --prefix=/usr/ || die "econf failed"
+ ./configure --prefix=/usr/
chmod +x bin/balsa-config
PATH=$PATH:"${S}"/bin
emake -j1 || die
@@ -63,18 +63,18 @@ src_compile() {
if [ $TECH_AMS ]; then
einfo "Compiling AMS035 tech"
cd "${WORKDIR}"/balsa-tech-ams-20030506
- econf || die "econf failed"
+ econf
fi
# config Xilinx FPGA backend
einfo "Compiling Xilinx FPGA backend"
cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
- econf || die "econf failed"
+ econf
# config example tech
einfo "Compiling tech example"
cd "${WORKDIR}"/balsa-tech-example-${PV}
- econf || die "econf failed"
+ econf
# config verilog simulator wrappers
einfo "Compiling verilog simulator wrappers"
@@ -87,48 +87,45 @@ src_compile() {
src_install() {
# install balsa
- cd "${S}"
- einfo "Installing balsa"
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# install manual and examples
dodir /usr/share/doc/${P}/
- cp -pPR "${WORKDIR}"/BalsaExamples ${D}/usr/share/doc/${P}/
- dodoc ${DISTDIR}/BalsaManual${PV}.pdf
+ cp -pPR "${WORKDIR}"/BalsaExamples "${D}"/usr/share/doc/${P}/
+ dodoc "${DISTDIR}"/BalsaManual${PV}.pdf
if [ $TECH_AMS ]; then
einfo "Installing AMS035 tech"
cd "${WORKDIR}"/balsa-tech-ams-20030506
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
fi
einfo "Installing Xilinx FPGA tech"
cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
einfo "Installing example tech"
cd "${WORKDIR}"/balsa-tech-example-${PV}
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
einfo "Installing verilog simulator wrappers"
cd "${WORKDIR}"/balsa-sim-verilog-${PV}
- DESTDIR=${D} make install || die "make verilog wrappers failed"
+ DESTDIR="${D}" make install || die "make verilog wrappers failed"
# fix paths
- cd ${D}
+ cd "${D}"
einfo "Fixing paths"
find . -type f -exec sed -i -e "s:${D}::" {} \;
find . -name "sed*" -exec rm -f {} \;
# add some docs
cd "${S}"
- einfo "Installing docs"
- dodoc AUTHORS COPYING NEWS README TODO
- mv ${D}/usr/doc/* ${D}/usr/share/doc/${P}/
- rmdir ${D}/usr/doc
+ dodoc AUTHORS NEWS README TODO
+ mv "${D}"/usr/doc/* "${D}"/usr/share/doc/${P}/
+ rmdir "${D}"/usr/doc
# fix collisions
- rm -f ${D}/usr/bin/libtool
+ rm -f "${D}"/usr/bin/libtool
}
pkg_postinst() {
diff --git a/sci-electronics/balsa/balsa-4.0.ebuild b/sci-electronics/balsa/balsa-4.0.ebuild
index 8f2f23451b7c..f4a93681e040 100644
--- a/sci-electronics/balsa/balsa-4.0.ebuild
+++ b/sci-electronics/balsa/balsa-4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-4.0.ebuild,v 1.2 2010/08/27 09:39:28 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-4.0.ebuild,v 1.3 2012/04/25 17:22:35 jlec Exp $
EAPI="1"
@@ -33,7 +33,7 @@ RDEPEND="${DEPEND}
BALSA_TECH_AMS="balsa-tech-ams-20030506.tar.gz"
-if [ -f ${DISTDIR}/${BALSA_TECH_AMS} ]; then
+if [ -f "${DISTDIR}"/${BALSA_TECH_AMS} ]; then
TECH_AMS=1
fi
@@ -47,7 +47,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-datadir.patch
epatch "${FILESDIR}"/${PV}-ldflags.patch
eautoreconf
- sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I"${S}"/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
+ sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" "${WORKDIR}"/balsa-sim-verilog-${PV}/libs/Makefile.in
sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' "${S}"/bin/Makefile.in
sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' "${S}"/share/balsa/types/Makefile.in
sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' "${S}"/share/balsa/sim/Makefile.in
@@ -87,45 +87,43 @@ src_compile() {
--includedir="${S}"/src/libs/balsasim \
--with-icarus-includes=/usr/include \
--with-icarus-libs=/usr/$(get_libdir) \
- --with-cver-includes=/usr/include/cver_pli_incs || die
+ --with-cver-includes=/usr/include/cver_pli_incs
}
src_install() {
# install balsa
- einfo "Installing balsa"
- emake DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
if [ $TECH_AMS ]; then
einfo "Installing AMS035 tech"
cd "${WORKDIR}"/balsa-tech-ams-20030506
- emake DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
fi
einfo "Installing Xilinx FPGA tech"
cd "${WORKDIR}"/balsa-tech-xilinx-${PV}
- emake DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
einfo "Installing example tech"
cd "${WORKDIR}"/balsa-tech-example-${PV}
- emake DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
einfo "Installing verilog simulator wrappers"
cd "${WORKDIR}"/balsa-sim-verilog-${PV}
- DESTDIR=${D} emake install || die "make verilog wrappers failed"
+ DESTDIR="${D}" emake install || die "make verilog wrappers failed"
# fix paths
- cd ${D}
+ cd "${D}"
einfo "Fixing paths"
find . -type f -exec sed -i -e "s:${D}::" {} \;
find . -name "sed*" -exec rm -f {} \;
# add some docs
cd "${S}"
- einfo "Installing docs"
dodoc AUTHORS NEWS README TODO || die
# fix collisions
- rm -f ${D}/usr/bin/libtool || die
+ rm -f "${D}"/usr/bin/libtool || die
}
pkg_postinst() {
diff --git a/sci-electronics/balsa/metadata.xml b/sci-electronics/balsa/metadata.xml
index 6ab0e747a6f1..5e761826e5a7 100644
--- a/sci-electronics/balsa/metadata.xml
+++ b/sci-electronics/balsa/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-electronics</herd>
- <longdescription>
+ <herd>sci-electronics</herd>
+ <longdescription>
Balsa is an asynchronous circuit synthesis system developed over a number of
years at the APT group of the School Of Computer Science, The University of
Manchester. Balsa is built around the Handshake Circuits methology and can