summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-09 10:07:54 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-09 10:07:54 +0000
commit21a0f2313ae2ebf8223e2546e12108a3e7273f56 (patch)
treec35e243596c25610ea8cee84c55fc4bcac53ffd1 /sci-electronics
parentversion bump (diff)
downloadgentoo-2-21a0f2313ae2ebf8223e2546e12108a3e7273f56.tar.gz
gentoo-2-21a0f2313ae2ebf8223e2546e12108a3e7273f56.tar.bz2
gentoo-2-21a0f2313ae2ebf8223e2546e12108a3e7273f56.zip
Version bump, bug #204183.
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/geda/ChangeLog9
-rw-r--r--sci-electronics/geda/geda-1.4.0.ebuild100
2 files changed, 107 insertions, 2 deletions
diff --git a/sci-electronics/geda/ChangeLog b/sci-electronics/geda/ChangeLog
index e7289156847a..2421ae1513b4 100644
--- a/sci-electronics/geda/ChangeLog
+++ b/sci-electronics/geda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/geda
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.38 2007/09/19 11:50:32 calchan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/ChangeLog,v 1.39 2008/02/09 10:07:54 calchan Exp $
+
+*geda-1.4.0 (09 Feb 2008)
+
+ 09 Feb 2008; Denis Dupeyron <calchan@gentoo.org> +geda-1.4.0.ebuild:
+ Version bump, bug #204183.
19 Sep 2007; Denis Dupeyron <calchan@gentoo.org> geda-1.1.1.ebuild:
Fixed guile dependency.
diff --git a/sci-electronics/geda/geda-1.4.0.ebuild b/sci-electronics/geda/geda-1.4.0.ebuild
new file mode 100644
index 000000000000..a0603640a086
--- /dev/null
+++ b/sci-electronics/geda/geda-1.4.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/geda/geda-1.4.0.ebuild,v 1.1 2008/02/09 10:07:54 calchan Exp $
+
+inherit eutils versionator
+
+SUBDIR="v$(get_version_component_range 1-2)"
+S="${WORKDIR}"
+
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="Core metapackage for all the necessary components you would need for a minimal gEDA/gaf system"
+SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gattrib-${PV}.tar.gz
+ http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gnetlist-${PV}.tar.gz
+ http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gschem-${PV}.tar.gz
+ http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-gsymcheck-${PV}.tar.gz
+ http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-symbols-${PV}.tar.gz
+ http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-utils-${PV}.tar.gz
+ doc? ( http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-docs-${PV}.tar.gz )
+ examples? ( http://www.geda.seul.org/release/${SUBDIR}/${PV}/geda-examples-${PV}.tar.gz )"
+
+IUSE="doc examples gd threads"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-scheme/guile-1.6.3
+ =sci-libs/libgeda-${PV}"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8" ; then
+ built_with_use "dev-scheme/guile" deprecated \
+ || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
+ fi
+ if use gd ; then
+ built_with_use sci-libs/libgeda gd || die "sci-libs/libgeda must be compiled with USE=gd"
+ else
+ ! built_with_use sci-libs/libgeda gd || die "sci-libs/libgeda must be compiled with USE=-gd"
+ fi
+}
+
+src_compile() {
+ local myconf="--disable-threads"
+ use threads || myconf="--enable-threads=posix"
+ for subdir in geda-{symbols,gschem,gnetlist,gsymcheck,gattrib,utils}-${PV}; do
+ cd "${S}/${subdir}"
+ econf \
+ ${myconf} \
+ --disable-dependency-tracking \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-pcbconfdir=/usr/share/pcb \
+ --with-pcbm4dir=/usr/share/pcb/m4 \
+ --disable-update-desktop-database \
+ --disable-rpath \
+ --with-x \
+ || die "Configuration failed in ${subdir}"
+ emake || die "Compilation failed in ${subdir}"
+ done
+
+ if use doc ; then
+ cd "${S}/geda-docs-${PV}"
+ econf --with-docdir=/usr/share/doc/${PF} || die "Configuration failed in geda-docs-${PV}"
+ emake || die "Compilation failed in geda-docs-${PV}"
+ fi
+}
+
+src_install () {
+ for subdir in geda-{symbols,gschem,gnetlist,gsymcheck,gattrib,utils}-${PV}; do
+ cd "${S}/${subdir}"
+ emake DESTDIR="${D}" install || die "Installation failed in geda-${subdir}-${PV}"
+ newdoc AUTHORS AUTHORS.${subdir}
+ newdoc BUGS BUGS.${subdir}
+ for READMEx in $(ls README*); do
+ newdoc ${READMEx} ${READMEx}.${subdir}
+ done
+ done
+
+ rm "${D}"/usr/share/gEDA/sym/gnetman -Rf # Fix collision with gnetman; bug #77361.
+
+ if use doc ; then
+ cd "${S}"/geda-docs-${PV}
+ emake DESTDIR="${D}" install || die "Installation failed in geda-docs-${PV}"
+ fi
+
+ if use examples ; then
+ cd "${S}"
+ mv geda-examples-${PV} examples
+ insinto /usr/share/gEDA
+ doins -r examples
+ fi
+}
+
+src_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+src_postrm() {
+ fdo-mime_desktop_database_update
+}
+